Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » RSM 7.5 exports EMF UML2 XMI v3.x instead of v.2.x
RSM 7.5 exports EMF UML2 XMI v3.x instead of v.2.x [message #628046] Thu, 12 November 2009 07:44 Go to next message
No real name is currently offline No real name
Messages: 3
Registered: November 2009
Junior Member
Hi,

RSM/RSA 7.5.4 should be able to export into the EMF UML2 XMI v2.x format according to the data sheets and the export description. But the exported *.uml file references the v.3.x namespace: xmlns:uml="http://www.eclipse.org/uml2/3.0.0/UML

The uml2 libraries are of version 2.2.2.

What is the real version of the exported XMI? How can it be recognized?

thanks
Michael
Re: RSM 7.5 exports EMF UML2 XMI v3.x instead of v.2.x [message #628050 is a reply to message #628046] Thu, 12 November 2009 10:09 Go to previous message
Rafael Chaves is currently offline Rafael Chaves
Messages: 362
Registered: July 2009
Senior Member
Michael, the latest release of the UML2 project is 3.0.x (since July,
released as part of Eclipse Galileo). Maybe you have UML2 3.0 installed
instead of UML2 2.2?

tmik@gmx-topmail.de wrote:
> Hi,
>
> RSM/RSA 7.5.4 should be able to export into the EMF UML2 XMI v2.x format
> according to the data sheets and the export description. But the
> exported *.uml file references the v.3.x namespace:
> xmlns:uml="http://www.eclipse.org/uml2/3.0.0/UML
>
> The uml2 libraries are of version 2.2.2.
>
> What is the real version of the exported XMI? How can it be recognized?
>
> thanks
> Michael
Previous Topic:Applying stereotype to a model which is not contained in a resource yet?
Next Topic:Applying stereotype programmatically fails
Goto Forum:
  


Current Time: Thu Aug 28 03:31:28 EDT 2014

Powered by FUDForum. Page generated in 0.04171 seconds