Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Context Sensitive Help problems
Context Sensitive Help problems [message #623540] Thu, 03 September 2009 15:13 Go to next message
Chris Phelps is currently offline Chris Phelps
Messages: 2
Registered: September 2009
Junior Member
We are trying to develop context-sensitive help for our RCP application,
and are running into a number of issues. For some of our views, our
documentation is correct and functional. For others, however, we see a
variety of behaviors.

- One view produces the correct help content when it gains focus from
another view, but does not provide the correct help when you press F1 on
the view directly.

- Another view does not find content when F1'd, and shows the help
content from a previous view when it gains focus from that view. The
"About View Name" header is correct for this view, but the content remains
that of the previous view.

- Some of our malfunctioning views display the "Each workbench window
contains..." message, while others contain the "Click on any workbench
part..." message.

We have examined all the code for these plugins, and the help context
seems to be set correctly (the
PlatformUI.getWorkbench().getHelpSystem().setHelp() is called from the
view's createPartControl()). The context.xml and plugin.xml for the
documentation plugin seems correct and well-formed. Using the Plug-In
spy, the active help context ID matches up with the ID in the context.xml.


Finally, we have tried deploying this help plugin both in an Infocenter
and locally, and have tried both .jar format and as a folder structure.
In all cases, the behavior is similar.

Has anyone seen similar behaviors, or have any suggestions on other things
we should try?

Thanks very much
Chris
Re: Context Sensitive Help problems [message #740255 is a reply to message #623540] Tue, 18 October 2011 10:08 Go to previous message
thomasr Missing name is currently offline thomasr Missing name
Messages: 6
Registered: December 2010
Junior Member

Hi chris,
its been a while ago when you raised this question. Did you find a solution for this behaviour ? I'm currently facing exactly the same issue.
Thank you
Previous Topic:Searching in help does not work
Next Topic:context help showing wrong content
Goto Forum:
  


Current Time: Wed Sep 17 17:42:36 GMT 2014

Powered by FUDForum. Page generated in 0.01952 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software