Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Context-sensitive help on wizard dialogs: sometimes appears, sometimes not
Context-sensitive help on wizard dialogs: sometimes appears, sometimes not [message #623259] Tue, 24 March 2009 19:05
Mike Yawn is currently offline Mike YawnFriend
Messages: 50
Registered: July 2009
Member
I have context sensitive help pages assigned to each page of a
multi-page wizard dialog.

Sometimes the wizard pages will appear when the (?) is clicked, and
other times they do not. When they do not appear, there doesn't seem
to be any indication of a problem (nothing written to log file) -- it's
just as if there was no help for that page.

I haven't yet figured out exactly what the pattern is. However, a few
things I've noticed:

- If a help page appears fine, and I close it, and then go to the next
page in the wizard -- if I hit 'Back' to return to the page and try to
display the help again, it frequently does not appear.
- If a file page does not appear, and I go to a previous page in the
wizard and bring up help there, and then hit Next >, then the help
page for the next dialog page (which couldn't be brought up using the
(?) button) will be loaded when navigating to the page.

So there seems to be some weird connection between wizard navigation and
help page loading that is different than just loading the help for the
"current" wizard page.

Any ideas?
Thanks,
Mike
Previous Topic:Minimize of "Welcome Page" leads to a perspective without a toolbar
Next Topic:Can Infocenter display files other than HTML and PDF?
Goto Forum:
  


Current Time: Fri Dec 19 11:48:24 GMT 2014

Powered by FUDForum. Page generated in 0.01770 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software