Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Feature build.xml not generated in headless build
Feature build.xml not generated in headless build [message #602888] Sun, 25 October 2009 08:28 Go to next message
Franck Mising name is currently offline Franck Mising nameFriend
Messages: 91
Registered: July 2009
Location: France
Member
I am trying to set up a PDE headless build for a feature, and the build fails in the genericTargets.xml cleanElement target.

That target tries to invoke a clean target in the feature/build.xml file which generateScripts has not generated - generateScripts only generates build.xml files for each plugin that make up the feature, but not for the feature itself.

Is generateScripts supposed to generate a feature build.xml? Or do I need to adjust something build.properties so that the build stops looking for that file?
If I right-click feature.xml in the IDE and select "PDE Tools -> generate ant build file" the same thing happens, I get one build.xml file per plugin but not for the feature itself.

By build.properties file is below, any suggestion appreciated!

------------------------------------------------------------ ------------------------

topLevelElementType = feature

topLevelElementId = com.fairisaac.eclipse.features.advisor

#product=/plugin or feature id/path/to/.product
runPackager=true

#archiveNamePrefix=
archivePrefix=eclipse
collectingFolder=${archivePrefix}
configs = *, *, *
allowBinaryCycles = true
outputUpdateJars = true

zipargs=
tarargs=

buildDirectory=C:/eclipse
buildType=I
buildId=Nightly
buildLabel=${buildType}.${buildId}
timestamp=007

base=C:/
baseLocation=${base}/galileo

baseos=win32
basews=win32
basearch=x86

filteredDependencyCheck=false

resolution.devMode=false

#pluginPath=

skipBase=true
eclipseURL=<url for eclipse download site>
eclipseBuildId=<Id of Eclipse build to get>
eclipseBaseURL=${eclipseURL}/eclipse-platform-${eclipseBuild Id}-win32.zip

skipMaps=true
mapsRepo=:pserver:mailto:anonymous@example.com/path/to/repo
mapsRoot=path/to/maps
mapsCheckoutTag=HEAD
mapsTagTag=v${buildId}

skipFetch=true

logExtension=.log
javacDebugInfo=false
javacFailOnError=true
javacVerbose=true
Re: Feature build.xml not generated in headless build [message #602892 is a reply to message #602888] Sun, 25 October 2009 10:31 Go to previous message
Franck Mising name is currently offline Franck Mising nameFriend
Messages: 91
Registered: July 2009
Location: France
Member
Found the issue, build.properties was missing in the feature directory which causes the PDE Build to consider the feature as binary.
Previous Topic:Feature build.xml not generated in headless build
Next Topic:Is it possible to set plugin and feature versions from ant build?
Goto Forum:
  


Current Time: Mon Dec 22 10:11:57 GMT 2014

Powered by FUDForum. Page generated in 0.01581 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software