Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Error running PDE project
Error running PDE project [message #567535] Thu, 29 May 2008 08:16
Eclipse User
Originally posted by: xxx.yyy.zz

Hi,
I'm reading MBS document and creating a new C toolchain PDE project.
When I run as Eclipse Application to test the ProjectType I receive the
errors:

!SESSION 2008-05-27
20:50:31.593 -----------------------------------------------

eclipse.buildId=I20070625-1500
java.version=1.6.0_05
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=it_IT
Framework arguments: -product org.eclipse.sdk.ide
Command-line arguments: -product org.eclipse.sdk.ide -data
C:\Progetti\iar/../runtime-EclipseApplication -dev
file:C:/Progetti/iar/.metadata/.plugins/org.eclipse.pde.core /Eclipse
Application/dev.properties -os win32 -ws win32 -arch x86


!ENTRY org.eclipse.osgi 4 0 2008-05-27 20:50:34.798
!MESSAGE Error installing bundle:
reference:file:plugins/org.eclipse.equinox.common_3.3.0.v200 70426.jar/
!STACK 0

org.osgi.framework.BundleException: Bundle "org.eclipse.equinox.common"
version "3.3.0.v20070426" has already been installed from:
update@plugins/org.eclipse.equinox.common_3.3.0.v20070426.jar

at
org.eclipse.osgi.framework.internal.core.Framework.createAnd VerifyBundle(Fra
mework.java:642)
at
org.eclipse.osgi.framework.internal.core.Framework.installWo rkerPrivileged(F
ramework.java:909)
at
org.eclipse.osgi.framework.internal.core.Framework$2.run(Fra mework.java:824)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.Framework.installWo rker(Framework.j
ava:875)
at
org.eclipse.osgi.framework.internal.core.Framework.installBu ndle(Framework.j
ava:819)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.i nstallBundle(Bun
dleContextImpl.java:229)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.installBundl es(EclipseStarte
r.java:1064)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBun dles(EclipseStar
ter.java:621)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.startup(Ecli pseStarter.java:
303)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:172)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
at org.eclipse.equinox.launcher.Main.main(Main.java:1148)


!ENTRY org.eclipse.osgi 4 0 2008-05-27 20:50:34.828
!MESSAGE Error installing bundle:
reference:file:plugins/org.eclipse.core.runtime_3.3.100.v200 70530.jar/

!STACK 0

org.osgi.framework.BundleException: Bundle "org.eclipse.core.runtime"
version "3.3.100.v20070530" has already been installed from:
update@plugins/org.eclipse.core.runtime_3.3.100.v20070530.jar

at
org.eclipse.osgi.framework.internal.core.Framework.createAnd VerifyBundle(Fra
mework.java:642)
at
org.eclipse.osgi.framework.internal.core.Framework.installWo rkerPrivileged(F
ramework.java:909)
at
org.eclipse.osgi.framework.internal.core.Framework$2.run(Fra mework.java:824)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.Framework.installWo rker(Framework.j
ava:875)
at
org.eclipse.osgi.framework.internal.core.Framework.installBu ndle(Framework.j
ava:819)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.i nstallBundle(Bun
dleContextImpl.java:229)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.installBundl es(EclipseStarte
r.java:1064)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBun dles(EclipseStar
ter.java:621)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.startup(Ecli pseStarter.java:
303)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:172)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
at org.eclipse.equinox.launcher.Main.main(Main.java:1148)

!ENTRY org.eclipse.osgi 4 0 2008-05-27 20:50:35.859
!MESSAGE Application error
!STACK 1

java.lang.IllegalStateException: Unable to acquire application service.
Ensure that the org.eclipse.core.runtime bundle is resolved and started (see
config.ini).

at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAp
pLauncher.java:72)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:363)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
at org.eclipse.equinox.launcher.Main.main(Main.java:1148)


Please, can anyone explain them?
Thanks
--
SteM
Previous Topic:Error running PDE project
Next Topic:Actions and Commands
Goto Forum:
  


Current Time: Sun Sep 21 18:19:01 GMT 2014

Powered by FUDForum. Page generated in 0.05777 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software