Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Eclipse won't execute PHP.
Eclipse won't execute PHP. [message #555774] Sat, 28 August 2010 13:33 Go to next message
Liam  is currently offline Liam
Messages: 3
Registered: August 2010
Junior Member
Hello.

If have seen a couple posts of folks having the same issue as I, but there is no resolution to those posts so I though I'd give it a try. I have Eclipse/PDT/Zend Debug working fine on my Linux desktop, but for some reason I am having difficulty with Windows XP sp3.

The problem on the Windows machine:

When I attempt to run a *.php as a script or as a web page I get a failure. When I attempt to run *.php files as a script I get...

"Error launching 'phpinfo.php'

The session could not be started.
In order to generate debug information, please make sure that the debugger is properly configured as a php.ini directive.

When I attempt to run a *.php as a web page from within Eclipse I get a 404, but the URL is correct e.g. http://localhost/phpinfo.php. If I actually copy the phpinfo.php to the docroot of Apache it works fine.

Under: Window>Preferences>PHP>PHP Executable
I believe I have correct information:

Execution Path: C:\PHP\php.exe
PHP in file: C:\PHP\php.ini
SAPI: CLI
PHP debugger: Zend Debugger

Any help would be much appreciated!

Liam
Re: Eclipse won't execute PHP. [message #555845 is a reply to message #555774] Sun, 29 August 2010 14:13 Go to previous messageGo to next message
Liam  is currently offline Liam
Messages: 3
Registered: August 2010
Junior Member
Hello,

I have a suspicion that Eclipse isn't reading the php.ini for some reason. While I do have it configured within Window>Preferences>PHP>Executables, if I drop the php.ini information from the Executable config I get the same exception, if I leave the php.ini directive in the executable config and rename the php.ini I also still get the same exception.

The exception:
"Error launching 'phpinfo' The session could not be started. In order to generate debug information, please make sure that the debugger is properly configured as a php.ini directive"

Although...
In my php-error.log I do get the following exception which tells me the php.exe is reading the php.ini file (as this is where the php-error.log is configured, but perhaps this is a default directory for the file?). I believe the exception itself is benign.

The exception:
[29-Aug-2010 09:49:33] PHP Warning: phpinfo(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for '-4.0/DST' instead in C:\Documents and Settings\me\Desktop\My_Work_Documents\eclipse\workspace\lptp hp\phpinfo2.php on line 2

Thanks for the help.

Liam
Re: Eclipse won't execute PHP. [message #556136 is a reply to message #555845] Tue, 31 August 2010 00:19 Go to previous message
Liam  is currently offline Liam
Messages: 3
Registered: August 2010
Junior Member
Well I believe I am making some forward progress. I downloaded the Zend PDT distribution and it worked without issue.

I also pointed the executable definition from my original distribution from eclipse.org (Window>Preferences>PHP>Executables) to the zend php-cgi.exe and php.ini and it started working. When I ran phpinfo(); for this binary I noticed that the zend version was 5.3.2 and it was the VC9 build.

So at this point I downloaded the 5.3.2 VC9 x86 build for windows from the php.net archives to see if the issue was with 5.3.3, but once again I ran into the same issue when I try to run any php file as a script telling me I need to point to a valid php.ini!

Is anyone out there using the 5.3.3 VC9 x86 build from php.net with eclipse?

Thanks

-Liam
Previous Topic:2.2 Plugin not being loaded
Next Topic:External Lib not seen
Goto Forum:
  


Current Time: Sun Oct 26 08:49:13 GMT 2014

Powered by FUDForum. Page generated in 0.01727 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software