Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » No ant console output -Eclipse Helios
icon9.gif  No ant console output -Eclipse Helios [message #552232] Wed, 11 August 2010 11:33 Go to next message
No real name is currently offline No real name
Messages: 1
Registered: August 2010
Junior Member
Hi !
I'm a newbie and hope i posted my question in the correct forum.

i downloaded eclipse Helios to replace eclipse ganymede.

when i make a java project with a ant build script and run the ant script ( it's a simple script ) i don't get any out put in the console. But when i run ant in ganymede version the script makes an output in the console.

I found this in the log file,
Quote:

!SESSION 2010-08-11 13:15:36.063 -----------------------------------------------
eclipse.buildId=I20100608-0911
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=sv_SE
Framework arguments: -product org.eclipse.epp.package.jee.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product

!ENTRY org.eclipse.ant.launching 4 120 2010-08-11 13:17:06.603
!MESSAGE Error logged from Ant UI:
!STACK 0
java.net.SocketTimeoutException: Accept timed out
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.PlainSocketImpl.accept(Unknown Source)
at java.net.ServerSocket.implAccept(Unknown Source)
at java.net.ServerSocket.accept(Unknown Source)
at org.eclipse.ant.internal.launching.launchConfigurations.Remo teAntBuildListener$ServerConnection.run(RemoteAntBuildListen er.java:89)



I tried to search and see if some one have had the same problem but couldn't find any.

I tried to use external ANT (1.80) but it gives no output either.

Please need help, anyone...

Re: No ant console output -Eclipse Helios [message #555178 is a reply to message #552232] Wed, 25 August 2010 17:29 Go to previous messageGo to next message
Richard Ferris is currently offline Richard Ferris
Messages: 1
Registered: August 2010
Junior Member
I ran into the same problem and found a work-around:

1. Go to Project-Properties-Builders.
2. Select your builder and Edit.
3. Click on the Build Options tab.
4. Allocate a file for the log and de-select the "Launch in background" option.
5. Go to Window-Preferences-Run/Debug-Console
6. De-select the "Limit console output" option.

Some subset of these steps would probably work, but there you have it.
Re: No ant console output -Eclipse Helios [message #559667 is a reply to message #552232] Fri, 17 September 2010 14:34 Go to previous message
André is currently offline André
Messages: 1
Registered: September 2010
Junior Member
This has got to be some bug.

When I execute HelloWorld.exe in the command line I get the usual ouput.

However, through Eclipse I can't see any output.
Previous Topic:[Moved] Help Contents on Standalone Help Eclipse
Next Topic:Create new launchConfigurationType problem
Goto Forum:
  


Current Time: Sat Oct 25 23:01:31 GMT 2014

Powered by FUDForum. Page generated in 0.02121 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software