Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Missing requirement org.eclipse.cor.runtime
Missing requirement org.eclipse.cor.runtime [message #550024] Wed, 28 July 2010 15:20 Go to next message
Nitesh Verma is currently offline Nitesh Verma
Messages: 3
Registered: July 2010
Junior Member
Hi,

i am trying to install Black Berry web pluggin in Eclipse Helios
but i am getting the following error of missing dependencies:

Cannot complete the install because one or more required items could not be found.
Software being installed: BlackBerry Web Development Plug-in 1.0.0.200907241249-33 (net.rim.browser.tools.feature.feature.group 1.0.0.200907241249-33)
Missing requirement: BlackBerry Web Development Plug-in 1.0.0.200907241249-33 (net.rim.browser.tools.feature.feature.group 1.0.0.200907241249-33) requires 'org.eclipse.core.runtime [3.4.0,3.5.0)' but it could not be found


can anyone help

Thanks in advance,
Nitesh
Re: Missing requirement org.eclipse.cor.runtime [message #550038 is a reply to message #550024] Wed, 28 July 2010 16:11 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 25919
Registered: July 2009
Senior Member
Nitesh,

Apparently that plugin declares that it just won't work with version 3.5
or higher of the core runtime so you shouldn't expect to install it in
Helios or Galileo.


Nitesh Verma wrote:
> Hi,
>
> i am trying to install Black Berry web pluggin in Eclipse Helios
> but i am getting the following error of missing dependencies:
>
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: BlackBerry Web Development Plug-in
> 1.0.0.200907241249-33 (net.rim.browser.tools.feature.feature.group
> 1.0.0.200907241249-33)
> Missing requirement: BlackBerry Web Development Plug-in
> 1.0.0.200907241249-33 (net.rim.browser.tools.feature.feature.group
> 1.0.0.200907241249-33) requires 'org.eclipse.core.runtime
> [3.4.0,3.5.0)' but it could not be found
>
>
> can anyone help
> Thanks in advance,
> Nitesh
Re: Missing requirement org.eclipse.cor.runtime [message #550044 is a reply to message #550038] Wed, 28 July 2010 16:58 Go to previous messageGo to next message
Nitesh Verma is currently offline Nitesh Verma
Messages: 3
Registered: July 2010
Junior Member
Thanks for your quick reply.

In the plugin website it is given that the requirement is eclipse 3.5

http://na.blackberry.com/eng/developers/browserdev/eclipsepl ugin.jsp

how can i have org.eclipse.core.runtime in my eclipse.
and if it is present how can i check..
Re: Missing requirement org.eclipse.cor.runtime [message #550064 is a reply to message #550044] Wed, 28 July 2010 22:03 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 25919
Registered: July 2009
Senior Member
Nitesh,

The message requires 'org.eclipse.core.runtime [3.4.0,3.5.0)' tells me
that the inclusive lower bound in 3.4.0 and the exclusive upper bound is
3.5.0 so that sounds like the Ganymede version of Eclipse, i.e., the 3.4
release. So to me, whatever you're installing will only install into
Ganymede.

Use Help->About Eclipse SDK->Installation Details->Plug-ins to see what
plugin versions are in your installation.


Nitesh Verma wrote:
> Thanks for your quick reply.
>
> In the plugin website it is given that the requirement is eclipse 3.5
>
> http://na.blackberry.com/eng/developers/browserdev/eclipsepl ugin.jsp
>
> how can i have org.eclipse.core.runtime in my eclipse.
> and if it is present how can i check..
Re: Missing requirement org.eclipse.cor.runtime [message #550362 is a reply to message #550064] Fri, 30 July 2010 02:18 Go to previous message
Nitesh Verma is currently offline Nitesh Verma
Messages: 3
Registered: July 2010
Junior Member
Thanks Ed Merks.

Its working on Ganymede version of Eclipse.
Previous Topic:Failed to run RCP application after migration from eclipse 3.1 to eclipse 3.2
Next Topic:Cannot get Eclipse Helios to run on windows 7 with Java
Goto Forum:
  


Current Time: Fri Jul 25 14:33:59 EDT 2014

Powered by FUDForum. Page generated in 0.02072 seconds