Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse.exe will not start after editing eclipse.ini
Eclipse.exe will not start after editing eclipse.ini [message #549071] Fri, 23 July 2010 20:45 Go to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 4
Registered: July 2010
Junior Member
Hello all! I would just like to start by saying that I am very new to Eclipse. What I want is the Eclipse for PHP Developers. Here is as much information as I can think of (without being overwhelming). If you need more, Please ask me. I really want to solve this. Thanks!

I am running Windows Vista Home Premium 64bit. This is on HP pavillion m9458f.

I began by downloading the eclipse-php-helios-win32-x86_64.zip for Windows 64bit and saving it to my desktop ( http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/helios/R/eclipse-php-helios-win32-x 86_64.zip&url=http://mirror.csclub.uwaterloo.ca/eclipse/ technology/epp/downloads/release/helios/R/eclipse-php-helios -win32-x86_64.zip&mirror_id=492). I then extracted it by right-clicking and choosing "Extract all..." to C:\Program Files. It automatically created the eclipse folder in that directory.

After getting the error "A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations...", I discovered that I have to modify my eclipse.ini file to include the following lines (http://wiki.eclipse.org/Eclipse.ini).
-vm
C:\Program Files (x86)\Java\jre6\bin\javaw.exe

Here is what eclipse.ini now looks like:

Quote:
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1. 0.v20100503
-product
org.eclipse.epp.package.php.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vm
C:\Program Files (x86)\Java\jre6\bin\javaw.exe
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx384m


The javaw.exe file version is 6.0.200.2 I have also tried linking it to the 6.0.10.7 version included in C:\Program Files (x86)\Java\jre1.6.0_01\bin

The problem: eclipse will not start. There are no error messages since I edited eclipse.ini. If I can provide any more information or if I have forgotten something, please let me know. Thank you!

P.S. I have checked out this page: http://wiki.eclipse.org/FAQ_I_unzipped_Eclipse,_but_it_won't _start._Why%3F and do not think that I have done anything wrong except possible number 2 (bad VM). I don't know if I am using a 32 or 64 bit version of JVM. How can I tell? Thanks!

[Updated on: Fri, 23 July 2010 21:11]

Report message to a moderator

Re: Eclipse.exe will not start after editing eclipse.ini [message #549078 is a reply to message #549071] Sat, 24 July 2010 01:22 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 1
Registered: July 2010
Junior Member
I had the same problem as you have. You might need to download JRE 64 bit version, assuming you are installing Helios 64bit. Links below has helped me solving the problem. I hope they will help you too. Good luck
https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_De veloper-Site/en_US/-/USD/ViewFilteredProducts-SingleVariatio nTypeFilter
http://stackoverflow.com/questions/2030434/eclipse-no-java-j re-jdk-no-virtual-machine
http://www.eclipse.org/forums/index.php?t=msg&goto=54294 0&
Re: Eclipse.exe will not start after editing eclipse.ini [message #549123 is a reply to message #549071] Sat, 24 July 2010 17:48 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3133
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2010.07.23 18:45, listedegarde@gmail.com wrote:
> Hello all! I would just like to start by saying that I am very new to
> Eclipse. What I want is the Eclipse for PHP Developers. Here is as much
> information as I can think of (without being overwhelming). If you need
> more, Please ask me. I really want to solve this. Thanks!
>
> I am running Windows Vista Home Premium 64bit. This is on HP pavillion
> m9458f.
>
> [snip]
>> plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1. 0.v20100503
>> -product
>> org.eclipse.epp.package.php.product
>> --launcher.defaultAction
>> openFile
>> --launcher.XXMaxPermSize
>> 256M
>> -showsplash
>> org.eclipse.platform
>> --launcher.XXMaxPermSize
>> 256m
>> -vm
>> C:\Program Files (x86)\Java\jre6\bin\javaw.exe
>> --launcher.defaultAction
>> openFile
>> -vmargs
>> -Dosgi.requiredJavaVersion=1.5
>> -Xms40m
>> -Xmx384m
>
>
> [snip]

Note that you must either use Eclipse 32 bit and a 32-bit JDK, or
Eclipse 64=bit and a 64-bit JDK. You can't mix the two worlds. By the
way, a 32-bit set works fine on a 64-bit Windows or Linux. I have so far
resisted moving to using 64-bit (too lazy).
Re: Eclipse.exe will not start after editing eclipse.ini [message #549425 is a reply to message #549123] Mon, 26 July 2010 11:28 Go to previous messageGo to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 4
Registered: July 2010
Junior Member
Thank you, both of you. Were you able to tell from the information that I sent that I was using a 32 bit JDK/JRE?

I'm downloading the 32bit eclipse for PHP, and I'll let you know how it goes.

Again, thanks a million for the help. It's really appreciated.
Re: Eclipse.exe will not start after editing eclipse.ini [message #549445 is a reply to message #549425] Mon, 26 July 2010 12:10 Go to previous messageGo to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 4
Registered: July 2010
Junior Member
All right, all seems to work! Thank you again!

Now all I have to do is figure out how it works. I thought that I was going to be able to see my PHP web page somewhere like in a browser, but haven't found out how to yet.
Re: Eclipse.exe will not start after editing eclipse.ini [message #549452 is a reply to message #549445] Mon, 26 July 2010 12:46 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3133
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 7/26/2010 10:10 AM, Liste wrote:
> All right, all seems to work! Thank you again!
>
> Now all I have to do is figure out how it works. I thought that I was
> going to be able to see my PHP web page somewhere like in a browser, but
> haven't found out how to yet.

Try the PHP (PDT) forum for Eclipse and find a simple tutorial
somewhere. An hour or so of that will probably finish leveling your
obstacles.
Re: Eclipse.exe will not start after editing eclipse.ini [message #549513 is a reply to message #549452] Mon, 26 July 2010 21:37 Go to previous message
Missing name Missing name is currently offline Missing name Missing name
Messages: 4
Registered: July 2010
Junior Member
OK. Thank you so much, Russell! I figured out that i didn't have Zend installed. I'm learning things, though! Thank you again for your help!
Previous Topic:Problem In Updating RFT 8.1.1 With Existing Eclipse
Next Topic:custom wizard does not appear
Goto Forum:
  


Current Time: Tue Jul 29 06:54:21 EDT 2014

Powered by FUDForum. Page generated in 0.01695 seconds