Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Nebula » TableCombo not showing up in Palette & CalendarCombo Bug?(after dropping the plugin and features folder nothing shows up)
TableCombo not showing up in Palette & CalendarCombo Bug? [message #547655] Mon, 19 July 2010 05:41 Go to next message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
i downloaded the component from
http://www.eclipse.org/downloads/download.php?file=/technolo gy/nebula/tablecombo/downloads/drops/latest/nebula-tablecomb o-ALL-incubation.zip
and unzipped it to my eclipse folder (i did the same with the CalendarCombo)
the control is now not showing up.
NOTE that the CalendarCombo does show up!

CalendarCombo is version 1.0.0
and
TableCombo is version 1.0.0.HEAD

any ideas?

another note is that the CalendarCombo throws an nullpointerexception whenever i click on the NONE button AFTER i clicked on the TODAY button (its working fine when you click on the NONE button at first - empty field)
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #547660 is a reply to message #547655] Mon, 19 July 2010 05:56 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
Hi,

TableCombo and CalendarCombo have nothing in common. I'm not sure what
you expect to show up. When you download and unzip you have an
eclipse/plugins/org.eclipse.nebula.widgets.tablecombo_1.0.0. HEAD.jar
which holds the binaries.

Tom

Am 19.07.10 11:41, schrieb Ludwig Moser:
> i downloaded the component from
> http://www.eclipse.org/downloads/download.php?file=/technolo gy/nebula/tablecombo/downloads/drops/latest/nebula-tablecomb o-ALL-incubation.zip
>
> and unzipped it to my eclipse folder (i did the same with the
> CalendarCombo)
> the control is now not showing up.
> NOTE that the CalendarCombo does show up!
>
> CalendarCombo is version 1.0.0
> and
> TableCombo is version 1.0.0.HEAD
>
> any ideas?
>
> another note is that the CalendarCombo throws an nullpointerexception
> whenever i click on the NONE button AFTER i clicked on the TODAY button
> (its working fine when you click on the NONE button at first - empty field)
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #547664 is a reply to message #547660] Mon, 19 July 2010 06:14 Go to previous messageGo to next message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
i know that they do not have anything in common (but the way you 'install' em).

so i expected both to show up (in my IDE) after unpacking them and restarting eclipse - but only one of them does (and i cannot include the TableCombo manually too)
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #547671 is a reply to message #547664] Mon, 19 July 2010 06:24 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
Hi,

Installing them is not really a good idea IMHO because they don't add
functionality to your IDE. You should hold them in your target.

Tom

Am 19.07.10 12:14, schrieb Ludwig Moser:
> i know that they do not have anything in common (but the way you
> 'install' em).
>
> so i expected both to show up (in my IDE) after unpacking them and
> restarting eclipse - but only one of them does (and i cannot include the
> TableCombo manually too)
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #547676 is a reply to message #547671] Mon, 19 July 2010 06:42 Go to previous messageGo to next message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
ok, i removed it from the ide.
added the jars now.
adding the components to the palette by hand.
0) right-click on the palette
1) import jar...
2) selecting the jar on FS.
3) message pops up that the MANIFEST.MF is incorrect/empty. -> show all classes - i select yes
4) pick the TableCombo.class as the class i want to add. -> OK
5) nothing happens.

when i do exactly the same with the CalendarCombo it shows up in my palette, so it cant be completely wrong what i do...

EDIT: i just saw in the palette manager that the TableCombo is marked as
java.lang.ClassNotFoundException: org.eclipse.nebula.widgets.tablecombo.TableCombo
but its selected out of the ide which means it should only show what really exists...

come on man.
i just checked:
1) palette manager
2) import jar
3) do the exactly same stuff as above! and now it works
wtf?

so the only thing left is the nullpointer exception in the CalendarCombo...

PS: Thanks for your patience...

[Updated on: Mon, 19 July 2010 06:49]

Report message to a moderator

Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #547689 is a reply to message #547676] Mon, 19 July 2010 07:18 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
That's strange because when looking at the content of MANIFEST.MF looks ok.

Tom

Am 19.07.10 12:42, schrieb Ludwig Moser:
> ok, i removed it from the ide.
> added the jars now.
> adding the components to the palette by hand.
> 1) import jar...
> 2) selecting the jar on FS.
> 3) message pops up that the MANIFEST.MF is incorrect/empty. -> show all
> classes - i select yes
> 4) pick the TableCombo.class as the class i want to add. -> OK
> 5) nothing happens.
>
> when i do exactly the same with the CalendarCombo it shows up in my
> palette, so it cant be completely wrong what i do...
>
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #547995 is a reply to message #547689] Tue, 20 July 2010 07:03 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
Just installed the nightly build into my Eclipse 3.6 all is looking fine.

Tom

Am 19.07.10 13:18, schrieb Tom Schindl:
> That's strange because when looking at the content of MANIFEST.MF looks ok.
>
> Tom
>
> Am 19.07.10 12:42, schrieb Ludwig Moser:
>> ok, i removed it from the ide.
>> added the jars now.
>> adding the components to the palette by hand.
>> 1) import jar...
>> 2) selecting the jar on FS.
>> 3) message pops up that the MANIFEST.MF is incorrect/empty. -> show all
>> classes - i select yes
>> 4) pick the TableCombo.class as the class i want to add. -> OK
>> 5) nothing happens.
>>
>> when i do exactly the same with the CalendarCombo it shows up in my
>> palette, so it cant be completely wrong what i do...
>>
>
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #548200 is a reply to message #547995] Wed, 21 July 2010 01:12 Go to previous messageGo to next message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
i'm on 3.5 Galileo
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #548562 is a reply to message #548200] Thu, 22 July 2010 07:10 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
Is there something in the .metadata/.log which give a bit more
informations on what's going wrong?

Tom

Am 21.07.10 07:12, schrieb Ludwig Moser:
> i'm on 3.5 Galileo
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #548792 is a reply to message #548562] Fri, 23 July 2010 01:13 Go to previous messageGo to next message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
nope there is neither 'nebula' nor 'combo' anywhere in the log.
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #599962 is a reply to message #547655] Mon, 19 July 2010 05:56 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
Hi,

TableCombo and CalendarCombo have nothing in common. I'm not sure what
you expect to show up. When you download and unzip you have an
eclipse/plugins/org.eclipse.nebula.widgets.tablecombo_1.0.0. HEAD.jar
which holds the binaries.

Tom

Am 19.07.10 11:41, schrieb Ludwig Moser:
> i downloaded the component from
> http://www.eclipse.org/downloads/download.php?file=/technolo gy/nebula/tablecombo/downloads/drops/latest/nebula-tablecomb o-ALL-incubation.zip
>
> and unzipped it to my eclipse folder (i did the same with the
> CalendarCombo)
> the control is now not showing up.
> NOTE that the CalendarCombo does show up!
>
> CalendarCombo is version 1.0.0
> and
> TableCombo is version 1.0.0.HEAD
>
> any ideas?
>
> another note is that the CalendarCombo throws an nullpointerexception
> whenever i click on the NONE button AFTER i clicked on the TODAY button
> (its working fine when you click on the NONE button at first - empty field)
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #599965 is a reply to message #547660] Mon, 19 July 2010 06:14 Go to previous messageGo to next message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
i know that they do not have anything in common (but the way you 'install' em).

so i expected both to show up (in my IDE) after unpacking them and restarting eclipse - but only one of them does (and i cannot include the TableCombo manually too)
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #599971 is a reply to message #547664] Mon, 19 July 2010 06:24 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
Hi,

Installing them is not really a good idea IMHO because they don't add
functionality to your IDE. You should hold them in your target.

Tom

Am 19.07.10 12:14, schrieb Ludwig Moser:
> i know that they do not have anything in common (but the way you
> 'install' em).
>
> so i expected both to show up (in my IDE) after unpacking them and
> restarting eclipse - but only one of them does (and i cannot include the
> TableCombo manually too)
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #599980 is a reply to message #547671] Mon, 19 July 2010 06:42 Go to previous messageGo to next message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
ok, i removed it from the ide.
added the jars now.
adding the components to the palette by hand.
1) import jar...
2) selecting the jar on FS.
3) message pops up that the MANIFEST.MF is incorrect/empty. -> show all classes - i select yes
4) pick the TableCombo.class as the class i want to add. -> OK
5) nothing happens.

when i do exactly the same with the CalendarCombo it shows up in my palette, so it cant be completely wrong what i do...
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #599986 is a reply to message #547676] Mon, 19 July 2010 07:18 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
That's strange because when looking at the content of MANIFEST.MF looks ok.

Tom

Am 19.07.10 12:42, schrieb Ludwig Moser:
> ok, i removed it from the ide.
> added the jars now.
> adding the components to the palette by hand.
> 1) import jar...
> 2) selecting the jar on FS.
> 3) message pops up that the MANIFEST.MF is incorrect/empty. -> show all
> classes - i select yes
> 4) pick the TableCombo.class as the class i want to add. -> OK
> 5) nothing happens.
>
> when i do exactly the same with the CalendarCombo it shows up in my
> palette, so it cant be completely wrong what i do...
>
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #600002 is a reply to message #547689] Tue, 20 July 2010 07:03 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
Just installed the nightly build into my Eclipse 3.6 all is looking fine.

Tom

Am 19.07.10 13:18, schrieb Tom Schindl:
> That's strange because when looking at the content of MANIFEST.MF looks ok.
>
> Tom
>
> Am 19.07.10 12:42, schrieb Ludwig Moser:
>> ok, i removed it from the ide.
>> added the jars now.
>> adding the components to the palette by hand.
>> 1) import jar...
>> 2) selecting the jar on FS.
>> 3) message pops up that the MANIFEST.MF is incorrect/empty. -> show all
>> classes - i select yes
>> 4) pick the TableCombo.class as the class i want to add. -> OK
>> 5) nothing happens.
>>
>> when i do exactly the same with the CalendarCombo it shows up in my
>> palette, so it cant be completely wrong what i do...
>>
>
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #600009 is a reply to message #547995] Wed, 21 July 2010 01:12 Go to previous messageGo to next message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
i'm on 3.5 Galileo
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #600018 is a reply to message #600009] Thu, 22 July 2010 07:10 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5296
Registered: July 2009
Senior Member
Is there something in the .metadata/.log which give a bit more
informations on what's going wrong?

Tom

Am 21.07.10 07:12, schrieb Ludwig Moser:
> i'm on 3.5 Galileo
Re: TableCombo not showing up in Palette & CalendarCombo Bug? [message #600026 is a reply to message #548562] Fri, 23 July 2010 01:13 Go to previous message
Ludwig Moser is currently offline Ludwig Moser
Messages: 328
Registered: July 2009
Senior Member
nope there is neither 'nebula' nor 'combo' anywhere in the log.
Previous Topic:Nebula TableCombo in Nebula grid ?
Next Topic:Scientific notation in formattedtext
Goto Forum:
  


Current Time: Mon Sep 01 03:37:22 EDT 2014

Powered by FUDForum. Page generated in 0.02329 seconds