Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Galileo on Solaris 10(Companion shared Library not found)
Eclipse Galileo on Solaris 10 [message #545890] Fri, 09 July 2010 14:40 Go to next message
Thor  is currently offline Thor Friend
Messages: 4
Registered: July 2010
Junior Member
Hello,

very strange problem....

i downloaded eclipse 3.5.3 (gtk-sparc)on my USB stick and put it on
my solaris 10 workstation.

I went into the ECLIPSE dir of the mounted stick-dir and typed ./ECLIPSE
, the application started and everything was fine.

Then I copied the ECLIPSE dir in my home directory
via "cp -r ECLIPSE/ ~/ ".
When I went into the ECLIPSE directory of my home dir and typed ./ECLIPSE the following error message was shown:
The ECLIPSE executable launcher was unable to locate it's
companion shared library.

I noticed, that the access rights were different on my home directoy compared with my stick directory so i chmod 777 on my home dir. However the error message kept showing up.

There are no logs in the configuration directory or via ECLIPSE -debug which could bring me any further.

Also the relevant files in the PLUGINS folder are there as on my stick dir.

Someone has an idea what could cause the problem`?

Regards

R4DIUM

[Updated on: Fri, 09 July 2010 14:45]

Report message to a moderator

Re: Eclipse Galileo on Solaris 10 [message #546778 is a reply to message #545890] Wed, 14 July 2010 08:10 Go to previous messageGo to next message
Thor  is currently offline Thor Friend
Messages: 4
Registered: July 2010
Junior Member
I finally found out what is wrong....

I extracted the zip file on a windows system to the usb-stick.
Then copied the usb-stick-directory to solaris,

Somehow the Uppercase/Lowercase differentiation of the filenames was lost during that copy-process.

When I extract the zip file directly on solaris the error didn't
appear.


Regards

Re: Eclipse Galileo on Solaris 10 [message #546779 is a reply to message #545890] Wed, 14 July 2010 08:11 Go to previous message
Thor  is currently offline Thor Friend
Messages: 4
Registered: July 2010
Junior Member
I finally found out what is wrong....

I extracted the zip file on a windows system to the usb-stick.
Then copied the usb-stick-directory to solaris,

Somehow the Uppercase/Lowercase differentiation of the filenames was lost during that copy-process.

When I extract the zip file directly on solaris the error didn't
appear.


Regards

Previous Topic:Where is configuration information stored?
Next Topic:can you create an operation to execute when an existing button is clicked
Goto Forum:
  


Current Time: Thu Dec 18 16:25:32 GMT 2014

Powered by FUDForum. Page generated in 0.01537 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software