Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Unable to build project with jam (or make)
Unable to build project with jam (or make) [message #536659] Sat, 29 May 2010 08:55 Go to next message
salvatore  is currently offline salvatore
Messages: 3
Registered: May 2010
Junior Member
Hi,

I'm trying to use eclipse-cdt to cross-compile a project that uses jam as build system.

I managed to import the project through the SVN plugin, but I'm unable to build the project.

From the project properties I unchecked the "use default build command" option, and replaced with jam. I also unchecked the "Generates makefile automatically".

When I try to build system I get.
(Cannot run program "jam": Unknown reason)


but jam is correctly install
emitrax@xartimequad:~$ jam -v
Jam 2.5-haiku-20090626. OS=LINUX. Copyright 1993-2002 Christopher Seiwald.
emitrax@xartimequad:~$ which jam
/usr/local/bin/jam
emitrax@xartimequad:~$


and the path of the binary is in the PATH variable of the eclipse enviroment
Project -> Properties -> C/C++ build -> environment 
PATH:  /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/bin/

I googled a bit and someone suggest to disable the "use parallel build option", but it didn't solve my problem.

I also tried to replace jam with the make command to see if the message would be different, but I still get the useless "Cannot run program "jam": Unknown reason" message.

Any idea how to solve this?

Thanks in advance.
S.
Re: Unable to build project with jam (or make) [message #537043 is a reply to message #536659] Tue, 01 June 2010 03:26 Go to previous messageGo to next message
Axel Mueller is currently offline Axel Mueller
Messages: 1949
Registered: July 2009
Senior Member
Quote:
When I try to build system I get.
(Cannot run program "jam": Unknown reason)

Does jam need any special shared libs that it cannot find when started within Eclipse? Can you check your LD_LIBRARY_PATH (or ldd jam)?

Quote:
I also tried to replace jam with the make command to see if the message would be different, but I still get the useless "Cannot run program "jam": Unknown reason" message.

That is weird. Are you sure that you substituted jam with the make command only in Project Properties->C/C++ Build "build command"? Can you grep for jam in your .cproject file (it is hidden in the project folder)?

BTW, which Eclipse/CDT version are you using?


Before you ask
- search this forum
- see the FAQ http://wiki.eclipse.org/CDT/User/FAQ
- google
Re: Unable to build project with jam (or make) [message #537048 is a reply to message #537043] Tue, 01 June 2010 03:41 Go to previous messageGo to next message
salvatore  is currently offline salvatore
Messages: 3
Registered: May 2010
Junior Member
Axel Mueller wrote on Tue, 01 June 2010 03:26
Quote:
When I try to build system I get.
(Cannot run program "jam": Unknown reason)

Does jam need any special shared libs that it cannot find when started within Eclipse? Can you check your LD_LIBRARY_PATH (or ldd jam)?


I will check this tonight when I'll get back to my computer. Thanks.

Axel Mueller wrote on Tue, 01 June 2010 03:26

Quote:
I also tried to replace jam with the make command to see if the message would be different, but I still get the useless "Cannot run program "jam": Unknown reason" message.

That is weird. Are you sure that you substituted jam with the make command only in Project Properties->C/C++ Build "build command"? Can you grep for jam in your .cproject file (it is hidden in the project folder)?


I'm sorry, this was a copy & paste error. The error I get is "Cannot run program "make": Unknown reason ... ".
which is also weird to me.

Axel Mueller wrote on Tue, 01 June 2010 03:26

BTW, which Eclipse/CDT version are you using?


I download both eclipse galileo and CDT few days ago, so they should be the lasted version (3.5 and 6.0.2 if I recall correctly).

Any idea?

Thanks again.
Re: Unable to build project with jam (or make) [message #537259 is a reply to message #536659] Tue, 01 June 2010 13:34 Go to previous message
salvatore  is currently offline salvatore
Messages: 3
Registered: May 2010
Junior Member
And so it worked!

I went to check the dependencies as you suggested and he gave me a weird "no permission error". Weird because apparently it got installed with the execution permission but not the reading one.

A simple chmod +r to the binary fixed my problem.

Thanks again.

S.
Previous Topic:Eclipse CDT Linux makefile
Next Topic:getIndex
Goto Forum:
  


Current Time: Fri Aug 22 00:16:28 EDT 2014

Powered by FUDForum. Page generated in 0.02170 seconds