Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Spatiotemporal Epidemiological Modeler (STEM) » Build from Source Qs
Build from Source Qs [message #522901] Wed, 24 March 2010 09:14 Go to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
I was trying to build STEM from source so I can start making a modified version, but am having trouble. The guidance I was using is here http://wiki.eclipse.org/index.php/STEM_Source_Code (to get source, which worked fine) and here http://wiki.eclipse.org/index.php/Installation_Guide (looking under Preparing to Run STEM as a STEM Developer).

I imported STEM (tried both the branches\STEM_1_0_0\ and trunk\ versions) into Eclipse. It builds everything it imports, but there were errors in a few packages. These were all due to failed imports from org.eclipse.birt. I looked up BIRT on the Eclipse site, and found this page to acquire it: http://wiki.eclipse.org/BIRT_Update_Site_URL

My Eclipse Platform is
Version: 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvC NGB
Build id: M20100211-1343
so I tried the BIRT 2.5.x milestone build which says it is compatible with Eclipse Platform 3.5.2. (I also tried the release build for Eclipse 3.5, just to see).

The STEM imports for BIRT are now alright, but STEM still won't start. I use the ANT script to build the internal data, then try to run the UI package. The STEM splash screen comes up, then I get the error pasted below.

I looked around a little online, but am not experienced with Eclipse and was hoping someone else will know right away how to resolve this. There looks to be a version error for org.eclipse.ecf.provider.filetransfer_3.0.1. In my plugins folder I have: org.eclipse.ecf.provider.filetransfer_3.0.1.v20090831-1906.j ar

Full error log below.

Doug


!SESSION 2010-03-23 17:53:09.482 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_17
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.stem.ui.product
Command-line arguments:  -product org.eclipse.stem.ui.product -data C:\Documents and Settings\drafalsk\workspace/../runtime-stem.product -dev file:C:/Documents and Settings/drafalsk/workspace/.metadata/.plugins/org.eclipse.pde.core/stem.product/dev.properties -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.equinox.app 0 0 2010-03-23 17:53:10.670
!MESSAGE Product org.eclipse.stem.ui.product could not be found.

!ENTRY org.eclipse.osgi 4 0 2010-03-23 17:53:10.685
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
      at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:236)
      at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1287)

!ENTRY org.eclipse.osgi 2 0 2010-03-23 17:53:10.717
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.717
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.p2.repository_1.0.1.R35x_v20100105.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.repository 2 0 2010-03-23 17:53:10.717
!MESSAGE Missing required bundle org.eclipse.ecf.provider.filetransfer_3.0.1.

!ENTRY org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.equinox.p2.metadata.repository_1.0.101.R35x_v20090812 [64] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.repository.helpers_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.metadata.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.spi.p2.repository_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.ui.navigator.resources_3.4.1.M20090826-0800 [101] was not resolved.
!SUBENTRY 2 org.eclipse.ui.navigator.resources 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.ui.ide_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.ui.ide_3.5.2.M20100113-0800 [102] was not resolved.
!SUBENTRY 2 org.eclipse.ui.ide 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.equinox.p2.engine_[1.0.100,2.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.equinox.p2.artifact.repository_1.0.101.R35x_v20090721 [106] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.repository.helpers_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.artifact.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.spi.p2.repository_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.equinox.p2.engine_1.0.102.R35x_v20091117 [114] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.equinox.p2.metadata.repository_1.0.100.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.metadata.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.metadata.repository.io_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.persistence_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.p2.artifact.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.p2.metadata.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.p2.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.spi.p2.metadata.repository_0.0.0.
!SUBENTRY 2 org.eclipse.equinox.p2.engine 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.provisional.spi.p2.repository_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.ui.win32_3.2.100.v20090429-1800 [115] was not resolved.
!SUBENTRY 2 org.eclipse.ui.win32 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing host org.eclipse.ui.ide_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.equinox.p2.repository_1.0.1.R35x_v20100105 [117] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.p2.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.ecf.provider.filetransfer_3.0.1.
!SUBENTRY 2 org.eclipse.equinox.p2.repository 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing imported package org.eclipse.equinox.internal.p2.repository.helpers_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.stem.diseasemodels.forcing_1.0.0.qualifier [721] was not resolved.
!SUBENTRY 2 org.eclipse.stem.diseasemodels.forcing 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.diseasemodels.forcing 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.stem.internal.data.geography.population.human.models_1.0.0.qualifier [724] was not resolved.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.population.human.models 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.population.human.models 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.internal.data_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.population.human.models 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.population.human.models 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography.models_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.stem.ui.populationmodels_1.0.0 [727] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.populationmodels 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.populationmodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.populationmodels 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.populationmodels 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.populationmodels 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.stem.populationmodels_1.0.0 [728] was not resolved.
!SUBENTRY 2 org.eclipse.stem.populationmodels 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.stem.internal.data.geography.population_1.0.0.qualifier [730] was not resolved.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.population 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.population 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.internal.data_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.population 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.stem.internal.data.geography.infrastructure.transportation_1.0.0.qualifier [731] was not resolved.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.infrastructure.transportation 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.infrastructure.transportation 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.infrastructure.transportation 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.internal.data_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.infrastructure.transportation 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.transport_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.stem.ui.reports_1.0.0.qualifier [733] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.reports 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.reports 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.732
!MESSAGE Bundle org.eclipse.stem.diseasemodels.externaldatasource_1.0.0.qualifier [734] was not resolved.
!SUBENTRY 2 org.eclipse.stem.diseasemodels.externaldatasource 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.diseasemodels.externaldatasource 2 0 2010-03-23 17:53:10.732
!MESSAGE Missing required bundle org.eclipse.stem.util.analysis_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui.ge_1.0.0.qualifier [736] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.ge 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.ge 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.solvers.rk_1.0.0 [737] was not resolved.
!SUBENTRY 2 org.eclipse.stem.solvers.rk 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 2 org.eclipse.stem.solvers.rk 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.analysis.automaticexperiment_1.0.0.qualifier [738] was not resolved.
!SUBENTRY 2 org.eclipse.stem.analysis.automaticexperiment 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.analysis.automaticexperiment 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.util.loggers_0.0.0.
!SUBENTRY 2 org.eclipse.stem.analysis.automaticexperiment 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.definitions_1.0.0.qualifier [741] was not resolved.
!SUBENTRY 2 org.eclipse.stem.definitions 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.internal.diseasemodels.scenarios_1.0.0.qualifier [742] was not resolved.
!SUBENTRY 2 org.eclipse.stem.internal.diseasemodels.scenarios 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.diseasemodels.scenarios 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.diseasemodels.scenarios 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.diseasemodels.scenarios 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography.models_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.internal.data.geography_1.0.0.qualifier [745] was not resolved.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.solvers.fd_1.0.0 [746] was not resolved.
!SUBENTRY 2 org.eclipse.stem.solvers.fd 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.solvers.fd 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.diseasemodels_1.0.0.qualifier [748] was not resolved.
!SUBENTRY 2 org.eclipse.stem.diseasemodels 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.diseasemodels 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.transport_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.internal.data.geography.models_1.0.0.qualificer [749] was not resolved.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.models 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.models 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data.geography.models 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui.diseasemodels.externaldatasource_1.0.0.qualifier [750] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.externaldatasource 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels.externaldatasource_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.externaldatasource 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.util.loggers_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.externaldatasource 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.externaldatasource 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui.diseasemodels.example_1.0.0.qualifier [751] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.example 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels.example_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.example 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.example 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui.diseasemodels_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui.diseasemodels_1.0.0.qualifier [752] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.ui.navigator.resources_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.transport_1.0.0.qualifier [754] was not resolved.
!SUBENTRY 2 org.eclipse.stem.transport 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui_1.0.0.qualifier [755] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.ui.navigator.resources_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.util.analysis_1.0.0.qualifier [756] was not resolved.
!SUBENTRY 2 org.eclipse.stem.util.analysis 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 2 org.eclipse.stem.util.analysis 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.util.analysis 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui.diseasemodels.forcing.editor_1.0.0.qualifier [757] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.forcing.editor 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels.forcing_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.forcing.editor 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.forcing.editor 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.forcing.editor 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.definitions_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.forcing.editor 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.diseasemodels.forcing.editor 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.util.loggers_1.0.0.qualifier [758] was not resolved.
!SUBENTRY 2 org.eclipse.stem.util.loggers 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 2 org.eclipse.stem.util.loggers 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.util.loggers 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.populationmodels_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.internal.data_1.0.0.qualifier [760] was not resolved.
!SUBENTRY 2 org.eclipse.stem.internal.data 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.data 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.transport_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.internal.diseasemodels.models_1.0.0.qualifier [761] was not resolved.
!SUBENTRY 2 org.eclipse.stem.internal.diseasemodels.models 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.diseasemodels.models 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.diseasemodels.models 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography_0.0.0.
!SUBENTRY 2 org.eclipse.stem.internal.diseasemodels.models 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.internal.data.geography.models_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui.solvers.rk_1.0.0 [762] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.solvers.rk 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.solvers.rk_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.solvers.rk 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.ui.ide_3.4.2.
!SUBENTRY 2 org.eclipse.stem.ui.solvers.rk 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.diseasemodels.example_1.0.0.qualifier [763] was not resolved.
!SUBENTRY 2 org.eclipse.stem.diseasemodels.example 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.diseasemodels_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui.nl1_1.0.0.qualifier [766] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.nl1 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing host org.eclipse.stem.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-23 17:53:10.748
!MESSAGE Bundle org.eclipse.stem.ui.solvers.fd_1.0.0 [767] was not resolved.
!SUBENTRY 2 org.eclipse.stem.ui.solvers.fd 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.solvers.fd_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.solvers.fd 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.ui.ide_0.0.0.
!SUBENTRY 2 org.eclipse.stem.ui.solvers.fd 2 0 2010-03-23 17:53:10.748
!MESSAGE Missing required bundle org.eclipse.stem.ui_0.0.0.
Re: Build from Source Qs [message #523020 is a reply to message #522901] Wed, 24 March 2010 15:05 Go to previous messageGo to next message
Stefan Edlund is currently offline Stefan Edlund
Messages: 127
Registered: July 2009
Location: IBM
Senior Member
Hi Doug,

the easy stuff first, can you try this and see if it works:

1. In Eclipse, Java Perspective, Open the "Run Configurations..."
2. Select stem.product in the tree in the left.
3. On the right, click the Plug-ins tab.
4. Click "Add Required Plug-ins"
5. Click Apply.
6. Click "Validate plugins"
7. If it says No problems was detected, click run
8. If you see a problem, can you paste it?

Thanks!
Re: Build from Source Qs [message #523044 is a reply to message #523020] Wed, 24 March 2010 16:51 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
Thanks for the suggestion. It was able to add the missing filetransfer plugin, and now it runs.
Re: Build from Source Qs [message #523050 is a reply to message #523044] Wed, 24 March 2010 17:25 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
...though I can't seem to export a stand-alone version. Per http://wiki.eclipse.org/Welcome_STEM_Developers, I open feature.product and try to export a standalone version (tried to export to archive and directory), but I get:

Unable to find plug-in: org.eclipse.equinox.launcher_1.0.200.v20090520. Please check the error log for more details.


Suggestions there?
Re: Build from Source Qs [message #523057 is a reply to message #523050] Wed, 24 March 2010 18:11 Go to previous messageGo to next message
Stefan Edlund is currently offline Stefan Edlund
Messages: 127
Registered: July 2009
Location: IBM
Senior Member
That doc seems a little out-of-date, we should fix.

Can you try opening the file "stem.product" instead, and selecting "Eclipse Product Export Wizard" from the overview tab.

Uncheck sync before exporting, pick a directory and change the root directory to "stem".

Does that work?
Re: Build from Source Qs [message #523818 is a reply to message #523057] Mon, 29 March 2010 09:50 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
I opened stem.product and tried to export (unchecking synch but leaving everything else at its defaults) to a directory, and I get
Unable to find plug-in: org.eclipse.equinox.launcher_1.0.200.v20090520. Please check the error log for more details.


Under testing, if I select 'Launch an Eclipse application' it runs (though I had to go in to dependencies first and click 'Add Required Plug-ins' first). It is just the exporting that seems problematic.

[Updated on: Mon, 29 March 2010 09:50]

Report message to a moderator

Re: Build from Source Qs [message #523942 is a reply to message #523818] Mon, 29 March 2010 19:19 Go to previous messageGo to next message
Stefan Edlund is currently offline Stefan Edlund
Messages: 127
Registered: July 2009
Location: IBM
Senior Member
Hi,

I tried it and was unable to export too. Can you open a defect on it? How badly do you need to be able to export?

Thanks.
/ Stefan
Re: Build from Source Qs [message #524050 is a reply to message #523942] Tue, 30 March 2010 09:21 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
I am not sure how badly I need it just yet. Per this other post, I am investigating whether I can use STEM from a web interface. There wasn't currently one available, so I wanted to be able to create a non-UI version that I can call as a command line program, or possibly integrate with a web application.

I was exploring STEM and wanted to make sure I could create the standard installation to make sure my environment is set up properly before trying to muck about.
Re: Build from Source Qs [message #524065 is a reply to message #524050] Tue, 30 March 2010 10:15 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
Any idea how long an issue like this takes to get resolved? It has to be some simple configuration issue I am just not experienced enough with Eclipse or STEM to diagnose. Someone must be able to do it though, I was using an exported executable version before I started trying to build it from source. It must be some simple configuration issue. I'm submitting a bug now.
Re: Build from Source Qs [message #524111 is a reply to message #522901] Tue, 30 March 2010 14:51 Go to previous messageGo to next message
Matthew Davis
Messages: 269
Registered: July 2009
Senior Member
Hi Doug, I posted a comment in the bug. Please try those steps and see if it works.
Re: Build from Source Qs [message #524571 is a reply to message #524111] Thu, 01 April 2010 09:17 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
Matthew Davis wrote on Tue, 30 March 2010 14:51
Hi Doug, I posted a comment in the bug. Please try those steps and see if it works.



I kept having the same error, so I decided to start clean for this, just in case. I blew away the source directory and grabbed it from SVN again. I imported trunk into my workspace. I followed the steps you posted in the DR (updated plugins under stem.product dependencies - it went from 163 to 165, then I saved). I get the same error regardless of whether synch is checked or not. ("Unable to find plug-in: org.eclipse.equinox.launcher_1.0.200.v20090520. Please check the error log for more details.") The session data from the error log event details:

eclipse.buildId=unknown
java.version=1.6.0_17
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.reporting.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.reporting.product


I still can run it as an Eclipse application...
Re: Build from Source Qs [message #525555 is a reply to message #524571] Tue, 06 April 2010 17:17 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
Any other thoughts?
Re: Build from Source Qs [message #525563 is a reply to message #522901] Tue, 06 April 2010 17:42 Go to previous messageGo to next message
Stefan Edlund is currently offline Stefan Edlund
Messages: 127
Registered: July 2009
Location: IBM
Senior Member
Hi Doug, with Matt's new stem.product file I'm able to do the export (thanks Matt!). Does your error log file has any more useful information as indicated in the error message?

Re: Build from Source Qs [message #525801 is a reply to message #525563] Wed, 07 April 2010 16:15 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
Nothing useful in the event details when I check the event log:
Quote:
eclipse.buildId=unknown
java.version=1.6.0_17
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.reporting.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.reporting.product


Error
Wed Apr 07 16:09:25 EDT 2010
Unable to find plug-in: org.eclipse.equinox.launcher_1.0.200.v20090520. Please check the error log for more details.


The plugin for this message was org.eclipse.pde.build.
Re: Build from Source Qs [message #525812 is a reply to message #525801] Wed, 07 April 2010 16:56 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
hooray, progress! This is not a STEM error, so I think that DR can be closed since the updated stem.product works for both of you.

It looks to be an installation / eclipse error, as noted in this thread. I made it a lot farther in the export process this time, now I get:

Quote:
eclipse.buildId=unknown
java.version=1.6.0_17
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.reporting.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.reporting.product


Error
Wed Apr 07 16:50:56 EDT 2010
Missing requirement: STEM 1.0.1 (org.eclipse.stem.ui.product 1.0.1) requires 'org.apache.commons.codec [1.3.0.v20080530-1600]' but it could not be found


I'll go try to add it and see if I hit other errors...

Update -- I don't need to add it, it is already listed in the plug-ins. Two versions are:
Id: org.apache.commons.codec, Version: 1.3.0.v20080530-1600, Location: reference:file:plugins/org.apache.commons.codec_1.3.0.v20080 530-1600.jar
Id: org.apache.commons.codec, Version: 1.3.0.v20100106-1700, Location: reference:file:plugins/org.apache.commons.codec_1.3.0.v20100 106-1700.jar

So I'll have to figure out how to sort that out later.

Thanks for the help!

Update 2 -- I just changed the stem.product dependencies to specify version 1.3.0.v20080530-1600 for org.apache.commons.codec and it built. Not sure if that is the best way to fix it, but it gets me what I need for now.

[Updated on: Wed, 07 April 2010 17:15]

Report message to a moderator

Re: Build from Source Qs [message #526138 is a reply to message #525812] Thu, 08 April 2010 16:27 Go to previous messageGo to next message
Matthew Davis
Messages: 269
Registered: July 2009
Senior Member
Hi Doug, I don't think we're dependent on a specific version of commons.codec (the dependencies aren't in STEM, they're in Eclipse packages). Also it looks like Eclipse still ships (as of 3.5.2) the 20080530 version. Not sure where the 20100106 one comes in, unless it's part of another feature in your Eclipse SDK install.

I think your local fix is probably the best course of action.
Re: Build from Source Qs [message #563172 is a reply to message #525563] Wed, 07 April 2010 16:15 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
Nothing useful in the event details when I check the event log:
Quote:
> eclipse.buildId=unknown
> java.version=1.6.0_17
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Framework arguments: -product org.eclipse.epp.package.reporting.product
> Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.reporting.product
>
>
> Error
> Wed Apr 07 16:09:25 EDT 2010
> Unable to find plug-in: org.eclipse.equinox.launcher_1.0.200.v20090520. Please check the error log for more details.


The plugin for this message was org.eclipse.pde.build.
Re: Build from Source Qs [message #563195 is a reply to message #563172] Wed, 07 April 2010 16:56 Go to previous messageGo to next message
Doug  is currently offline Doug
Messages: 30
Registered: March 2010
Member
hooray, progress!

It looks to be an installation / eclipse error, as noted in http://dev.eclipse.org/mhonarc/lists/p2-dev/msg01703.html I made it a lot farther in the export process this time, now I get:

Quote:
> eclipse.buildId=unknown
> java.version=1.6.0_17
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Framework arguments: -product org.eclipse.epp.package.reporting.product
> Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.reporting.product
>
>
> Error
> Wed Apr 07 16:50:56 EDT 2010
> Missing requirement: STEM 1.0.1 (org.eclipse.stem.ui.product 1.0.1) requires 'org.apache.commons.codec [1.3.0.v20080530-1600]' but it could not be found


I'll go try to add it and see if I hit other errors...
Re: Build from Source Qs [message #563220 is a reply to message #563195] Thu, 08 April 2010 16:27 Go to previous message
Matthew Davis
Messages: 269
Registered: July 2009
Senior Member
Hi Doug, I don't think we're dependent on a specific version of commons.codec (the dependencies aren't in STEM, they're in Eclipse packages). Also it looks like Eclipse still ships (as of 3.5.2) the 20080530 version. Not sure where the 20100106 one comes in, unless it's part of another feature in your Eclipse SDK install.

I think your local fix is probably the best course of action.
Previous Topic:Dependence on administrative regions
Next Topic:Web interface?
Goto Forum:
  


Current Time: Mon Sep 01 14:41:54 EDT 2014

Powered by FUDForum. Page generated in 0.12828 seconds