Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » EclipseLink OSGi and RCP
EclipseLink OSGi and RCP [message #515745] Sat, 20 February 2010 09:43 Go to next message
Sir Wayne is currently offline Sir Wayne
Messages: 216
Registered: July 2009
Senior Member
Hello,

i want to use EclipseLink 2.0 with a eclipse RCP. I downloaded all EclipseLink Bundles.If I add the Bundle org.eclipse.persistence.jpa to my eclipse RCP Manifest
Require-Bundle: org.eclipse.ui,
 org.eclipse.core.runtime,
 org.eclipse.core.expressions;bundle-version="3.4.100",
 org.eclipse.persistence.jpa;bundle-version="2.0.0"

, always all Bundles will be unsatisfied and I get a red Error in IDE.
Whats wrong? What I have to do to use EclipseLink Bundles right?

Thanks and best Regards

John

Re: EclipseLink OSGi and RCP [message #515753 is a reply to message #515745] Sat, 20 February 2010 12:41 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 216
Registered: July 2009
Senior Member
okay i have always the Porblem if I use Spring...
I import the package org.springframework.orm.jpa.vendor and all my bundles are unsatisfied and without importing ClassNotFoundException *grrr*
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.springframework.dao.annotation.PersistenceExceptionTranslationPostProcessor#0' defined in URL [bundleentry://862.fwk27189676/META-INF/spring/client-context.xml]: Initialization of bean failed; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'entityManagerFactory' defined in URL [bundleentry://862.fwk27189676/META-INF/spring/client-context.xml]: Cannot resolve reference to bean 'jpaVendorAdapter' while setting bean property 'jpaVendorAdapter'; nested exception is org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [org.springframework.orm.jpa.vendor.EclipseLinkJpaVendorAdapter] for bean with name 'jpaVendorAdapter' defined in URL [bundleentry://862.fwk27189676/META-INF/spring/client-context.xml]; nested exception is java.lang.ClassNotFoundException: org.springframework.orm.jpa.vendor.EclipseLinkJpaVendorAdapter not found from bundle [client]
Related cause: org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [org.springframework.orm.jpa.vendor.EclipseLinkJpaVendorAdapter] for bean with name 'jpaVendorAdapter' defined in URL [bundleentry://862.fwk27189676/META-INF/spring/client-context.xml]; nested exception is java.lang.ClassNotFoundException: org.springframework.orm.jpa.vendor.EclipseLinkJpaVendorAdapter not found from bundle [client]
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519)
	at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:450)
	at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:290)
	at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
	at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:287)
	at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:189)
	at org.springframework.context.support.AbstractApplicationContext.getBean(AbstractApplicationContext.java:1004)


Re: EclipseLink OSGi and RCP [message #515754 is a reply to message #515745] Sat, 20 February 2010 12:41 Go to previous messageGo to next message
Sir Wayne is currently offline Sir Wayne
Messages: 216
Registered: July 2009
Senior Member
No Message Body
Re: EclipseLink OSGi and RCP [message #518633 is a reply to message #515745] Thu, 04 March 2010 16:33 Go to previous message
Gordon Yorke is currently offline Gordon Yorke
Messages: 77
Registered: July 2009
Member
Your entry for required bundles is incorrect. It should look like:

Require-Bundle: org.eclipse.ui,
org.eclipse.persistence.core;bundle-version="2.0.1.v20100213-r6600 ",
org.eclipse.persistence.jpa;bundle-version="2.0.0"
Previous Topic:IndexOutOfBoundsException in ObjectBuilder
Next Topic:soft deletes and implications
Goto Forum:
  


Current Time: Tue Sep 30 10:16:23 GMT 2014

Powered by FUDForum. Page generated in 0.02220 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software