Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » EcoreTools cannot be installed on Eclipse 3.6 M4
EcoreTools cannot be installed on Eclipse 3.6 M4 [message #504452] Sat, 19 December 2009 09:12 Go to next message
h1055071 is currently offline h1055071
Messages: 335
Registered: July 2009
Senior Member
I'm using Eclipse 3.6 M4 (I have to because of bugs in the 3.5 stream
for Cocoa and Linux, but that's another story) and have just
re-installed all of my plug-ins because of the updated Helios
repository. But I cannot now install the Ecore Tools. This is the error
message:

Cannot complete the install because of a conflicting dependency.
Software being installed: Ecore Tools SDK (Incubation)
0.9.0.v200906221231 (org.eclipse.emf.ecoretools.sdk.feature.group
0.9.0.v200906221231)
Software currently installed: EMF Validation Framework OCL
Integration 1.3.0.v20091215-1218-3--7w311A232602329
(org.eclipse.emf.validation.ocl.feature.group
1.3.0.v20091215-1218-3--7w311A232602329)

I need to have the OCL plug-in for other things.

Any advice how to solve this?

Phillipus
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #504453 is a reply to message #504452] Sat, 19 December 2009 14:16 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26050
Registered: July 2009
Senior Member
Phillipus,

Sorry, there are some changes needed to accommodate the OCL version
changes and the Ecore Tools team hasn't been able to respond. I'm
trying to figure out how best to proceed to get this going again, so it
might be a couple of weeks before we fix this problem. Sorry.



Phillipus wrote:
> I'm using Eclipse 3.6 M4 (I have to because of bugs in the 3.5 stream
> for Cocoa and Linux, but that's another story) and have just
> re-installed all of my plug-ins because of the updated Helios
> repository. But I cannot now install the Ecore Tools. This is the
> error message:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Ecore Tools SDK (Incubation)
> 0.9.0.v200906221231 (org.eclipse.emf.ecoretools.sdk.feature.group
> 0.9.0.v200906221231)
> Software currently installed: EMF Validation Framework OCL
> Integration 1.3.0.v20091215-1218-3--7w311A232602329
> (org.eclipse.emf.validation.ocl.feature.group
> 1.3.0.v20091215-1218-3--7w311A232602329)
>
> I need to have the OCL plug-in for other things.
>
> Any advice how to solve this?
>
> Phillipus
>
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #504456 is a reply to message #504453] Sat, 19 December 2009 09:32 Go to previous messageGo to next message
h1055071 is currently offline h1055071
Messages: 335
Registered: July 2009
Senior Member
On 19/12/2009 14:16, Ed Merks wrote:
> Phillipus,
>
> Sorry, there are some changes needed to accommodate the OCL version
> changes and the Ecore Tools team hasn't been able to respond. I'm trying
> to figure out how best to proceed to get this going again, so it might
> be a couple of weeks before we fix this problem. Sorry.
>
>
>
> Phillipus wrote:
>> I'm using Eclipse 3.6 M4 (I have to because of bugs in the 3.5 stream
>> for Cocoa and Linux, but that's another story) and have just
>> re-installed all of my plug-ins because of the updated Helios
>> repository. But I cannot now install the Ecore Tools. This is the
>> error message:
>>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Ecore Tools SDK (Incubation)
>> 0.9.0.v200906221231 (org.eclipse.emf.ecoretools.sdk.feature.group
>> 0.9.0.v200906221231)
>> Software currently installed: EMF Validation Framework OCL Integration
>> 1.3.0.v20091215-1218-3--7w311A232602329
>> (org.eclipse.emf.validation.ocl.feature.group
>> 1.3.0.v20091215-1218-3--7w311A232602329)
>>
>> I need to have the OCL plug-in for other things.
>>
>> Any advice how to solve this?
>>
>> Phillipus
>>

Thanks, Ed, for the fast response. I might try installing an older OCL
plug-in manually.

Phillipus
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #504461 is a reply to message #504456] Sat, 19 December 2009 11:12 Go to previous messageGo to next message
h1055071 is currently offline h1055071
Messages: 335
Registered: July 2009
Senior Member
On 19/12/2009 14:25, Phillipus wrote:
> On 19/12/2009 14:16, Ed Merks wrote:
>> Phillipus,
>>
>> Sorry, there are some changes needed to accommodate the OCL version
>> changes and the Ecore Tools team hasn't been able to respond. I'm trying
>> to figure out how best to proceed to get this going again, so it might
>> be a couple of weeks before we fix this problem. Sorry.
>>
>>
>>
>> Phillipus wrote:
>>> I'm using Eclipse 3.6 M4 (I have to because of bugs in the 3.5 stream
>>> for Cocoa and Linux, but that's another story) and have just
>>> re-installed all of my plug-ins because of the updated Helios
>>> repository. But I cannot now install the Ecore Tools. This is the
>>> error message:
>>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Ecore Tools SDK (Incubation)
>>> 0.9.0.v200906221231 (org.eclipse.emf.ecoretools.sdk.feature.group
>>> 0.9.0.v200906221231)
>>> Software currently installed: EMF Validation Framework OCL Integration
>>> 1.3.0.v20091215-1218-3--7w311A232602329
>>> (org.eclipse.emf.validation.ocl.feature.group
>>> 1.3.0.v20091215-1218-3--7w311A232602329)
>>>
>>> I need to have the OCL plug-in for other things.
>>>
>>> Any advice how to solve this?
>>>
>>> Phillipus
>>>
>
> Thanks, Ed, for the fast response. I might try installing an older OCL
> plug-in manually.
>
> Phillipus
>

For anyone who is interested, I installed EMF, XSD, GEF, GMF and the
Ecore Tools from Eclipse's updater (using the Helios update site at
http://download.eclipse.org/releases/helios) then I downloaded manually
the "emf-validation-SDK-1.3.1.zip" file and unzipped it into the
"dropins" folder. That seems to have kept Eclipse happy.

Phil
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #514407 is a reply to message #504461] Mon, 15 February 2010 09:07 Go to previous messageGo to next message
Hallvard Traetteberg is currently offline Hallvard Traetteberg
Messages: 594
Registered: July 2009
Location: Trondheim, Norway
Senior Member
Phillipus wrote:
> On 19/12/2009 14:25, Phillipus wrote:
>> On 19/12/2009 14:16, Ed Merks wrote:
>>> Phillipus,
>>>
>>> Sorry, there are some changes needed to accommodate the OCL version
>>> changes and the Ecore Tools team hasn't been able to respond. I'm trying
>>> to figure out how best to proceed to get this going again, so it might
>>> be a couple of weeks before we fix this problem. Sorry.

Any update on Ecore Tools and Helios compatibility?

Hallvard
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #514448 is a reply to message #514407] Mon, 15 February 2010 07:00 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26050
Registered: July 2009
Senior Member
Hallvard,

They committed the necessary changes and have a build going, but were
having trouble promoting it to the Helios repo. I'm not sure if that's
resolved. Nick was helping them.


Hallvard Trætteberg wrote:
> Phillipus wrote:
>> On 19/12/2009 14:25, Phillipus wrote:
>>> On 19/12/2009 14:16, Ed Merks wrote:
>>>> Phillipus,
>>>>
>>>> Sorry, there are some changes needed to accommodate the OCL version
>>>> changes and the Ecore Tools team hasn't been able to respond. I'm
>>>> trying
>>>> to figure out how best to proceed to get this going again, so it might
>>>> be a couple of weeks before we fix this problem. Sorry.
>
> Any update on Ecore Tools and Helios compatibility?
>
> Hallvard
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #514610 is a reply to message #514448] Mon, 15 February 2010 18:32 Go to previous messageGo to next message
Hallvard Traetteberg is currently offline Hallvard Traetteberg
Messages: 594
Registered: July 2009
Location: Trondheim, Norway
Senior Member
Ed,

Thanks for the update. Another question: With the latest delegate stuff
(validation of invariants and constraints and eInvoke), annotations
become even more important. I wonder if the support for annotations in
the property sheet has been changed/improved.

Hallvard

Ed Merks wrote:
> Hallvard,
>
> They committed the necessary changes and have a build going, but were
> having trouble promoting it to the Helios repo. I'm not sure if that's
> resolved. Nick was helping them.
>
>
> Hallvard Trætteberg wrote:
>> Phillipus wrote:
>>> On 19/12/2009 14:25, Phillipus wrote:
>>>> On 19/12/2009 14:16, Ed Merks wrote:
>>>>> Phillipus,
>>>>>
>>>>> Sorry, there are some changes needed to accommodate the OCL version
>>>>> changes and the Ecore Tools team hasn't been able to respond. I'm
>>>>> trying
>>>>> to figure out how best to proceed to get this going again, so it might
>>>>> be a couple of weeks before we fix this problem. Sorry.
>>
>> Any update on Ecore Tools and Helios compatibility?
>>
>> Hallvard
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #621947 is a reply to message #504453] Sat, 19 December 2009 14:25 Go to previous messageGo to next message
h1055071 is currently offline h1055071
Messages: 335
Registered: July 2009
Senior Member
On 19/12/2009 14:16, Ed Merks wrote:
> Phillipus,
>
> Sorry, there are some changes needed to accommodate the OCL version
> changes and the Ecore Tools team hasn't been able to respond. I'm trying
> to figure out how best to proceed to get this going again, so it might
> be a couple of weeks before we fix this problem. Sorry.
>
>
>
> Phillipus wrote:
>> I'm using Eclipse 3.6 M4 (I have to because of bugs in the 3.5 stream
>> for Cocoa and Linux, but that's another story) and have just
>> re-installed all of my plug-ins because of the updated Helios
>> repository. But I cannot now install the Ecore Tools. This is the
>> error message:
>>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Ecore Tools SDK (Incubation)
>> 0.9.0.v200906221231 (org.eclipse.emf.ecoretools.sdk.feature.group
>> 0.9.0.v200906221231)
>> Software currently installed: EMF Validation Framework OCL Integration
>> 1.3.0.v20091215-1218-3--7w311A232602329
>> (org.eclipse.emf.validation.ocl.feature.group
>> 1.3.0.v20091215-1218-3--7w311A232602329)
>>
>> I need to have the OCL plug-in for other things.
>>
>> Any advice how to solve this?
>>
>> Phillipus
>>

Thanks, Ed, for the fast response. I might try installing an older OCL
plug-in manually.

Phillipus
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #621948 is a reply to message #621947] Sat, 19 December 2009 15:58 Go to previous messageGo to next message
h1055071 is currently offline h1055071
Messages: 335
Registered: July 2009
Senior Member
On 19/12/2009 14:25, Phillipus wrote:
> On 19/12/2009 14:16, Ed Merks wrote:
>> Phillipus,
>>
>> Sorry, there are some changes needed to accommodate the OCL version
>> changes and the Ecore Tools team hasn't been able to respond. I'm trying
>> to figure out how best to proceed to get this going again, so it might
>> be a couple of weeks before we fix this problem. Sorry.
>>
>>
>>
>> Phillipus wrote:
>>> I'm using Eclipse 3.6 M4 (I have to because of bugs in the 3.5 stream
>>> for Cocoa and Linux, but that's another story) and have just
>>> re-installed all of my plug-ins because of the updated Helios
>>> repository. But I cannot now install the Ecore Tools. This is the
>>> error message:
>>>
>>> Cannot complete the install because of a conflicting dependency.
>>> Software being installed: Ecore Tools SDK (Incubation)
>>> 0.9.0.v200906221231 (org.eclipse.emf.ecoretools.sdk.feature.group
>>> 0.9.0.v200906221231)
>>> Software currently installed: EMF Validation Framework OCL Integration
>>> 1.3.0.v20091215-1218-3--7w311A232602329
>>> (org.eclipse.emf.validation.ocl.feature.group
>>> 1.3.0.v20091215-1218-3--7w311A232602329)
>>>
>>> I need to have the OCL plug-in for other things.
>>>
>>> Any advice how to solve this?
>>>
>>> Phillipus
>>>
>
> Thanks, Ed, for the fast response. I might try installing an older OCL
> plug-in manually.
>
> Phillipus
>

For anyone who is interested, I installed EMF, XSD, GEF, GMF and the
Ecore Tools from Eclipse's updater (using the Helios update site at
http://download.eclipse.org/releases/helios) then I downloaded manually
the "emf-validation-SDK-1.3.1.zip" file and unzipped it into the
"dropins" folder. That seems to have kept Eclipse happy.

Phil
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #622138 is a reply to message #621948] Mon, 15 February 2010 09:07 Go to previous messageGo to next message
Hallvard Traetteberg is currently offline Hallvard Traetteberg
Messages: 594
Registered: July 2009
Location: Trondheim, Norway
Senior Member
Phillipus wrote:
> On 19/12/2009 14:25, Phillipus wrote:
>> On 19/12/2009 14:16, Ed Merks wrote:
>>> Phillipus,
>>>
>>> Sorry, there are some changes needed to accommodate the OCL version
>>> changes and the Ecore Tools team hasn't been able to respond. I'm trying
>>> to figure out how best to proceed to get this going again, so it might
>>> be a couple of weeks before we fix this problem. Sorry.

Any update on Ecore Tools and Helios compatibility?

Hallvard
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #622141 is a reply to message #514407] Mon, 15 February 2010 11:38 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26050
Registered: July 2009
Senior Member
Hallvard,

They committed the necessary changes and have a build going, but were
having trouble promoting it to the Helios repo. I'm not sure if that's
resolved. Nick was helping them.


Hallvard Trætteberg wrote:
> Phillipus wrote:
>> On 19/12/2009 14:25, Phillipus wrote:
>>> On 19/12/2009 14:16, Ed Merks wrote:
>>>> Phillipus,
>>>>
>>>> Sorry, there are some changes needed to accommodate the OCL version
>>>> changes and the Ecore Tools team hasn't been able to respond. I'm
>>>> trying
>>>> to figure out how best to proceed to get this going again, so it might
>>>> be a couple of weeks before we fix this problem. Sorry.
>
> Any update on Ecore Tools and Helios compatibility?
>
> Hallvard
Re: EcoreTools cannot be installed on Eclipse 3.6 M4 [message #622146 is a reply to message #622141] Mon, 15 February 2010 23:05 Go to previous message
Hallvard Traetteberg is currently offline Hallvard Traetteberg
Messages: 594
Registered: July 2009
Location: Trondheim, Norway
Senior Member
Ed,

Thanks for the update. Another question: With the latest delegate stuff
(validation of invariants and constraints and eInvoke), annotations
become even more important. I wonder if the support for annotations in
the property sheet has been changed/improved.

Hallvard

Ed Merks wrote:
> Hallvard,
>
> They committed the necessary changes and have a build going, but were
> having trouble promoting it to the Helios repo. I'm not sure if that's
> resolved. Nick was helping them.
>
>
> Hallvard Trætteberg wrote:
>> Phillipus wrote:
>>> On 19/12/2009 14:25, Phillipus wrote:
>>>> On 19/12/2009 14:16, Ed Merks wrote:
>>>>> Phillipus,
>>>>>
>>>>> Sorry, there are some changes needed to accommodate the OCL version
>>>>> changes and the Ecore Tools team hasn't been able to respond. I'm
>>>>> trying
>>>>> to figure out how best to proceed to get this going again, so it might
>>>>> be a couple of weeks before we fix this problem. Sorry.
>>
>> Any update on Ecore Tools and Helios compatibility?
>>
>> Hallvard
Previous Topic:[EEF] Forms vs. property editing
Next Topic:Manually creating persistence.xml or hbm.xml
Goto Forum:
  


Current Time: Fri Sep 19 06:04:10 GMT 2014

Powered by FUDForum. Page generated in 0.05976 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software