Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Application Server Starts, but nothing visible in Profiling Monitor view(Jetty Starts and App deploys, but can't see anything in the Profiling Monitor View)
Application Server Starts, but nothing visible in Profiling Monitor view [message #503616] Mon, 14 December 2009 19:03 Go to next message
Andrew is currently offline AndrewFriend
Messages: 9
Registered: July 2009
Junior Member
I'm attempting to profile a Web Application running under Jetty 6.1.22, Eclipse 3.5, Ubuntu 9.04 and Java 1.6.0_16.

I can start Jetty in Profiling mode, and I can deploy the Application using the 'Profile Application on Server' command, but nothing shows up in the Profiling Monitor view of the Profiling and Logging perspective.

There's nothing in the .metadata/.log file, so does anyone have any suggestions as to where I could look for errors, or a way to actually make something come up in the view? I'm attempting to profile execution time.

Something did show up after I had installed it for the first time and it all seemed to work, but when I restarted the server and deployed my application, it didn't seem to register it, so I deleted it. And now there's nothing there.

Any suggestions would be greatly appreciated.

[Updated on: Tue, 15 December 2009 00:05]

Report message to a moderator

Re: Application Server Starts, but nothing visible in Profiling Monitor view [message #503766 is a reply to message #503616] Tue, 15 December 2009 16:28 Go to previous message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Andrew,

How did you 'start Jetty in Profiling mode'? Did you setup an server
instance in the Server views and start the server in profile mode? You
mentioned that you were attempting to profile execution time and I assume
you make the selection of execution time analysis in the profile on server
dialog window.
Is the server shown as Profiling in the server view after it is started, or
is it shown as 'Run'?

Eugene

"Andrew" <nzipsi@gmail.com> wrote in message
news:hg6jq3$e9l$1@build.eclipse.org...
> I'm attempting to profile a Web Application running under Jetty 6.1.22,
> Eclipse 3.5, Ubuntu 9.04 and Java 1.6.0_16.
>
> I can start Jetty in Profiling mode, and I can deploy the Application
> using the 'Profile Application on Server' command, but nothing shows up in
> the Profiling Monitor view of the Profiling and Logging perspective.
>
> There's nothing in the .metadata/.log file, so does anyone have any
> suggestions as to where I could look for errors, or a way to actually make
> something come up in the view? I'm attempting to profile execution time.
>
> Something did show up after I had installed it for the first time and it
> all seemed to work, but when I restarted the server and deployed my
> application, it didn't seem to register it, so I deleted it. And now
> there's nothing there.
>
> Any suggestions would be greatly appreciated.
Previous Topic:Proposed TPTP 4.7 component reorganization
Next Topic:Bug prediction using past testing effort
Goto Forum:
  


Current Time: Fri Dec 19 12:01:43 GMT 2014

Powered by FUDForum. Page generated in 0.02842 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software