Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » [Galileo SR1] Unable to manage Update Sites(Nothing happens after clicking on "Ok" upon adding a new Update Site information or after clicking "Edit" in the Available Software Sites window )
icon13.gif  [Galileo SR1] Unable to manage Update Sites [message #500813] Sun, 29 November 2009 06:09 Go to next message
Nikhil Lanjewar is currently offline Nikhil LanjewarFriend
Messages: 1
Registered: July 2009
Junior Member
I'm trying to add a new Update site in the existing list of update sites in my Eclipse Galileo JEE (Linux x86_64) running on a Fedora Core 12 x86_64. The IDE starts up well and then I tried adding a new update location. After giving the site HTTP address and a name, when I click on the "Ok" button, nothing happens. Even the window stays there as it was. When I move the mouse cursor back on the OK button to try clicking again, the button goes into a "clicked" state after mouse hovers on it, thus making it unclickable. Below is the Action to reproduce this behaviour:


  1. Open Eclipse Galileo JEE SR1 Linux x86_64
  2. Go to Help -> Install New Software
  3. Click on the "Add" Button
  4. Type the Site Name and enter site location
  5. Click on "Ok"


Similar behaviour was also observed when I tried to Edit existing Update sites. In that case, it didn't even open the Edit Dialog. The "Edit" button itself got stuck.

Any pointers to fix the above issue would really be helpful.
Re: [Galileo SR1] Unable to manage Update Sites [message #500849 is a reply to message #500813] Sun, 29 November 2009 17:00 Go to previous message
David Wegener is currently offline David WegenerFriend
Messages: 1352
Registered: July 2009
Senior Member
Nikhil Lanjewar wrote:
> I'm trying to add a new Update site in the existing list of update sites
> in my Eclipse Galileo JEE (Linux x86_64) running on a Fedora Core 12
> x86_64. The IDE starts up well and then I tried adding a new update
> location. After giving the site HTTP address and a name, when I click on
> the "Ok" button, nothing happens. Even the window stays there as it was.
> When I move the mouse cursor back on the OK button to try clicking
> again, the button goes into a "clicked" state after mouse hovers on it,
> thus making it unclickable. Below is the Action to reproduce this
> behaviour:
>
>
> Open Eclipse Galileo JEE SR1 Linux x86_64
> Go to Help -> Install New Software
> Click on the "Add" Button
> Type the Site Name and enter site location
> Click on "Ok"
>
>
> Similar behaviour was also observed when I tried to Edit existing Update
> sites. In that case, it didn't even open the Edit Dialog. The "Edit"
> button itself got stuck.
>
> Any pointers to fix the above issue would really be helpful.
This is caused by an incompatibility between SWT and the latest Gtk.
You can get around the problem by creating a script to start Eclipse and
including export GDK_NATIVE_WINDOWS=true.

See this bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=291257
Previous Topic:XX:MaxPermSize
Next Topic:Architecture
Goto Forum:
  


Current Time: Mon Dec 22 22:49:06 GMT 2014

Powered by FUDForum. Page generated in 0.09980 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software