Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » How to correctly integrate a milestone build?
How to correctly integrate a milestone build? [message #498102] Sat, 14 November 2009 08:49 Go to next message
Eclipse User
Originally posted by: formatzeh.gmx.de

I want to use the EMF 2.6.0M2 milestone [1] because the fixed bug 255786
promises some new power in automatic model validation. So I downloaded
the All-In-One SDK from [1] and put the content of the zip into a new
folder in the dropins folder. But when opening Eclipse the only version
which will be displayed in the plug-ins tab in the installation details
is 2.5.0. That's why I'm asking for help how to integrate a milestone
correctly.



[1]
http://www.eclipse.org/modeling/emf/downloads/?project=emf&a mp;showAll=1&hlbuild=S200909211047#S200909211047
[2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=255786
Re: How to correctly integrate a milestone build? [message #498112 is a reply to message #498102] Sat, 14 November 2009 10:43 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1334
Registered: July 2009
Senior Member
Gilbert Mirenque wrote:
> I want to use the EMF 2.6.0M2 milestone [1] because the fixed bug 255786
> promises some new power in automatic model validation. So I downloaded
> the All-In-One SDK from [1] and put the content of the zip into a new
> folder in the dropins folder. But when opening Eclipse the only version
> which will be displayed in the plug-ins tab in the installation details
> is 2.5.0. That's why I'm asking for help how to integrate a milestone
> correctly.
>
>
>
> [1]
> http://www.eclipse.org/modeling/emf/downloads/?project=emf&a mp;showAll=1&hlbuild=S200909211047#S200909211047
> [2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=255786

Why not just run the milestone build?

If you want to try just incorporating the EMF changes follow the
directions here:http://www.eclipse.org/modeling/emf/updates/ to add the
milestones update sight to update manager.
Re: How to correctly integrate a milestone build? [message #498120 is a reply to message #498112] Sat, 14 November 2009 12:34 Go to previous messageGo to next message
Eclipse User
Originally posted by: formatzeh.gmx.de

Hi David,

> Why not just run the milestone build?
sorry for the stupid question but how do I do this? Until now I have no
experiences with milestone builds.

> If you want to try just incorporating the EMF changes follow the
> directions here:http://www.eclipse.org/modeling/emf/updates/ to add the
> milestones update sight to update manager.

I added http://download.eclipse.org/modeling/emf/updates/milestones/ to
the update sites and only checked "EMF/XSD All in one SDK" to install.
But I got the following error messages:

Cannot complete the install because one or more required items could not
be found.
Software being installed: EMF/XSD All-In-One SDK 2.6.0.v200911060804
(org.eclipse.emf.all.feature.group 2.6.0.v200911060804)
Missing requirement: XSD to Ecore Mapping 2.5.0.v200911060804
(org.eclipse.emf.mapping.xsd2ecore 2.5.0.v200911060804) requires 'bundle
org.eclipse.core.runtime [3.6.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: EMF/XSD All-In-One SDK 2.6.0.v200911060804
(org.eclipse.emf.all.feature.group 2.6.0.v200911060804)
To: org.eclipse.xsd.sdk.feature.group [2.6.0.v200911060804]
Cannot satisfy dependency:
From: XSD Mapping 2.6.0.v200911060804
(org.eclipse.xsd.mapping.feature.group 2.6.0.v200911060804)
To: org.eclipse.emf.mapping.xsd2ecore [2.5.0.v200911060804]
Cannot satisfy dependency:
From: XSD - XML Schema Definition SDK 2.6.0.v200911060804
(org.eclipse.xsd.sdk.feature.group 2.6.0.v200911060804)
To: org.eclipse.xsd.mapping.feature.group [2.6.0.v200911060804]

Seems that I need Eclipse 3.6? I thought that I just can install an
update into my Galileo version.
Re: How to correctly integrate a milestone build? [message #498123 is a reply to message #498120] Sat, 14 November 2009 13:06 Go to previous messageGo to next message
David Wegener is currently offline David Wegener
Messages: 1334
Registered: July 2009
Senior Member
Gilbert Mirenque wrote:
> Hi David,
>
>> Why not just run the milestone build?
> sorry for the stupid question but how do I do this? Until now I have no
> experiences with milestone builds.
>

A Milestone build is the same as a regular build. Unzip it to a
directory on your computer and run eclipse/eclipse.exe depending on your
platform.

>> If you want to try just incorporating the EMF changes follow the
>> directions here:http://www.eclipse.org/modeling/emf/updates/ to add the
>> milestones update sight to update manager.
>
> I added http://download.eclipse.org/modeling/emf/updates/milestones/ to
> the update sites and only checked "EMF/XSD All in one SDK" to install.
> But I got the following error messages:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: EMF/XSD All-In-One SDK 2.6.0.v200911060804
> (org.eclipse.emf.all.feature.group 2.6.0.v200911060804)
> Missing requirement: XSD to Ecore Mapping 2.5.0.v200911060804
> (org.eclipse.emf.mapping.xsd2ecore 2.5.0.v200911060804) requires 'bundle
> org.eclipse.core.runtime [3.6.0,4.0.0)' but it could not be found
> Cannot satisfy dependency:
> From: EMF/XSD All-In-One SDK 2.6.0.v200911060804
> (org.eclipse.emf.all.feature.group 2.6.0.v200911060804)
> To: org.eclipse.xsd.sdk.feature.group [2.6.0.v200911060804]
> Cannot satisfy dependency:
> From: XSD Mapping 2.6.0.v200911060804
> (org.eclipse.xsd.mapping.feature.group 2.6.0.v200911060804)
> To: org.eclipse.emf.mapping.xsd2ecore [2.5.0.v200911060804]
> Cannot satisfy dependency:
> From: XSD - XML Schema Definition SDK 2.6.0.v200911060804
> (org.eclipse.xsd.sdk.feature.group 2.6.0.v200911060804)
> To: org.eclipse.xsd.mapping.feature.group [2.6.0.v200911060804]
>
> Seems that I need Eclipse 3.6? I thought that I just can install an
> update into my Galileo version.

The 2.6 version looks to have been developed against the 3.6 Eclipse
version. Plugins have version dependencies since they depend on
specific behaviors in their dependent plugins. You have to have the
required minimum version in order to run the plugin.
Re: How to correctly integrate a milestone build? [message #498181 is a reply to message #498123] Sun, 15 November 2009 11:12 Go to previous message
Eclipse User
Originally posted by: formatzeh.gmx.de

Ok thanks, now I took Eclipse 3.6 and could install the EMF build.
Previous Topic:How to wait on refresh during headless project creation from a CLI?
Next Topic:disable copy/paste/rename of files with particular extension
Goto Forum:
  


Current Time: Thu Jul 24 09:11:14 EDT 2014

Powered by FUDForum. Page generated in 0.01733 seconds