Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Cannot debug my application
Cannot debug my application [message #496124] Sun, 08 November 2009 18:53 Go to next message
Anders  ind is currently offline Anders indFriend
Messages: 2
Registered: November 2009
Junior Member
Hello!

I have tried to create a midlet with eclipseme. Instead of wireless tookit I have installed Java_ME_platform_SDK_3.0 because it should replace wireless toolkit. I have also installed the jdt plugin in eclipse.

In the windows->preferences->j2me settings I have scanned for devices by pressing import + browse and choosen the directory C:\Java_ME_platform_SDK_3.0. Why I had to specify that directory is unknown to me because I have already specified it in window->preferences->j2me and WTK Root. (1)

When I have selected the directory I also had to press Refresh (2).

I took a long time to generate the list (3). I had to press finish to remove the search window and actually populate the list (4). I got 12 entries, the first of them pre-selected. I dont know why (5). One entry was named DefaultCldcPhone2 and another DefaultCldcPhone1 (6). I pressed ok, because eventually I know have a device to run my application on. Now I created a midlet suite and a midlet which had the method startApp, destroyApp and pauseApp. The order of the function when they had been autogenerated was not in this apparent order (7). If I debug my application I get a sun style cell phone window with an application that is not the one I have programmed but the default application (8). Eclipse tries to connect to the debugger which it does not manage to do. (9). Instead it hangs until a timeout has been encountered (10).

Why is eclipse hanging is my main question. I have also marked some other confusing things with numbers in my posting.

Thanks for reading this!
Re: Cannot debug my application [message #496213 is a reply to message #496124] Mon, 09 November 2009 11:37 Go to previous message
Diego Madruga Sandin is currently offline Diego Madruga SandinFriend
Messages: 59
Registered: July 2009
Member
Hi,

I would suggest you post this question in the EclipseME mail list.

I'll also encourage you to try to start using MTJ instead of EclipseME. If you have some time, please, take a look on our documentation.

Regards,
Diego




Previous Topic:Proposed feautre: Export user defined symbols as separated .properties file
Next Topic:Cannot debug my application
Goto Forum:
  


Current Time: Sat Nov 29 06:48:33 GMT 2014

Powered by FUDForum. Page generated in 0.24197 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software