Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse on 64-bit Windows 7(Solved)
Eclipse on 64-bit Windows 7 [message #495526] Thu, 05 November 2009 09:16 Go to next message
Missing name Mising name is currently offline Missing name Mising nameFriend
Messages: 3
Registered: November 2009
Junior Member
I recently installed Windows 7 (64-bit) onto my laptop. I am a college student with a major in computer science and I am learning Java. Eclipse IDE for Java Developers worked perfectly fine with my 64-bit Windows Vista, but now, every time I try to open Eclipse, I get this error message:

A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations:
C:\Users\Corbyn\Desktop\eclipse\jre\bin\javaw.exe
javaw.exe in your current PATH

I'm not completely sure what it's asking for, so help would be greatly appreciated

EDIT: Forgot to mention that there is no such folder ( \jre ) in my eclipse directory.

[Updated on: Mon, 17 March 2014 20:58]

Report message to a moderator

Re: Eclipse on 64-bit Windows 7 [message #495617 is a reply to message #495526] Thu, 05 November 2009 14:08 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3268
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

cjohnson1991@gmail.com wrote:
> I recently installed Windows 7 (64-bit) onto my laptop. I am a college
> student with a major in computer science and I am learning Java. Eclipse
> IDE for Java Developers worked perfectly fine with my 64-bit Windows
> Vista, but now, every time I try to open Eclipse, I get this error message:
>
> A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be
> available in order to run Eclipse. No Java virtual machine was found
> after searching the following locations:
> C:\Users\Corbyn\Desktop\eclipse\jre\bin\javaw.exe
> javaw.exe in your current PATH
>
> I'm not completely sure what it's asking for, so help would be greatly
> appreciated
I can't specifically answer your question, but as noted frequently in
this forum, you should specifically use the -vm switch in your
eclipse.ini file to avoid such trouble.

http://wiki.eclipse.org/Eclipse.ini

Russ Bateman
Re: Eclipse on 64-bit Windows 7 [message #495632 is a reply to message #495526] Thu, 05 November 2009 14:41 Go to previous messageGo to next message
David Kerber is currently offline David KerberFriend
Messages: 100
Registered: July 2009
Senior Member
In article <hcu54s$hs1$1@build.eclipse.org>, cjohnson1991@gmail.com
says...
> I recently installed Windows 7 (64-bit) onto my laptop. I am a college student with a major in computer science and I am learning Java. Eclipse IDE for Java Developers worked perfectly fine with my 64-bit Windows Vista, but now, every time I try to open Eclipse, I get this error message:
>
> A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations:
> C:\Users\Corbyn\Desktop\eclipse\jre\bin\javaw.exe
> javaw.exe in your current PATH
>
> I'm not completely sure what it's asking for, so help would be greatly appreciated

It's telling you it can't find the JRE that eclipse needs to run. Have
you installed one?


--
/~\ The ASCII
\ / Ribbon Campaign
X Against HTML
/ \ Email!

Remove the ns_ from if replying by e-mail (but keep posts in the
newsgroups if possible).
Re: Eclipse on 64-bit Windows 7 [message #495779 is a reply to message #495632] Fri, 06 November 2009 03:38 Go to previous messageGo to next message
Missing name Mising name is currently offline Missing name Mising nameFriend
Messages: 3
Registered: November 2009
Junior Member
I have the JRE downloaded and installed. now how do i point eclipse to the javaw.exe file?
Re: Eclipse on 64-bit Windows 7 [message #495784 is a reply to message #495617] Fri, 06 November 2009 03:58 Go to previous messageGo to next message
Missing name Mising name is currently offline Missing name Mising nameFriend
Messages: 3
Registered: November 2009
Junior Member
Problem solved, thank you
Re: Eclipse on 64-bit Windows 7 [message #496069 is a reply to message #495779] Sat, 07 November 2009 20:58 Go to previous messageGo to next message
Walter Harley is currently offline Walter HarleyFriend
Messages: 847
Registered: July 2009
Senior Member
Corbyn wrote:
> I have the JRE downloaded and installed. now how do i point eclipse to
> the javaw.exe file?

Read the link that was posted earlier in this thread.
Re: Eclipse on 64-bit Windows 7 [message #511126 is a reply to message #495526] Sat, 30 January 2010 02:48 Go to previous messageGo to next message
Ryan is currently offline RyanFriend
Messages: 1
Registered: January 2010
Junior Member
I am having the same problem as the original poster, I tried doing the fixes posed in the link (I.E. adding those commands to the .ini file), but when i do that, it seems like clicking the eclipse.exe does nothing. Any suggestions/ideas?

[Updated on: Sat, 30 January 2010 02:48]

Report message to a moderator

Re: Eclipse on 64-bit Windows 7 [message #511249 is a reply to message #511126] Sun, 31 January 2010 20:35 Go to previous messageGo to next message
Em  is currently offline Em Friend
Messages: 2
Registered: January 2010
Junior Member
Try to see if your path variable is set... go to My Computer properties > Advanced system settings > under Advanced tab you have the Environment variables button, click it, and under System variables you should have the path variable. That variable is a list of paths that allow you to access exe's from anywhere just by typing their name and those paths are separated by semi-colon (;)... in there you should have something like ;C:\Program Files (x86)\Java\jre6\bin

If you don't have it, you either need to install JRE... and as a side note, you'll only need the 32-bit one, no need for 64-bit one at all... but if you do have it installed, just look up the path of java.exe and add it to that string... also don't end it with a ; or a \ and don't put the path in quotes.

[Updated on: Sun, 31 January 2010 20:35]

Report message to a moderator

Re: Eclipse on 64-bit Windows 7 [message #511983 is a reply to message #511249] Wed, 03 February 2010 15:17 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2411
Registered: July 2009
Senior Member
On 1/31/10 3:35 PM, Em wrote:
> Try to see if your path variable is set... go to My Computer properties
> > Advanced system settings > under Advanced tab you have the
> Environment variables button, click it, and under System variables you
> should have the path variable. That variable is a list of paths that
> allow you to access exe's from anywhere just by typing their name and
> those paths are separated by semi-colon (;)... in there you should have
> something like ;C:\Program Files (x86)\Java\jre6\bin
>
> If you don't have it, you either need to install JRE... and as a side
> note, you'll only need the 32-bit one, no need for 64-bit one at all...
> but if you do have it installed, just look up the path of java.exe and
> add it to that string... also don't end it with a ; or a \ and don't put
> the path in quotes.

I would recommend AGAINST adding Java to the system path, especially if
you want to maintain multiple versions of Java on your system. Using
eclipse.ini (instructions posted above via wiki link) is the best way to
specify what JVM you want Eclipse to run in.

Eric
Re: Eclipse on 64-bit Windows 7 [message #511991 is a reply to message #511126] Wed, 03 February 2010 15:27 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2411
Registered: July 2009
Senior Member
Ryan wrote on Fri, 29 January 2010 21:48
I am having the same problem as the original poster, I tried doing the fixes posed in the link (I.E. adding those commands to the .ini file), but when i do that, it seems like clicking the eclipse.exe does nothing. Any suggestions/ideas?

It could be a problem with how you formatted eclipse.ini - as the wiki page says, the format is very particular. Double-check what you've done and even post it here for us to review, if you want.

Eric
Re: Eclipse on 64-bit Windows 7 [message #647671 is a reply to message #495632] Fri, 07 January 2011 17:01 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 4
Registered: January 2011
Junior Member
I did it and now i have message that i dont have VM in folder where it actually is. What should I do?
Re: Eclipse on 64-bit Windows 7 [message #648032 is a reply to message #647671] Mon, 10 January 2011 21:51 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2411
Registered: July 2009
Senior Member
On 1/7/11 12:02 PM, sz4rlej@gmail.com wrote:
> I did it and now i have message that i dont have VM in folder where it
> actually is. What should I do?

You did what? Be specific, and refer to already-supplied advice.

Eric
Re: Eclipse on 64-bit Windows 7 [message #648874 is a reply to message #495526] Fri, 14 January 2011 19:27 Go to previous messageGo to next message
JimED  is currently offline JimED Friend
Messages: 1
Registered: July 2010
Junior Member
I'm having the same problem. Edited the system environment variables AND the eclipse.ini. Now I get the error on the attached image.

Here is my eclipse.ini:


-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1. 1.R36x_v20100810
-product
org.eclipse.epp.package.reporting.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vm
C:\Program Files (x86)\Java\jdk1.6.0_23\jre\bin\javaw.exe
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m

http://www.fun4u.com/eclipse.jpg



[Updated on: Sat, 15 January 2011 00:58]

Report message to a moderator

Re: Eclipse on 64-bit Windows 7 [message #648893 is a reply to message #648874] Sat, 15 January 2011 00:24 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3268
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

Your message is devoid of all context and must refer to an earlier
thread from which it is disassociated.

I can tell you right now, however, that you're telling the Eclipse that
uses this .ini file to use a 32-bit JRE. That's a no-no if your Eclipse
is in fact a 64-bit one, which it appears to be.


On 14-Jan-11 12:27, JimED wrote:
> I'm having the same problem. Edited the system environment variables AND
> the eclipse.ini. Now I get the error on the attached image.
>
> Here is my eclipse.ini:
>
>
> -startup
> plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
> --launcher.library
> plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.
> 1.R36x_v20100810
> -product
> org.eclipse.epp.package.reporting.product
> --launcher.defaultAction
> openFile
> --launcher.XXMaxPermSize
> 256M
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> -vm
> C:\Program Files (x86)\Java\jdk1.6.0_23\jre\bin\javaw.exe
> --launcher.defaultAction
> openFile
> -vmargs
> -Dosgi.requiredJavaVersion=1.5
> -Xms40m
> -Xmx512m
Re: Eclipse on 64-bit Windows 7 [message #648942 is a reply to message #648874] Sun, 16 January 2011 02:09 Go to previous messageGo to next message
Lucy Navarro is currently offline Lucy NavarroFriend
Messages: 1
Registered: January 2011
Junior Member
This is great...This will be very helpful...I'll take this as my future reference...Thanks!
Re: Eclipse on 64-bit Windows 7 [message #1272280 is a reply to message #495784] Mon, 17 March 2014 14:36 Go to previous messageGo to next message
saravanan R is currently offline saravanan RFriend
Messages: 1
Registered: March 2014
Junior Member
how to solve this error


A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations:
C:\Users\Corbyn\Desktop\eclipse\jre\bin\javaw.exe
javaw.exe in your current PATH
Re: Eclipse on 64-bit Windows 7 [message #1401210 is a reply to message #1272280] Tue, 15 July 2014 09:37 Go to previous message
Totyu Totev is currently offline Totyu TotevFriend
Messages: 1
Registered: July 2014
Junior Member
This error happens when a JVM 32-bit (JRE/JDK) is tried to be used with an Eclipse 64-bit or otherwise.
Previous Topic:ant build and cvs
Next Topic:Optional DATE Parameter in BIRT
Goto Forum:
  


Current Time: Sun Dec 21 21:43:13 GMT 2014

Powered by FUDForum. Page generated in 0.03571 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software