Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Some inter-plug-in dependencies have not been satisfied
Some inter-plug-in dependencies have not been satisfied [message #494899] Tue, 03 November 2009 07:34
Matthias Kohles is currently offline Matthias Kohles
Messages: 71
Registered: July 2009
Member
Here we go again,

well, again i have to bother you with my maybe stupid questions Smile

Everytime the eclipse.buildscript task is running, i received those dependencies issues. The build is running fine but i wonder what those messages mean? I checked my host eclipse and my target eclipse, and the plugins mentioned in those messages are available.

Messages:

[java] generateScript:
[java] [eclipse.buildScript] Some inter-plug-in dependencies have not been satisfied.
[java] [eclipse.buildScript] Bundle com.myplugin.sdk:
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.pde.core_0.0.0.
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.ant.core_0.0.0.
[java] [eclipse.buildScript] Bundle com.myplugin.sdk.nl.core:
[java] [eclipse.buildScript]       Another singleton version selected: com.myplugin.sdk.nl.core_1.0.0
[java] [eclipse.buildScript] Bundle com.myplugin.sdk.help:
[java] [eclipse.buildScript]       Another singleton version selected: com.myplugin.sdk.help_1.0.0
[java] [eclipse.buildScript] Bundle com.myplugin.sdk:
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.pde.core_0.0.0.
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.ant.core_0.0.0.

[java] [eclipse.buildScript] Bundle org.eclipse.emf.nl_de:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.emf_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.emf.nl_es:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.emf_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.emf.nl_fr:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.emf_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.emf.nl_it:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.emf_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.emf.nl_nl:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.emf_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.emf.nl_no:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.emf_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.emf.nl_pt_BR:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.emf_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.equinox.nl_de:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.equinox_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.equinox.nl_es:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.equinox_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.equinox.nl_fr:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.equinox_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.equinox.nl_nl:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.equinox_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.equinox.nl_no:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.equinox_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.equinox.nl_pt_BR:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.equinox_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.junit.nl_de:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.junit_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.junit.nl_es:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.junit_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.junit.nl_fr:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.junit_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.junit.nl_nl:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.junit_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.junit.nl_no:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.junit_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.junit.nl_pt_BR:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.junit_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.junit:
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.debug.core_[3.3.0,4.0.0).
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.debug.ui_[3.3.0,4.0.0).
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.jdt.core_[3.3.0,4.0.0).
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.jdt.ui_[3.3.0,4.0.0).
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.jdt.launching_[3.2.0,4.0.0).
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.jdt.debug.ui_[3.2.0,4.0.0).
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.compare_[3.3.0,4.0.0).
[java] [eclipse.buildScript]       Missing required plug-in org.eclipse.ltk.core.refactoring_[3.3.0,4.0.0).
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.launching.macosx.nl_de:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.launching.macosx_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.launching.macosx.nl_es:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.launching.macosx_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.launching.macosx.nl_fr:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.launching.macosx_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.launching.macosx.nl_nl:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.launching.macosx_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.launching.macosx.nl_no:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.launching.macosx_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.jdt.launching.macosx.nl_pt_BR:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.jdt.launching.macosx_0.0.0 has not been found.
[java] [eclipse.buildScript] Bundle org.eclipse.platform.source.win32.win32.x86:
[java] [eclipse.buildScript]       Host plug-in org.eclipse.platform.source_3.3.3.r33x_r20080129-_19UEl7Ezk_gXF1kouft has not been found.


There are a few entries that are language packs (emf, jdt.junit...), and they are located in my eclipse target platform but with different versioning (they have 3.4.0 version numbers, not 0.0.0 as the messages says). Whats wrong with that?

Then some of my plugins are missing the pde_core, but there is no dependency entry in their feature.xml for pde.core???

And what thas "another singleton version..." mean? i googled for it but didn't find anything which made me understand that.

best regards and big thanks for helping me

Matthias

[Updated on: Tue, 03 November 2009 07:35]

Report message to a moderator

Previous Topic:Imported JUnit package is not resolved
Next Topic:Some inter-plug-in dependencies have not been satisfied
Goto Forum:
  


Current Time: Sun Sep 21 04:16:26 GMT 2014

Powered by FUDForum. Page generated in 0.01773 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software