Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Workbench could not be found in the registry(Application dies in workbench with Application "org.eclipse.ui.ide.workbench" could not be found in the registry error?)
Workbench could not be found in the registry [message #489774] Mon, 05 October 2009 20:51 Go to next message
Mike S is currently offline Mike SFriend
Messages: 21
Registered: July 2009
Junior Member
Don't know if this is the correct place to be asking this but here goes? I started using Eclipse 3.5 and after installing and cleaning up some errors due to the changes to CDO interface it appeared to be working alright except for the project I had set up to test my application which had a error indicator on the project but nothing indicating any Java error in any files. I ran my application as a plugin and it appeared to be working out OK. I added the erlang IDE plugin and created an erlang project around this time. I finally got back to getting the error out of my application test project and and tried to run it and I get the following errors:

!SESSION 2009-10-05 13:55:04.198 -----------------------------------------------
eclipse.buildId=I20090611-1540
java.version=1.6.0_07
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments: -product org.eclipse.platform.ide
Command-line arguments: -product org.eclipse.platform.ide -data /home/stapleton/devel/eclipseProjects/newDM/../runtime-Eclip seApplication -dev file:/home/stapleton/devel/eclipseProjects/newDM/.metadata/. plugins/org.eclipse.pde.core/Eclipse Application/dev.properties -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 4 0 2009-10-05 13:55:06.237
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.emf.cdo.server.app, org.eclipse.emf.codegen.CodeGen, org.eclipse.emf.codegen.JMerger, org.eclipse.emf.codegen.ecore.Generator, org.eclipse.equinox.app.error, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool, org.eclipse.jdt.apt.core.aptBuild, org.eclipse.jdt.core.JavaCodeFormatter, org.eclipse.pde.junit.runtime.uitestapplication, org.eclipse.pde.junit.runtime.legacytestapplication, org.eclipse.pde.junit.runtime.coretestapplication, org.eclipse.pde.junit.runtime.coretestapplicationnonmain, org.eclipse.pde.junit.runtime.nonuithreadtestapplication, org.eclipse.update.core.standaloneUpdate, org.eclipse.update.core.siteOptimizer.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDe faultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run (MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)

!ENTRY org.eclipse.osgi 2 0 2009-10-05 13:55:07.681
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-10-05 13:55:07.681
!MESSAGE Bundle reference:file:/home/stapleton/devel/eclipse_modeling35/ecli pse/plugins/org.eclipse.pde.core_3.5.0.v20090602.jar was not resolved.
!SUBENTRY 2 org.eclipse.pde.core 2 0 2009-10-05 13:55:07.681
!MESSAGE Missing required bundle org.eclipse.equinox.p2.repository_[1.0.0,2.0.0).

and these last messages run on quit a bit for many bundles? My plugin gets executed from the Navigational window and now it won't even show up in the menu. This is something that has been working for months? Now where my plugin menu item used to be is the menu item "Generate Ecore DSL" when an ecore file is selected. Used to have my own menu item that used the .ecore file to build Google Protocol Messages? Anyone seen this before and have an idea of what is happening and how it can be corrected?

Thanks,
Mike
.




Re: Workbench could not be found in the registry [message #490055 is a reply to message #489774] Wed, 07 October 2009 06:11 Go to previous messageGo to next message
Lars Vogel is currently offline Lars VogelFriend
Messages: 1049
Registered: July 2009
Senior Member

Looks like you are missing bundles. See here to check you launch
configuration:
http://www.vogella.de/articles/RichClientPlatform/article.ht ml#runconfiguration

Mike Stapleton wrote:
> Don't know if this is the correct place to be asking this but here goes?
> I started using Eclipse 3.5 and after installing and cleaning up some
> errors due to the changes to CDO interface it appeared to be working
> alright except for the project I had set up to test my application which
> had a error indicator on the project but nothing indicating any Java
> error in any files. I ran my application as a plugin and it appeared to
> be working out OK. I added the erlang IDE plugin and created an erlang
> project around this time. I finally got back to getting the error out of
> my application test project and and tried to run it and I get the
> following errors:
>
> !SESSION 2009-10-05 13:55:04.198
> -----------------------------------------------
> eclipse.buildId=I20090611-1540
> java.version=1.6.0_07
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
> Framework arguments: -product org.eclipse.platform.ide
> Command-line arguments: -product org.eclipse.platform.ide -data
> /home/stapleton/devel/eclipseProjects/newDM/../runtime-Eclip
> seApplication -dev
> file:/home/stapleton/devel/eclipseProjects/newDM/.metadata/.
> plugins/org.eclipse.pde.core/Eclipse Application/dev.properties -os
> linux -ws gtk -arch x86
>
> !ENTRY org.eclipse.osgi 4 0 2009-10-05 13:55:06.237
> !MESSAGE Application error
> !STACK 1
> java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench"
> could not be found in the registry. The applications available are:
> org.eclipse.ant.core.antRunner, org.eclipse.emf.cdo.server.app,
> org.eclipse.emf.codegen.CodeGen, org.eclipse.emf.codegen.JMerger,
> org.eclipse.emf.codegen.ecore.Generator, org.eclipse.equinox.app.error,
> org.eclipse.help.base.infocenterApplication,
> org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool,
> org.eclipse.jdt.apt.core.aptBuild,
> org.eclipse.jdt.core.JavaCodeFormatter,
> org.eclipse.pde.junit.runtime.uitestapplication,
> org.eclipse.pde.junit.runtime.legacytestapplication,
> org.eclipse.pde.junit.runtime.coretestapplication,
> org.eclipse.pde.junit.runtime.coretestapplicationnonmain,
> org.eclipse.pde.junit.runtime.nonuithreadtestapplication,
> org.eclipse.update.core.standaloneUpdate,
> org.eclipse.update.core.siteOptimizer.
> at org.eclipse.equinox.internal.app.EclipseAppContainer.startDe
> faultApp(EclipseAppContainer.java:242)
> at org.eclipse.equinox.internal.app.MainApplicationLauncher.run
> (MainApplicationLauncher.java:29)
> at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher
> .runApplication(EclipseAppLauncher.java:110)
> at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher
> .start(EclipseAppLauncher.java:79)
> at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS
> tarter.java:368)
> at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS
> tarter.java:179)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce
> ssorImpl.java:39)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe
> thodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
> at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
>
> !ENTRY org.eclipse.osgi 2 0 2009-10-05 13:55:07.681
> !MESSAGE One or more bundles are not resolved because the following root
> constraints are not resolved:
> !SUBENTRY 1 org.eclipse.osgi 2 0 2009-10-05 13:55:07.681
> !MESSAGE Bundle
> reference:file:/home/stapleton/devel/eclipse_modeling35/ecli
> pse/plugins/org.eclipse.pde.core_3.5.0.v20090602.jar was not resolved.
> !SUBENTRY 2 org.eclipse.pde.core 2 0 2009-10-05 13:55:07.681
> !MESSAGE Missing required bundle
> org.eclipse.equinox.p2.repository_[1.0.0,2.0.0).
>
> and these last messages run on quit a bit for many bundles? My plugin
> gets executed from the Navigational window and now it won't even show up
> in the menu. This is something that has been working for months? Now
> where my plugin menu item used to be is the menu item "Generate Ecore
> DSL" when an ecore file is selected. Used to have my own menu item that
> used the .ecore file to build Google Protocol Messages? Anyone seen this
> before and have an idea of what is happening and how it can be corrected?
>
> Thanks,
> Mike




--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter
Re: Workbench could not be found in the registry [message #800177 is a reply to message #490055] Thu, 16 February 2012 19:45 Go to previous messageGo to next message
Kris Reid is currently offline Kris ReidFriend
Messages: 5
Registered: February 2012
Junior Member
When I hit "Validate Plugins" it says that there are none missing.

But then I get this error log

!ENTRY org.eclipse.osgi 2 0 2012-02-16 19:42:22.886
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.886
!MESSAGE Bundle initial@reference:file:../../../../../eclipse-indigo/plugins/org.eclipse.jdt.junit.runtime_3.4.300.v20110505-0800.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit.runtime 2 0 2012-02-16 19:42:22.887
!MESSAGE Missing required bundle org.junit_3.8.2.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.887
!MESSAGE Bundle initial@reference:file:../../../../../eclipse-indigo/plugins/org.eclipse.jdt.junit4.runtime_1.1.200.v20110505-0800.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit4.runtime 2 0 2012-02-16 19:42:22.887
!MESSAGE Missing required bundle org.junit_4.7.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.887
!MESSAGE Bundle initial@reference:file:../../../../../eclipse-indigo/plugins/org.eclipse.pde.junit.runtime_3.4.100.v20110406.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.pde.junit.runtime 2 0 2012-02-16 19:42:22.887
!MESSAGE Missing required bundle org.junit_3.8.2.

!ENTRY org.eclipse.osgi 2 0 2012-02-16 19:42:22.890
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.890
!MESSAGE Bundle org.eclipse.jdt.junit4.runtime_1.1.200.v20110505-0800 was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit4.runtime 2 0 2012-02-16 19:42:22.890
!MESSAGE Missing required bundle org.junit_4.7.0.
!SUBENTRY 2 org.eclipse.jdt.junit4.runtime 2 0 2012-02-16 19:42:22.890
!MESSAGE Missing required bundle org.eclipse.jdt.junit.runtime_[3.4.200,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.891
!MESSAGE Bundle org.eclipse.jdt.junit.runtime_3.4.300.v20110505-0800 was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit.runtime 2 0 2012-02-16 19:42:22.891
!MESSAGE Missing required bundle org.junit_3.8.2.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.891
!MESSAGE Bundle org.eclipse.pde.junit.runtime_3.4.100.v20110406 was not resolved.
!SUBENTRY 2 org.eclipse.pde.junit.runtime 2 0 2012-02-16 19:42:22.891
!MESSAGE Missing required bundle org.eclipse.jdt.junit.runtime_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.pde.junit.runtime 2 0 2012-02-16 19:42:22.891
!MESSAGE Missing required bundle org.junit_3.8.2.
!SUBENTRY 2 org.eclipse.pde.junit.runtime 2 0 2012-02-16 19:42:22.892
!MESSAGE Missing optionally required bundle org.eclipse.ui_[3.2.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2012-02-16 19:42:22.904
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.904
!MESSAGE Bundle initial@reference:file:../../../../../eclipse-indigo/plugins/org.eclipse.jdt.junit.runtime_3.4.300.v20110505-0800.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit.runtime 2 0 2012-02-16 19:42:22.904
!MESSAGE Missing required bundle org.junit_3.8.2.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.905
!MESSAGE Bundle initial@reference:file:../../../../../eclipse-indigo/plugins/org.eclipse.jdt.junit4.runtime_1.1.200.v20110505-0800.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit4.runtime 2 0 2012-02-16 19:42:22.905
!MESSAGE Missing required bundle org.junit_4.7.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.905
!MESSAGE Bundle initial@reference:file:../../../../../eclipse-indigo/plugins/org.eclipse.pde.junit.runtime_3.4.100.v20110406.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.pde.junit.runtime 2 0 2012-02-16 19:42:22.905
!MESSAGE Missing required bundle org.junit_3.8.2.

!ENTRY org.eclipse.osgi 2 0 2012-02-16 19:42:22.908
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.908
!MESSAGE Bundle org.eclipse.jdt.junit4.runtime_1.1.200.v20110505-0800 was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit4.runtime 2 0 2012-02-16 19:42:22.908
!MESSAGE Missing required bundle org.junit_4.7.0.
!SUBENTRY 2 org.eclipse.jdt.junit4.runtime 2 0 2012-02-16 19:42:22.908
!MESSAGE Missing required bundle org.eclipse.jdt.junit.runtime_[3.4.200,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.909
!MESSAGE Bundle org.eclipse.jdt.junit.runtime_3.4.300.v20110505-0800 was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit.runtime 2 0 2012-02-16 19:42:22.909
!MESSAGE Missing required bundle org.junit_3.8.2.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-02-16 19:42:22.909
!MESSAGE Bundle org.eclipse.pde.junit.runtime_3.4.100.v20110406 [14] was not resolved.
!SUBENTRY 2 org.eclipse.pde.junit.runtime 2 0 2012-02-16 19:42:22.909
!MESSAGE Missing required bundle org.eclipse.jdt.junit.runtime_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.pde.junit.runtime 2 0 2012-02-16 19:42:22.909
!MESSAGE Missing required bundle org.junit_3.8.2.
!SUBENTRY 2 org.eclipse.pde.junit.runtime 2 0 2012-02-16 19:42:22.910
!MESSAGE Missing optionally required bundle org.eclipse.ui_[3.2.0,4.0.0).

!ENTRY org.eclipse.osgi 4 0 2012-02-16 19:42:22.912
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.pde.junit.runtime.coretestapplication" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
icon12.gif  Re: Workbench could not be found in the registry [message #820447 is a reply to message #800177] Wed, 14 March 2012 06:13 Go to previous messageGo to next message
MyungWoon Oh is currently offline MyungWoon OhFriend
Messages: 30
Registered: March 2012
Member
You need to add 2 plug-ins in 'Run configurations'

- Go 'Run > Run Configurations...'
- Choose your run configuration
- click on 'Plug-ins' tab

add plug-ins below

org.eclipse.core.net
org.eclipse.ui.ide.application

I found this fixed the 'Application "org.eclipse.ui.ide.workbench" could not be found in the registry.' problem.

But I think it would be far better if clicking on 'Add Required Plug-ins' button automatically added those 2 plug-ins. Mad
Re: Workbench could not be found in the registry [message #926498 is a reply to message #820447] Fri, 28 September 2012 18:18 Go to previous message
David Rees is currently offline David ReesFriend
Messages: 47
Registered: September 2012
Member
MyungWoon Oh wrote on Wed, 14 March 2012 02:13
You need to add 2 plug-ins in 'Run configurations'

- Go 'Run > Run Configurations...'
- Choose your run configuration
- click on 'Plug-ins' tab

add plug-ins below

org.eclipse.core.net
org.eclipse.ui.ide.application

I found this fixed the 'Application "org.eclipse.ui.ide.workbench" could not be found in the registry.' problem.

But I think it would be far better if clicking on 'Add Required Plug-ins' button automatically added those 2 plug-ins. Mad


Thanks Myung, that fixed things for me. I didn't have the problem under 3.8, but it showed up under Juno SR1, 4.2.1.

I agree they should be listed in the required plugins. Or perhaps my EMF generated plugin should have them as required plugins?
Previous Topic:Restarting Juno
Next Topic:P2.inf Copy
Goto Forum:
  


Current Time: Fri Dec 19 04:50:51 GMT 2014

Powered by FUDForum. Page generated in 0.02860 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software