Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » new software installed, but features and plugins not available ?
new software installed, but features and plugins not available ? [message #479953] Thu, 13 August 2009 08:40 Go to next message
Eclipse User
Originally posted by: Armin.Ehrenfels.t-online.de

Hi group,

I'm in deep trouble with Eclipse 3.5.

I installed the RCP/Plugin package for Linux 32b. No problem.
Then, I installed Spring's IDE software. No problem.

When I restarted Eclipse, I could see that the Spring IDE is installed,
but somehow, the features and plugins are not loaded/activated.

I repeated this with other software packages (Maven, Groovy, ...) and
experienced the same problem.

I wanted to investigate the problem further by switching to the classic
update manager. Eclipse Help explains:

> In some situations you may not be able to install or update software
using the menu commands in the Help menu. In these situations you will
automatically be redirected to the classic update manager. You can also
access the classic update manager from the General > Capabilities preference
page by enabling the Classic Update capability. When this capability is
enabled,
a Software Updates... sub-menu will appear in the Help menu, providing
access
to classic update commands.

I assume that General > Capabilities means Window > Preferences >
General > Capabilities. The problem is the menu ... General doesn't have
an item Capabilities !

At this point, I'm really stuck and any help is very much appreciated.
If more information is needed to solve the problem, please let me know.
If this is the wrong group to discuss the problem, please, point me to
the right one.

Thank you in advance and regards

Armin
Re: new software installed, but features and plugins not available ? [message #480021 is a reply to message #479953] Thu, 13 August 2009 14:01 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Is there anything in your error log? <workspace>/.metadata/.log ?

What is the "RCP/Plugin package"? I installed eclipse from eclipse-SDK-I20090611-1540-linux-gtk.tar.gz from http://download.eclipse.org/eclipse/downloads/ and it works fine for me.

PW


Re: new software installed, but features and plugins not available ? [message #480063 is a reply to message #480021] Thu, 13 August 2009 16:26 Go to previous messageGo to next message
David Carver is currently offline David Carver
Messages: 174
Registered: July 2009
Senior Member
I'm experieincing a similar issue with the P2 installer from a repository. If I provision a product from a repository, the product is installed. If I try to add any additional items through the Install Software option, it gets installed, but is never activated or actually useable.

Features show the same. Nothing in the error log to indicate that there is anything wrong either.
Re: new software installed, but features and plugins not available ? [message #480101 is a reply to message #480021] Thu, 13 August 2009 19:35 Go to previous message
Eclipse User
Originally posted by: Armin.Ehrenfels.t-online.de

Paul,

thank you for your reply.

There is no .log in .metadata.
By RCP/Plugin package, I mean I installed from
eclipse-rcp-galileo-linux-gtk.tar.gz.

Regards

Armin


Paul Webster schrieb:
> Is there anything in your error log? <workspace>/.metadata/.log ?
>
> What is the "RCP/Plugin package"? I installed eclipse from
> eclipse-SDK-I20090611-1540-linux-gtk.tar.gz from
> http://download.eclipse.org/eclipse/downloads/ and it works fine for me.
>
> PW
>
Previous Topic:p2 Installer Installation Not complete
Next Topic:how to check if DS is running?
Goto Forum:
  


Current Time: Tue Sep 23 12:37:18 GMT 2014

Powered by FUDForum. Page generated in 0.02654 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software