Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Plug-in not in the plug-in registy
Plug-in not in the plug-in registy [message #478868] Fri, 07 August 2009 10:06 Go to next message
saurav sarkar is currently offline saurav sarkar
Messages: 424
Registered: July 2009
Senior Member
Hi All,

I have developed a plug-in and exported it.
Then i had put the plug-in in the plugins directory of the eclipse.
I could not find the plug-in in the plugin registry.
I can find the plug-in in the plugins view.
May be i dont have the full concept of plugin registry.

Please provide your inputs here.

Thanks and Regards,
Saurav


Re: Plug-in not in the plug-in registy [message #478911 is a reply to message #478868] Fri, 07 August 2009 12:50 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 26054
Registered: July 2009
Senior Member
Suarav,

These days you should be putting it into the dropins folder if you're
adding it later. You might use -clean -debug as flags when starting and
then look at the <workspace>/.metadata/.log for clues why your plugin
might not be activated (because of missing dependencies for example).

saurav wrote:
> Hi All,
>
> I have developed a plug-in and exported it.
> Then i had put the plug-in in the plugins directory of the eclipse.
> I could not find the plug-in in the plugin registry.
> I can find the plug-in in the plugins view.
> May be i dont have the full concept of plugin registry.
>
> Please provide your inputs here.
>
> Thanks and Regards,
> Saurav
>
Re: Plug-in not in the plug-in registy [message #478986 is a reply to message #478868] Fri, 07 August 2009 19:52 Go to previous messageGo to next message
Lars Vogel is currently offline Lars Vogel
Messages: 1049
Registered: July 2009
Senior Member

Hi,

have a look here for an example including how to import it into Eclipse
3.5. http://www.vogella.de/articles/EclipsePlugIn/article.html

Best regards, Lars

saurav wrote:
> Hi All,
>
> I have developed a plug-in and exported it.
> Then i had put the plug-in in the plugins directory of the eclipse.
> I could not find the plug-in in the plugin registry.
> I can find the plug-in in the plugins view.
> May be i dont have the full concept of plugin registry.
>
> Please provide your inputs here.
>
> Thanks and Regards,
> Saurav
>




--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
Re: Plug-in not in the plug-in registy [message #479551 is a reply to message #478986] Tue, 11 August 2009 14:36 Go to previous message
saurav sarkar is currently offline saurav sarkar
Messages: 424
Registered: July 2009
Senior Member
Thanks Lars and Ed for your helpful replies.
I could find out the major reasons were the dependencies were not properly
loaded.

Thanks again.

cheers,
Saurav


Previous Topic:HowTo: Add Text under the Image in Action of ToolbarManager?
Next Topic:Eclipse doesn't compile anything
Goto Forum:
  


Current Time: Sun Sep 21 02:07:12 GMT 2014

Powered by FUDForum. Page generated in 0.01657 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software