Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » [UML] Problem running ATL standalone with UML files
[UML] Problem running ATL standalone with UML files [message #473090] Mon, 04 June 2007 15:37 Go to next message
Paul Gribben is currently offline Paul GribbenFriend
Messages: 28
Registered: July 2009
Junior Member
Hi,

I wasn't sure whether to post this to the UML or ATL group, so I've posted
it to both.

I've been trying to put together a java launcher for ATL transformations
that use eclipse UML2 model files. I am currently getting a problem when
the transform attempts to resolve the 'hasStereotype' operation:

message: ERROR: could not find operation hasStereotype on Void having
supertypes: [OclAny]

I'm guessing that I need to register some extension or plugin element in
the standalone environment context, but can't figure out what to do. So
far I've registered the UML2 package doing this:

org.eclipse.uml2.uml.UMLPackage.eINSTANCE.getEFactoryInstanc e();

I also did the following (but am unsure if I needed to):

Map extensionToFactoryMap =
Resource.Factory.Registry.INSTANCE.getExtensionToFactoryMap( );
extensionToFactoryMap.put(UMLResource.FILE_EXTENSION,
UMLResource.Factory.INSTANCE);
extensionToFactoryMap.put(XMI2UMLResource.FILE_EXTENSION,
XMI2UMLResource.Factory.INSTANCE);

Any help would be greatly appreciated.

Thanks
Paul
Re: [UML] Problem running ATL standalone with UML files [message #473095 is a reply to message #473090] Tue, 05 June 2007 09:01 Go to previous message
Freddy Allilaire is currently offline Freddy AllilaireFriend
Messages: 130
Registered: July 2009
Senior Member
Hi Paul,

This post was answered on M2M newsgroup.

When posting to multiple newsgroups, please try to do so with a single
posting addressed to all the groups rather than with a separate posting
to each group ;-)

Regards,
Freddy.

Paul Gribben a écrit :
> Hi,
>
> I wasn't sure whether to post this to the UML or ATL group, so I've
> posted it to both.
>
> I've been trying to put together a java launcher for ATL transformations
> that use eclipse UML2 model files. I am currently getting a problem when
> the transform attempts to resolve the 'hasStereotype' operation:
>
> message: ERROR: could not find operation hasStereotype on Void having
> supertypes: [OclAny]
>
> I'm guessing that I need to register some extension or plugin element in
> the standalone environment context, but can't figure out what to do. So
> far I've registered the UML2 package doing this:
>
> org.eclipse.uml2.uml.UMLPackage.eINSTANCE.getEFactoryInstanc e();
>
> I also did the following (but am unsure if I needed to):
>
> Map extensionToFactoryMap =
> Resource.Factory.Registry.INSTANCE.getExtensionToFactoryMap( );
> extensionToFactoryMap.put(UMLResource.FILE_EXTENSION,
> UMLResource.Factory.INSTANCE);
> extensionToFactoryMap.put(XMI2UMLResource.FILE_EXTENSION,
> XMI2UMLResource.Factory.INSTANCE);
>
> Any help would be greatly appreciated.
>
> Thanks
> Paul
>


--
Freddy Allilaire - ATLAS Group (INRIA & LINA)
http://www.sciences.univ-nantes.fr/lina/atl/contrib/allilair e
Re: [UML] Problem running ATL standalone with UML files [message #619683 is a reply to message #473090] Tue, 05 June 2007 09:01 Go to previous message
Freddy Allilaire is currently offline Freddy AllilaireFriend
Messages: 130
Registered: July 2009
Senior Member
Hi Paul,

This post was answered on M2M newsgroup.

When posting to multiple newsgroups, please try to do so with a single
posting addressed to all the groups rather than with a separate posting
to each group ;-)

Regards,
Freddy.

Paul Gribben a écrit :
> Hi,
>
> I wasn't sure whether to post this to the UML or ATL group, so I've
> posted it to both.
>
> I've been trying to put together a java launcher for ATL transformations
> that use eclipse UML2 model files. I am currently getting a problem when
> the transform attempts to resolve the 'hasStereotype' operation:
>
> message: ERROR: could not find operation hasStereotype on Void having
> supertypes: [OclAny]
>
> I'm guessing that I need to register some extension or plugin element in
> the standalone environment context, but can't figure out what to do. So
> far I've registered the UML2 package doing this:
>
> org.eclipse.uml2.uml.UMLPackage.eINSTANCE.getEFactoryInstanc e();
>
> I also did the following (but am unsure if I needed to):
>
> Map extensionToFactoryMap =
> Resource.Factory.Registry.INSTANCE.getExtensionToFactoryMap( );
> extensionToFactoryMap.put(UMLResource.FILE_EXTENSION,
> UMLResource.Factory.INSTANCE);
> extensionToFactoryMap.put(XMI2UMLResource.FILE_EXTENSION,
> XMI2UMLResource.Factory.INSTANCE);
>
> Any help would be greatly appreciated.
>
> Thanks
> Paul
>


--
Freddy Allilaire - ATLAS Group (INRIA & LINA)
http://www.sciences.univ-nantes.fr/lina/atl/contrib/allilair e
Previous Topic:[UML] Problem running ATL standalone with UML files
Next Topic:[Announce] MDT UML2 2.1.0 2.1RC2 is available
Goto Forum:
  


Current Time: Tue Dec 23 03:18:16 GMT 2014

Powered by FUDForum. Page generated in 0.01626 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software