Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » RCP Export problem - launcher unable to locate its companion shared library
RCP Export problem - launcher unable to locate its companion shared library [message #466060] Thu, 12 April 2007 23:47 Go to next message
Matt Ryan is currently offline Matt Ryan
Messages: 11
Registered: July 2009
Junior Member
Hi,

(I searched for this on the newsgroups before but didn't find the answer
- if I missed it please accept my apologies.)


I have an RCP application that I'm trying to export to two platforms -
Linux and Windows. I'm developing on Linux. When I do the
multi-platform export, the application runs fine on Linux. On Windows,
when I double-click the icon I get an error message that says, "The
<application_name> executable launcher was unable to locate its
companion shared library."

Can anyone give me pointers on this please?
Re: RCP Export problem - launcher unable to locate its companion shared [message #466062 is a reply to message #466060] Fri, 13 April 2007 05:43 Go to previous messageGo to next message
Eclipse User
Originally posted by: logicline.listak.freemail.hu

I had same problem, but I solve it successfully.

You must copy org.eclipse.equinox.launcher.win32.win32.x86_x.x.x _directory_ from an Eclipse Windows installation to your Eclipse application plugin directory and it's will be working.

I used org.eclipse.equinox.launcher.win32.win32.x86_1.0.0.v20070318 which is located in Eclipse 3.3M6 SDK plugin directory.

I think the org.eclipse.equinox.launcher_x.x.x.jar plugin (org.eclipse.equinox.launcher_1.0.0.v20070319.jar for me) also necessary.
Re: RCP Export problem - launcher unable to locate its companion shared [message #466429 is a reply to message #466062] Wed, 18 April 2007 20:48 Go to previous message
Matt Ryan is currently offline Matt Ryan
Messages: 11
Registered: July 2009
Junior Member
Thanks for your advice on this. I followed your instructions, but
unfortunately I am still seeing the same problem.

Joseph Girnt wrote:
> I had same problem, but I solve it successfully.
>
> You must copy org.eclipse.equinox.launcher.win32.win32.x86_x.x.x _directory_ from an Eclipse Windows installation to your Eclipse application plugin directory and it's will be working.
>
> I used org.eclipse.equinox.launcher.win32.win32.x86_1.0.0.v20070318 which is located in Eclipse 3.3M6 SDK plugin directory.
>
> I think the org.eclipse.equinox.launcher_x.x.x.jar plugin (org.eclipse.equinox.launcher_1.0.0.v20070319.jar for me) also necessary.
Previous Topic:CTabFolder and selection changes
Next Topic:Participating in a PullUpRefactoring
Goto Forum:
  


Current Time: Fri Sep 19 16:03:09 GMT 2014

Powered by FUDForum. Page generated in 0.02322 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software