Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » 3.2m4 standalone problem
3.2m4 standalone problem [message #466002] Wed, 28 December 2005 10:34 Go to next message
Simon Meaden is currently offline Simon Meaden
Messages: 10
Registered: July 2009
Junior Member
Hi,

I am building a standalone application using SWT and am trying eclipse
3.2m4 which works fine. However when I try the standalone I get the
following error.

Unable to load graphics library [Cairo is required]
(java.lang.UnsatisfiedLinkError:
/opt/java-libs/lib/3.2m4/libswt-cairo-gtk-3218.so: /lib/libc.so.6: version
`GLIBC_2.4' not found (required by /usr/lib/libcairo.so.2))

Now assuming 3.2m4 is using the same libraries how do I access them for my
application. I am using the -Djava.library.path=/opt/java-libs/lib/3.2m4
switch which worked before. It looks like libc is for the wrong version of
GLibC. Any assistance would be appreciated, I could revert to the earlier
version if necessary but would prefer not.

Thanks
Simon Meaden
Re: 3.2m4 standalone problem [message #466141 is a reply to message #466002] Tue, 03 January 2006 12:37 Go to previous messageGo to next message
Veronika Irvine is currently offline Veronika Irvine
Messages: 1272
Registered: July 2009
Senior Member
Eclipse 3.2 M4 does not make use of any advanced graphics features so it
does not need to load the cairo library.

The cairo library you are picking up is one which you have installed
yourself. Eclipse no longer ships a cairo library in 3.2
See:
http://bugs.eclipse.org/bugs/show_bug.cgi?id=110924

Also see the post in this newsgroup "cairo no longer shipped with 3.2M3?".

"Simon Meaden" <simonmeaden@blueyonder.co.uk> wrote in message
news:ae1e933edb04e05612e2ad71ab9d39b2$1@www.eclipse.org...
> Hi,
>
> I am building a standalone application using SWT and am trying eclipse
> 3.2m4 which works fine. However when I try the standalone I get the
> following error.
>
> Unable to load graphics library [Cairo is required]
> (java.lang.UnsatisfiedLinkError:
> /opt/java-libs/lib/3.2m4/libswt-cairo-gtk-3218.so: /lib/libc.so.6: version
> `GLIBC_2.4' not found (required by /usr/lib/libcairo.so.2))
>
> Now assuming 3.2m4 is using the same libraries how do I access them for my
> application. I am using the -Djava.library.path=/opt/java-libs/lib/3.2m4
> switch which worked before. It looks like libc is for the wrong version of
> GLibC. Any assistance would be appreciated, I could revert to the earlier
> version if necessary but would prefer not.
>
> Thanks
> Simon Meaden
>
Re: 3.2m4 standalone problem [message #466183 is a reply to message #466141] Wed, 04 January 2006 13:07 Go to previous messageGo to next message
Charles Tuckey is currently offline Charles Tuckey
Messages: 18
Registered: July 2009
Junior Member
Veronika Irvine wrote:
> Eclipse 3.2 M4 does not make use of any advanced graphics features so it
> does not need to load the cairo library.
>
Hi Veronika,

I don't understand this. Ok, I understand it but I can't believe it's
true. Looking at the code for the GC class (linux-gtk) it makes cairo
calls all over the place. What am I not getting?

thanks,
charlie
Re: 3.2m4 standalone problem [message #466292 is a reply to message #466183] Thu, 05 January 2006 16:16 Go to previous message
Veronika Irvine is currently offline Veronika Irvine
Messages: 1272
Registered: July 2009
Senior Member
Cairo is used for advanced graphics like anti-aliasing, paths, patterns,
transformations. Once you are in advanced graphis mode, all the calls must
be made using the cairo library. If we are not in advanced graphics mode,
GC uses gdk calls.

You will notice in the GC code that the cairo calls are made after checking
if cairo != 0. The use of Cairo is initialized by calling
GC.setAdvanced(true) or by using advanced features such as
setAntiAlias(true).

For example look at GC.drawLine() - with Cario it uses cairo_move_to(),
cairo_stroke() etc otherwise it calls gdk_draw_line().

"Charles Tuckey" <charlest@otii.com> wrote in message
news:dph2uf$lii$1@utils.eclipse.org...
> Veronika Irvine wrote:
>> Eclipse 3.2 M4 does not make use of any advanced graphics features so it
>> does not need to load the cairo library.
>>
> Hi Veronika,
>
> I don't understand this. Ok, I understand it but I can't believe it's
> true. Looking at the code for the GC class (linux-gtk) it makes cairo
> calls all over the place. What am I not getting?
>
> thanks,
> charlie
Previous Topic:printing in gtk?
Next Topic:Drag and Drop feedback in Mac OS X
Goto Forum:
  


Current Time: Thu Aug 21 16:09:02 EDT 2014

Powered by FUDForum. Page generated in 0.02344 seconds