Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » What JARs are required to run a JFace App?
What JARs are required to run a JFace App? [message #433539] Sat, 10 April 2004 02:52 Go to next message
Pete is currently offline Pete
Messages: 26
Registered: July 2009
Junior Member
Hi,

I am just a newbie to SWT/Jface, I am using the latest Eclipse 3.0 M8,

from this: http://www-106.ibm.com/developerworks/library/os-ecgui1/

It said that I have to include the following JARs :

C:\eclipse-2.1.0\plugins\org.eclipse.jface_2.1.0\jface.jar
C:\eclipse-2.1.0\plugins\org.eclipse.runtime_2.1.0\runtime.j ar
C:\eclipse-2.1.0\plugins\org.eclipse.swt.win32_2.1.0\ws\win3 2\swt.jar
C:\eclipse-2.1.0\plugins\org.eclipse.ui.workbench_2.1.0\work bench.jar
C:\eclipse-2.1.0\plugins\org.eclipse.core.runtime_2.1.0\runt ime.jar

But I am using Eclipse 3.0 , I cannot find this
C:\eclipse-2.1.0\plugins\org.eclipse.runtime_2.1.0\runtime.j ar

So I have only included the rest of the JARs, the app can compile and
run, but the Menu cannot be showed.

Anyone can help?
Re: What JARs are required to run a JFace App? [message #433545 is a reply to message #433539] Sat, 10 April 2004 08:48 Go to previous messageGo to next message
Mike Lischke is currently offline Mike Lischke
Messages: 78
Registered: July 2009
Member
Pete wrote

>But I am using Eclipse 3.0 , I cannot find this
C:\eclipse-2.1.0\plugins\org.eclipse.runtime_2.1.0\runtime.j ar
>
>So I have only included the rest of the JARs, the app can compile and
run, but the Menu cannot be showed.

Well, you should have a bit more imagination. 3M8 is a beta so you cannot
expect that references for the release version of Eclipse fit also the
unofficial version. If you don't find org.eclipse.core.runtime_2.... but
instead org.eclipse.core.runtime_3... then it seems quite obvious to use
the latter. The same holds for the other packages.

Mike
--
www.soft-gems.net
Re: What JARs are required to run a JFace App? [message #433549 is a reply to message #433545] Sat, 10 April 2004 09:06 Go to previous message
Pete is currently offline Pete
Messages: 26
Registered: July 2009
Junior Member
Hi Mike,

I have found :

org.eclipse.core.runtime_3.0.0\runtime.jar

but not this :

org.eclipse.runtime_3.0.0\runtime.jar

I believe that should be "2" runtime.jar needed as said in the IBM'
tutorial ? Isn't ?

------------------
C:\eclipse-2.1.0\plugins\org.eclipse.jface_2.1.0\jface.jar
C:\eclipse-2.1.0\plugins\org.eclipse.runtime_2.1.0\runtime.j ar
C:\eclipse-2.1.0\plugins\org.eclipse.swt.win32_2.1.0\ws\win3 2\swt.jar
C:\eclipse-2.1.0\plugins\org.eclipse.ui.workbench_2.1.0\work bench.jar
C:\eclipse-2.1.0\plugins\org.eclipse.core.runtime_2.1.0\runt ime.jar
------------------

Pete

Mike Lischke wrote:
> Pete wrote
>
>> But I am using Eclipse 3.0 , I cannot find this
>
> C:\eclipse-2.1.0\plugins\org.eclipse.runtime_2.1.0\runtime.j ar
>
>>
>> So I have only included the rest of the JARs, the app can compile and
>
> run, but the Menu cannot be showed.
>
> Well, you should have a bit more imagination. 3M8 is a beta so you
> cannot expect that references for the release version of Eclipse fit
> also the unofficial version. If you don't find
> org.eclipse.core.runtime_2.... but instead org.eclipse.core.runtime_3...
> then it seems quite obvious to use the latter. The same holds for the
> other packages.
>
> Mike
Previous Topic:gap in table item
Next Topic:Removing the vertical scrollbar from the Browser
Goto Forum:
  


Current Time: Wed Aug 20 00:51:39 EDT 2014

Powered by FUDForum. Page generated in 0.01546 seconds