Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Menu.setImage() a bug?
Menu.setImage() a bug? [message #432776] Fri, 26 March 2004 03:12 Go to next message
lianhongwu is currently offline lianhongwuFriend
Messages: 17
Registered: July 2009
Junior Member
I want to build a menu.Every menuItem i do not call the method "setText()"
instead of "setImage(Image image)",but when display the menu,what i have
seen is that the image is not above the menuItem, but behind the menuItem.
But the first menuItem is right ,the image above the menuItem,the others
are not in the right position,why?
Re: Menu.setImage() a bug? [message #432787 is a reply to message #432776] Fri, 26 March 2004 14:26 Go to previous message
Steve Northover is currently offline Steve NorthoverFriend
Messages: 1636
Registered: July 2009
Senior Member
This was fixed recently on Windows to be *better*. Try it now and let us
know. There is a bug in Windows we are trying to work around ...

"sh" <java_programmer@sohu.com> wrote in message
news:c4072s$h3r$1@eclipse.org...
> I want to build a menu.Every menuItem i do not call the method "setText()"
> instead of "setImage(Image image)",but when display the menu,what i have
> seen is that the image is not above the menuItem, but behind the menuItem.
> But the first menuItem is right ,the image above the menuItem,the others
> are not in the right position,why?
>
Previous Topic:How to make the menu font size larger,
Next Topic:cannot change toolbar color
Goto Forum:
  


Current Time: Wed Nov 26 04:33:08 GMT 2014

Powered by FUDForum. Page generated in 0.04011 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software