Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Table problem on Windows
Table problem on Windows [message #432596] Wed, 24 March 2004 00:51 Go to next message
Sascha Zelzer is currently offline Sascha Zelzer
Messages: 11
Registered: July 2009
Junior Member
Hello!

I am developing a SWT/JFace app under Linux and tried it recently under
Windows. There all the SWT.Table widgets just don't display any rows -
under Linux they work as expected. I don't get any error messages and the
code for adding/removing rows seems to work (though the result is not
visible). I've tried with various recent integration builds and always got
the same behavior.
I would be happy for any hints...

Thanks,
Sascha
Re: Table problem on Windows [message #432640 is a reply to message #432596] Wed, 24 March 2004 16:20 Go to previous message
Sascha Zelzer is currently offline Sascha Zelzer
Messages: 11
Registered: July 2009
Junior Member
I did some further tests with the table widget and found out, that a
TableColumn.pack() call is required for Windows to show the table
(columns) initially. Under Linux this call is not needed, since the
columns adapt their width automatically to the table width.

Just if someone else runs into the same problem...

Sascha
Previous Topic:Multiple readAndDispatch() event loops?
Next Topic:Why doesnt my TableTreeViewer drilldown?
Goto Forum:
  


Current Time: Mon Sep 22 04:21:27 GMT 2014

Powered by FUDForum. Page generated in 0.01480 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software