Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Tableviewer editor problem
Tableviewer editor problem [message #432347] Fri, 19 March 2004 03:12 Go to next message
Aashish Patil is currently offline Aashish Patil
Messages: 39
Registered: July 2009
Member
Hi,
I tried the table viewer example from the eclipse articles section. However,
after modification of value and moving away from the cell, the cell still
displays the old value. If the cell is selected again, it does show the
modified value but it again reverts back to the old value after traversing
away from cell.

..I am using swt 2.1.2, jface 2.1.1

Thanks
Aashish

ps:
I posted this on eclipse.platform too but maybe that was not the right
group.
Re: Tableviewer editor problem [message #432349 is a reply to message #432347] Fri, 19 March 2004 05:40 Go to previous message
Aashish Patil is currently offline Aashish Patil
Messages: 39
Registered: July 2009
Member
Figured it out.

One needs to call TableViewer#refresh(element)
in the ICellEditor#modify(...)

Reg
Aashish
"Aashish Patil" <aashishpatil@hotmail.com> wrote in message
news:c3do5e$649$1@eclipse.org...
> Hi,
> I tried the table viewer example from the eclipse articles section.
However,
> after modification of value and moving away from the cell, the cell still
> displays the old value. If the cell is selected again, it does show the
> modified value but it again reverts back to the old value after traversing
> away from cell.
>
> .I am using swt 2.1.2, jface 2.1.1
>
> Thanks
> Aashish
>
> ps:
> I posted this on eclipse.platform too but maybe that was not the right
> group.
>
>
>
>
>
Previous Topic:How Can an IWizard Find the Extension ID That Launched it?
Next Topic:Modeless JFace Dialog?
Goto Forum:
  


Current Time: Wed Oct 01 14:17:11 GMT 2014

Powered by FUDForum. Page generated in 0.03082 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software