Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Problem porting plugin from Europa to Galileo
Problem porting plugin from Europa to Galileo [message #412751] Thu, 30 July 2009 09:08 Go to next message
Derek is currently offline DerekFriend
Messages: 60
Registered: July 2009
Member
Hi,

I am in the process of porting my feature/plugins from Europa to Galileo.

My source is in Subversion, so I have checked them out from the
repository into the Galileo PDE.

I am trying to use the Eclipse Product export wizard from within my
Branding plugin and am getting various dependency errors that I don't
understand.

For example:
Cannot complete the install because one or more required items could not
be found.
Software being installed: com.xxx.xxxx.brand.product 0.0.0
Missing requirement: XXXXX Utilities 2.1.0.200907300958
(com.xxx.xxxx 2.1.0.200907300958) requires 'bundle org.eclipse.ui 0.0.0'
but it could not be found

I have a dependency on org.eclipse.ui (without a min/max version number).

Any ideas on my problem (needless to say, this all works in Europa).
--
Derek
MoRe: Problem porting plugin from Europa to Galileo [message #415881 is a reply to message #412751] Thu, 30 July 2009 10:24 Go to previous messageGo to next message
Derek is currently offline DerekFriend
Messages: 60
Registered: July 2009
Member
More info:

I notice there is now a "Validate" button. pressing this shows me that
for every Eclipse dependency, I have an error. For example

Missing Constraint: Require-Bundle: org.eclipse.ui;bundle-version="3.5.0"

I have change the Properties for my dependency to have no Minimum
version (error report as above, but with a version of "0.0.0"), to have
a Minimum version (error as above) and to have both Minimum and a
Maximum versions (error report as above but with version "[3.2.0.3.5.0)"

Any ideas?

Derek wrote:
> Hi,
>
> I am in the process of porting my feature/plugins from Europa to Galileo.
>
> My source is in Subversion, so I have checked them out from the
> repository into the Galileo PDE.
>
> I am trying to use the Eclipse Product export wizard from within my
> Branding plugin and am getting various dependency errors that I don't
> understand.
>
> For example:
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: com.xxx.xxxx.brand.product 0.0.0
> Missing requirement: XXXXX Utilities 2.1.0.200907300958 (com.xxx.xxxx
> 2.1.0.200907300958) requires 'bundle org.eclipse.ui 0.0.0' but it could
> not be found
>
> I have a dependency on org.eclipse.ui (without a min/max version number).
>
> Any ideas on my problem (needless to say, this all works in Europa).


--
Derek
Re: MoRe: Problem porting plugin from Europa to Galileo [message #468043 is a reply to message #415881] Mon, 03 August 2009 18:10 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: eclipse-news.rizzoweb.com

Derek wrote:
> More info:
>
> I notice there is now a "Validate" button. pressing this shows me that
> for every Eclipse dependency, I have an error. For example
>
> Missing Constraint: Require-Bundle: org.eclipse.ui;bundle-version="3.5.0"
>
> I have change the Properties for my dependency to have no Minimum
> version (error report as above, but with a version of "0.0.0"), to have
> a Minimum version (error as above) and to have both Minimum and a
> Maximum versions (error report as above but with version "[3.2.0.3.5.0)"
>
> Any ideas?

Try removing and then re-adding the dependencies. That will force PDE to
use the latest (Galileo) versions of everything.

Hope this helps,
Eric


> Derek wrote:
>> Hi,
>>
>> I am in the process of porting my feature/plugins from Europa to Galileo.
>>
>> My source is in Subversion, so I have checked them out from the
>> repository into the Galileo PDE.
>>
>> I am trying to use the Eclipse Product export wizard from within my
>> Branding plugin and am getting various dependency errors that I don't
>> understand.
>>
>> For example:
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software being installed: com.xxx.xxxx.brand.product 0.0.0
>> Missing requirement: XXXXX Utilities 2.1.0.200907300958
>> (com.xxx.xxxx 2.1.0.200907300958) requires 'bundle org.eclipse.ui
>> 0.0.0' but it could not be found
>>
>> I have a dependency on org.eclipse.ui (without a min/max version number).
>>
>> Any ideas on my problem (needless to say, this all works in Europa).
>
>
Re: MoRe: Problem porting plugin from Europa to Galileo [message #468095 is a reply to message #468043] Tue, 04 August 2009 06:44 Go to previous messageGo to next message
Derek is currently offline DerekFriend
Messages: 60
Registered: July 2009
Member
Hi Eric,

I have tried that but it makes no difference.

One thing I have found is that if I uncheck the "Generate metadata
repository" checkbox, then I do not get the errors. So, this seesm to be
something caused by p2.

Any other thoughts?

Thanks

On 03/08/2009 19:10, Eric Rizzo wrote:
> Derek wrote:
>> More info:
>>
>> I notice there is now a "Validate" button. pressing this shows me that
>> for every Eclipse dependency, I have an error. For example
>>
>> Missing Constraint: Require-Bundle: org.eclipse.ui;bundle-version="3.5.0"
>>
>> I have change the Properties for my dependency to have no Minimum
>> version (error report as above, but with a version of "0.0.0"), to
>> have a Minimum version (error as above) and to have both Minimum and a
>> Maximum versions (error report as above but with version "[3.2.0.3.5.0)"
>>
>> Any ideas?
>
> Try removing and then re-adding the dependencies. That will force PDE to
> use the latest (Galileo) versions of everything.
>
> Hope this helps,
> Eric
>
>
>> Derek wrote:
>>> Hi,
>>>
>>> I am in the process of porting my feature/plugins from Europa to
>>> Galileo.
>>>
>>> My source is in Subversion, so I have checked them out from the
>>> repository into the Galileo PDE.
>>>
>>> I am trying to use the Eclipse Product export wizard from within my
>>> Branding plugin and am getting various dependency errors that I don't
>>> understand.
>>>
>>> For example:
>>> Cannot complete the install because one or more required items could
>>> not be found.
>>> Software being installed: com.xxx.xxxx.brand.product 0.0.0
>>> Missing requirement: XXXXX Utilities 2.1.0.200907300958 (com.xxx.xxxx
>>> 2.1.0.200907300958) requires 'bundle org.eclipse.ui 0.0.0' but it
>>> could not be found
>>>
>>> I have a dependency on org.eclipse.ui (without a min/max version
>>> number).
>>>
>>> Any ideas on my problem (needless to say, this all works in Europa).
>>
>>


--
Derek
MoRe: Problem porting plugin from Europa to Galileo [message #600150 is a reply to message #412751] Thu, 30 July 2009 10:24 Go to previous messageGo to next message
Derek is currently offline DerekFriend
Messages: 60
Registered: July 2009
Member
More info:

I notice there is now a "Validate" button. pressing this shows me that
for every Eclipse dependency, I have an error. For example

Missing Constraint: Require-Bundle: org.eclipse.ui;bundle-version="3.5.0"

I have change the Properties for my dependency to have no Minimum
version (error report as above, but with a version of "0.0.0"), to have
a Minimum version (error as above) and to have both Minimum and a
Maximum versions (error report as above but with version "[3.2.0.3.5.0)"

Any ideas?

Derek wrote:
> Hi,
>
> I am in the process of porting my feature/plugins from Europa to Galileo.
>
> My source is in Subversion, so I have checked them out from the
> repository into the Galileo PDE.
>
> I am trying to use the Eclipse Product export wizard from within my
> Branding plugin and am getting various dependency errors that I don't
> understand.
>
> For example:
> Cannot complete the install because one or more required items could not
> be found.
> Software being installed: com.xxx.xxxx.brand.product 0.0.0
> Missing requirement: XXXXX Utilities 2.1.0.200907300958 (com.xxx.xxxx
> 2.1.0.200907300958) requires 'bundle org.eclipse.ui 0.0.0' but it could
> not be found
>
> I have a dependency on org.eclipse.ui (without a min/max version number).
>
> Any ideas on my problem (needless to say, this all works in Europa).


--
Derek
Re: MoRe: Problem porting plugin from Europa to Galileo [message #600286 is a reply to message #415881] Mon, 03 August 2009 18:10 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2371
Registered: July 2009
Senior Member
Derek wrote:
> More info:
>
> I notice there is now a "Validate" button. pressing this shows me that
> for every Eclipse dependency, I have an error. For example
>
> Missing Constraint: Require-Bundle: org.eclipse.ui;bundle-version="3.5.0"
>
> I have change the Properties for my dependency to have no Minimum
> version (error report as above, but with a version of "0.0.0"), to have
> a Minimum version (error as above) and to have both Minimum and a
> Maximum versions (error report as above but with version "[3.2.0.3.5.0)"
>
> Any ideas?

Try removing and then re-adding the dependencies. That will force PDE to
use the latest (Galileo) versions of everything.

Hope this helps,
Eric


> Derek wrote:
>> Hi,
>>
>> I am in the process of porting my feature/plugins from Europa to Galileo.
>>
>> My source is in Subversion, so I have checked them out from the
>> repository into the Galileo PDE.
>>
>> I am trying to use the Eclipse Product export wizard from within my
>> Branding plugin and am getting various dependency errors that I don't
>> understand.
>>
>> For example:
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software being installed: com.xxx.xxxx.brand.product 0.0.0
>> Missing requirement: XXXXX Utilities 2.1.0.200907300958
>> (com.xxx.xxxx 2.1.0.200907300958) requires 'bundle org.eclipse.ui
>> 0.0.0' but it could not be found
>>
>> I have a dependency on org.eclipse.ui (without a min/max version number).
>>
>> Any ideas on my problem (needless to say, this all works in Europa).
>
>
Re: MoRe: Problem porting plugin from Europa to Galileo [message #600342 is a reply to message #468043] Tue, 04 August 2009 06:44 Go to previous messageGo to next message
Derek is currently offline DerekFriend
Messages: 60
Registered: July 2009
Member
Hi Eric,

I have tried that but it makes no difference.

One thing I have found is that if I uncheck the "Generate metadata
repository" checkbox, then I do not get the errors. So, this seesm to be
something caused by p2.

Any other thoughts?

Thanks

On 03/08/2009 19:10, Eric Rizzo wrote:
> Derek wrote:
>> More info:
>>
>> I notice there is now a "Validate" button. pressing this shows me that
>> for every Eclipse dependency, I have an error. For example
>>
>> Missing Constraint: Require-Bundle: org.eclipse.ui;bundle-version="3.5.0"
>>
>> I have change the Properties for my dependency to have no Minimum
>> version (error report as above, but with a version of "0.0.0"), to
>> have a Minimum version (error as above) and to have both Minimum and a
>> Maximum versions (error report as above but with version "[3.2.0.3.5.0)"
>>
>> Any ideas?
>
> Try removing and then re-adding the dependencies. That will force PDE to
> use the latest (Galileo) versions of everything.
>
> Hope this helps,
> Eric
>
>
>> Derek wrote:
>>> Hi,
>>>
>>> I am in the process of porting my feature/plugins from Europa to
>>> Galileo.
>>>
>>> My source is in Subversion, so I have checked them out from the
>>> repository into the Galileo PDE.
>>>
>>> I am trying to use the Eclipse Product export wizard from within my
>>> Branding plugin and am getting various dependency errors that I don't
>>> understand.
>>>
>>> For example:
>>> Cannot complete the install because one or more required items could
>>> not be found.
>>> Software being installed: com.xxx.xxxx.brand.product 0.0.0
>>> Missing requirement: XXXXX Utilities 2.1.0.200907300958 (com.xxx.xxxx
>>> 2.1.0.200907300958) requires 'bundle org.eclipse.ui 0.0.0' but it
>>> could not be found
>>>
>>> I have a dependency on org.eclipse.ui (without a min/max version
>>> number).
>>>
>>> Any ideas on my problem (needless to say, this all works in Europa).
>>
>>


--
Derek
Re: MoRe: Problem porting plugin from Europa to Galileo [message #752891 is a reply to message #600342] Wed, 26 October 2011 14:59 Go to previous message
Konrad Missing name is currently offline Konrad Missing nameFriend
Messages: 2
Registered: October 2011
Junior Member
Hello,

is there a solution to this issue?

I encounter the same problem when trying to export my feature-based product, with Eclipse 3.7 Indigo:

***
Cannot complete the install because one or more required items could not be found.
Software being installed: XXX 1.1.0.3 (com.yyy.zzz.product 1.1.0.3)
Missing requirement: Application 1.1.0.3 (com.yyy.zzz.app.feature.group 1.1.0.3) requires 'org.eclipse.ui.forms 0.0.0' but it could not be found
Cannot satisfy dependency:
***

Launching the application inside Eclipse works. Export with "Generate metadata repository" unchecked works, as reported by Derek, but this is unsatisfying. Removing and re-adding dependencies does not help. Setting a minimum version for org.eclipse.ui.forms does not help, too.

Any ideas?

Cheers,
Konrad
Previous Topic:product export fails in the IDE
Next Topic:Including folder with features & update site
Goto Forum:
  


Current Time: Thu Nov 27 13:33:30 GMT 2014

Powered by FUDForum. Page generated in 0.08209 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software