Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » Internal Error while generating *.gmfgen. what does it mean?
Internal Error while generating *.gmfgen. what does it mean? [message #40418] Wed, 06 September 2006 08:38 Go to next message
Alexander Haag is currently offline Alexander Haag
Messages: 114
Registered: July 2009
Senior Member
Hi @all,

I've got some problems with my generation of a graphical editor.
I'm stuck in generating the Diagram Gen Model file (*.gmfgen). I allways
get the error:

>>java.lang.IllegalStateException: Can't find genFeature for feature
'allNodes' in class SequenceType
at
>> org.eclipse.gmf.internal.bridge.genmodel.GenModelMatcher.fin dGenFeature(GenModelMatcher.java:102)
at
>> org.eclipse.gmf.internal.bridge.genmodel.DiagramGenModelTran sformer.findGenFeature(DiagramGenModelTransformer.java:646)
at
>> org.eclipse.gmf.internal.bridge.genmodel.DiagramGenModelTran sformer.setupModelFacet(DiagramGenModelTransformer.java:700)
at
>> org.eclipse.gmf.internal.bridge.genmodel.DiagramGenModelTran sformer.createModelFacet(DiagramGenModelTransformer.java:658 )
at
>> org.eclipse.gmf.internal.bridge.genmodel.DiagramGenModelTran sformer.process(DiagramGenModelTransformer.java:241)
at
>> org.eclipse.gmf.internal.bridge.genmodel.MappingTransformer. transform(MappingTransformer.java:32)
at
>> org.eclipse.gmf.internal.codegen.popup.actions.TransformToGe nModel$1.transform(TransformToGenModel.java:189)
at
>> org.eclipse.gmf.internal.codegen.popup.actions.TransformToGe nModel$1.run(TransformToGenModel.java:159)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

The class SequenceType contains both Getter and Setter for 'AllNodes' and
the generated SequenceTypeImpl has the entry:

>> /**
>> * The cached value of the '{@link #getAllNodes() <em>All Nodes</em>}'
containment reference.
>> * <!-- begin-user-doc -->
>> * <!-- end-user-doc -->
>> * @see #getAllNodes()
>> * @generated
>> * @ordered
>> */
>> protected NodeTYPE allNodes = null;

Could you please help me?
Is there a way to get some more Information what the error is about?
What is meant with 'genFeature' for feature AllNodes?

All hints, tips, and other help is very much appreciated
Greets Alex Haag
Sorry for the posting [message #40510 is a reply to message #40418] Wed, 06 September 2006 09:24 Go to previous messageGo to next message
Alexander Haag is currently offline Alexander Haag
Messages: 114
Registered: July 2009
Senior Member
Hi again,

I just realized, that I posted my question too early! I solved the problem
myself.

Here is the aswer:
The *.genmodel looked identical to the *.ecore-file, but it wasn't. I
looked at the *.genmodel-file with a text-editor and saw that it was out
of sync(the genFeature AllNodes did not exist).
I reloaded the genmodel-file from the ecore and it worked perfectly.

Next time, I promise, I'll look twice before I post my questions.

Shame on me and my apoligies

Alex Haag
Re: Internal Error while generating *.gmfgen. what does it mean? [message #40598 is a reply to message #40418] Wed, 06 September 2006 10:45 Go to previous message
Hallvard Traetteberg is currently offline Hallvard Traetteberg
Messages: 601
Registered: July 2009
Location: Trondheim, Norway
Senior Member
On Wed, 6 Sep 2006 08:38:45 +0000 (UTC), Alexander.Haag@esg.de
(AlexHaag) wrote:

>Hi @all,
>
>I've got some problems with my generation of a graphical editor.
>I'm stuck in generating the Diagram Gen Model file (*.gmfgen). I allways
>get the error:
>
>>>java.lang.IllegalStateException: Can't find genFeature for feature
>'allNodes' in class SequenceType

This has happened for me many times, and the reason was always that
the genmodel was out of sync with the ecore model. In addition, the
genmodel in memory was out of sync with the file, so even though I saw
the "missing" feature, it wasn't in the file that the gmfgen generator
read.

The solution was to delete genmodel and recreate it using the wizard.

Hallvard
Previous Topic:problem with update of layout model when changing the semantic model
Next Topic:Can an attribute refer to two ecore reference objects?
Goto Forum:
  


Current Time: Sat Oct 25 20:51:06 GMT 2014

Powered by FUDForum. Page generated in 0.01804 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software