Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » use of dynamic templates with Java 5
use of dynamic templates with Java 5 [message #396003] Tue, 04 October 2005 07:48 Go to next message
Henrik Rentz-Reichert is currently offline Henrik Rentz-ReichertFriend
Messages: 220
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------000400050206090409070004
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

Hi,

I would like to use dynamic templates in conjunction with Java 5.

When I do so I see a warning in the error log (see attachment) and the
code generation aborts silently.

I'm using eclipse
Version: 3.1.0
Build id: I20050627-1435

Eclipse Modeling Framework (EMF)
Version: 2.2.0.I200508040200
Build id: 200508040200

Regards,

Henrik

--
...............................................
Henrik Rentz-Reichert mailto://hrr@protos.de


--------------000400050206090409070004
Content-Type: text/plain;
name="log.txt"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;
filename="log.txt"

Warning 2005-10-04 09:38:24.17
java.lang.reflect.InvocationTargetException
at org.eclipse.jface.operation.ModalContext.run(ModalContext.ja va:327)
at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(Progress MonitorDialog.java:447)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$GenerateAction.run(GenModelActionBarCon tributor.java:295)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:996 )
at org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:538)
at org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:488)
at org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:400)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3080)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :2713)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:1699)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:367)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:143)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:103)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:226)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:376)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334 )
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)
Caused by: java.lang.UnsupportedClassVersionError: org/eclipse/emf/codegen/ecore/templates/model/Interface_ (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
at java.security.SecureClassLoader.defineClass(SecureClassLoade r.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at org.eclipse.emf.codegen.jet.JETEmitter.initialize(JETEmitter .java:472)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl$1.i nitialize(GenModelImpl.java:1355)
at org.eclipse.emf.codegen.jet.JETEmitter.generate(JETEmitter.j ava:592)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenBaseImpl.gene rate(GenBaseImpl.java:381)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenClassImpl.gen erate(GenClassImpl.java:1129)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenPackageImpl.g enerate(GenPackageImpl.java:2183)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl.gen erate(GenModelImpl.java:1742)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$8.generate(GenModelActionBarContributor .java:219)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$9.execute(GenModelActionBarContributor. java:279)
at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:98)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1719)
at org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:110)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:113)
Root exception:
java.lang.UnsupportedClassVersionError: org/eclipse/emf/codegen/ecore/templates/model/Interface_ (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
at java.security.SecureClassLoader.defineClass(SecureClassLoade r.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at org.eclipse.emf.codegen.jet.JETEmitter.initialize(JETEmitter .java:472)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl$1.i nitialize(GenModelImpl.java:1355)
at org.eclipse.emf.codegen.jet.JETEmitter.generate(JETEmitter.j ava:592)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenBaseImpl.gene rate(GenBaseImpl.java:381)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenClassImpl.gen erate(GenClassImpl.java:1129)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenPackageImpl.g enerate(GenPackageImpl.java:2183)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl.gen erate(GenModelImpl.java:1742)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$8.generate(GenModelActionBarContributor .java:219)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$9.execute(GenModelActionBarContributor. java:279)
at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:98)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1719)
at org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:110)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:113)


--------------000400050206090409070004--
Re: use of dynamic templates with Java 5 [message #396010 is a reply to message #396003] Tue, 04 October 2005 14:28 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 26221
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------070103070002060507070306
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Henrik,

It looks like you are trying to run something compiled for 1.5 in a 1.4
runtime, which doesn't work because the .class files produced by 1.5
can't be read by a 1.4 runtime...


Henrik Rentz-Reichert wrote:

>Hi,
>
>I would like to use dynamic templates in conjunction with Java 5.
>
>When I do so I see a warning in the error log (see attachment) and the
>code generation aborts silently.
>
>I'm using eclipse
>Version: 3.1.0
>Build id: I20050627-1435
>
>Eclipse Modeling Framework (EMF)
>Version: 2.2.0.I200508040200
>Build id: 200508040200
>
>Regards,
>
>Henrik
>
>
>
> ------------------------------------------------------------ ------------
>
>Warning 2005-10-04 09:38:24.17
>java.lang.reflect.InvocationTargetException
>at org.eclipse.jface.operation.ModalContext.run(ModalContext.ja va:327)
>at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(Progress MonitorDialog.java:447)
>at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$GenerateAction.run(GenModelActionBarCon tributor.java:295)
>at org.eclipse.jface.action.Action.runWithEvent(Action.java:996 )
>at org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:538)
>at org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:488)
>at org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:400)
>at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
>at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
>at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3080)
>at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :2713)
>at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:1699)
>at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
>at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:367)
>at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:143)
>at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:103)
>at org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:226)
>at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:376)
>at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:163)
>at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
>at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
>at java.lang.reflect.Method.invoke(Method.java:324)
>at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334 )
>at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
>at org.eclipse.core.launcher.Main.run(Main.java:973)
>at org.eclipse.core.launcher.Main.main(Main.java:948)
>Caused by: java.lang.UnsupportedClassVersionError: org/eclipse/emf/codegen/ecore/templates/model/Interface_ (Unsupported major.minor version 49.0)
>at java.lang.ClassLoader.defineClass0(Native Method)
>at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
>at java.security.SecureClassLoader.defineClass(SecureClassLoade r.java:123)
>at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
>at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
>at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
>at java.security.AccessController.doPrivileged(Native Method)
>at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
>at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
>at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
>at org.eclipse.emf.codegen.jet.JETEmitter.initialize(JETEmitter .java:472)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl$1.i nitialize(GenModelImpl.java:1355)
>at org.eclipse.emf.codegen.jet.JETEmitter.generate(JETEmitter.j ava:592)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenBaseImpl.gene rate(GenBaseImpl.java:381)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenClassImpl.gen erate(GenClassImpl.java:1129)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenPackageImpl.g enerate(GenPackageImpl.java:2183)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl.gen erate(GenModelImpl.java:1742)
>at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$8.generate(GenModelActionBarContributor .java:219)
>at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$9.execute(GenModelActionBarContributor. java:279)
>at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:98)
>at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1719)
>at org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:110)
>at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:113)
>Root exception:
>java.lang.UnsupportedClassVersionError: org/eclipse/emf/codegen/ecore/templates/model/Interface_ (Unsupported major.minor version 49.0)
>at java.lang.ClassLoader.defineClass0(Native Method)
>at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
>at java.security.SecureClassLoader.defineClass(SecureClassLoade r.java:123)
>at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
>at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
>at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
>at java.security.AccessController.doPrivileged(Native Method)
>at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
>at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
>at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
>at org.eclipse.emf.codegen.jet.JETEmitter.initialize(JETEmitter .java:472)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl$1.i nitialize(GenModelImpl.java:1355)
>at org.eclipse.emf.codegen.jet.JETEmitter.generate(JETEmitter.j ava:592)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenBaseImpl.gene rate(GenBaseImpl.java:381)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenClassImpl.gen erate(GenClassImpl.java:1129)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenPackageImpl.g enerate(GenPackageImpl.java:2183)
>at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl.gen erate(GenModelImpl.java:1742)
>at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$8.generate(GenModelActionBarContributor .java:219)
>at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$9.execute(GenModelActionBarContributor. java:279)
>at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:98)
>at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1719)
>at org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:110)
>at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:113)
>
>
>


--------------070103070002060507070306
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Henrik,<br>
<br>
It looks like you are trying to run something compiled for 1.5 in a 1.4
runtime, which doesn't work because the .class files produced by 1.5
can't be read by a 1.4 runtime...<br>
<br>
<br>
Henrik Rentz-Reichert wrote:
<blockquote cite="middhtc5j$59g$1@news.eclipse.org" type="cite">
<pre wrap="">Hi,

I would like to use dynamic templates in conjunction with Java 5.

When I do so I see a warning in the error log (see attachment) and the
code generation aborts silently.

I'm using eclipse
Version: 3.1.0
Build id: I20050627-1435

Eclipse Modeling Framework (EMF)
Version: 2.2.0.I200508040200
Build id: 200508040200

Regards,

Henrik

</pre>
<pre wrap="">
<hr size="4" width="90%">
Warning 2005-10-04 09:38:24.17
java.lang.reflect.InvocationTargetException
at org.eclipse.jface.operation.ModalContext.run(ModalContext.ja va:327)
at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(Progress MonitorDialog.java:447)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$GenerateAction.run(GenModelActionBarCon tributor.java:295)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:996 )
at org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:538)
at org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:488)
at org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:400)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3080)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :2713)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:1699)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:367)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:143)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplicatio n.java:103)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(Pl atformActivator.java:226)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:376)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334 )
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)
Caused by: java.lang.UnsupportedClassVersionError: org/eclipse/emf/codegen/ecore/templates/model/Interface_ (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
at java.security.SecureClassLoader.defineClass(SecureClassLoade r.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at org.eclipse.emf.codegen.jet.JETEmitter.initialize(JETEmitter .java:472)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl$1.i nitialize(GenModelImpl.java:1355)
at org.eclipse.emf.codegen.jet.JETEmitter.generate(JETEmitter.j ava:592)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenBaseImpl.gene rate(GenBaseImpl.java:381)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenClassImpl.gen erate(GenClassImpl.java:1129)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenPackageImpl.g enerate(GenPackageImpl.java:2183)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl.gen erate(GenModelImpl.java:1742)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$8.generate(GenModelActionBarContributor .java:219)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$9.execute(GenModelActionBarContributor. java:279)
at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:98)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1719)
at org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:110)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:113)
Root exception:
java.lang.UnsupportedClassVersionError: org/eclipse/emf/codegen/ecore/templates/model/Interface_ (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
at java.security.SecureClassLoader.defineClass(SecureClassLoade r.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at org.eclipse.emf.codegen.jet.JETEmitter.initialize(JETEmitter .java:472)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl$1.i nitialize(GenModelImpl.java:1355)
at org.eclipse.emf.codegen.jet.JETEmitter.generate(JETEmitter.j ava:592)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenBaseImpl.gene rate(GenBaseImpl.java:381)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenClassImpl.gen erate(GenClassImpl.java:1129)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenPackageImpl.g enerate(GenPackageImpl.java:2183)
at org.eclipse.emf.codegen.ecore.genmodel.impl.GenModelImpl.gen erate(GenModelImpl.java:1742)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$8.generate(GenModelActionBarContributor .java:219)
at org.eclipse.emf.codegen.ecore.genmodel.presentation.GenModel ActionBarContributor$9.execute(GenModelActionBarContributor. java:279)
at org.eclipse.ui.actions.WorkspaceModifyOperation$1.run(Worksp aceModifyOperation.java:98)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1719)
at org.eclipse.ui.actions.WorkspaceModifyOperation.run(Workspac eModifyOperation.java:110)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:113)

</pre>
</blockquote>
<br>
</body>
</html>

--------------070103070002060507070306--
Re: use of dynamic templates with Java 5 [message #396024 is a reply to message #396010] Wed, 05 October 2005 08:08 Go to previous message
Henrik Rentz-Reichert is currently offline Henrik Rentz-ReichertFriend
Messages: 220
Registered: July 2009
Senior Member
Ed,

thanks. That solved the problem.

Regards, Henrik

Ed Merks wrote:
> Henrik,
>
> It looks like you are trying to run something compiled for 1.5 in a 1.4
> runtime, which doesn't work because the .class files produced by 1.5
> can't be read by a 1.4 runtime...
>
>
> Henrik Rentz-Reichert wrote:
>
>>Hi,
>>
>>I would like to use dynamic templates in conjunction with Java 5.
>>
>>When I do so I see a warning in the error log (see attachment) and the
>>code generation aborts silently.
>>
>>I'm using eclipse
>>Version: 3.1.0
>>Build id: I20050627-1435
>>
>>Eclipse Modeling Framework (EMF)
>>Version: 2.2.0.I200508040200
>>Build id: 200508040200
>>
>>Regards,
>>
>>Henrik
>>
>>
>>


--
...............................................
Henrik Rentz-Reichert mailto://hrr@protos.de
Previous Topic:Access to EMF models
Next Topic:can the generator produce a log file
Goto Forum:
  


Current Time: Wed Nov 26 03:34:05 GMT 2014

Powered by FUDForum. Page generated in 0.15138 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software