Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » import from rsa model
import from rsa model [message #392187] Fri, 08 April 2005 10:35 Go to next message
Eclipse User
Originally posted by: chs.tipas.at

i need to import from rational software architect 6.0.

what i have done so far is:
- i have a working rational rose model which is used as emf model.
- i tried to import the rose model to the Rational Software Archtect (rsa
6.0.0.2), that worked so far ...
- and exported the model.ecore to a file from rsa.
- but i cannot create a genmodel from the exported ecore

can I load from rsa model directly ?
Re: import from rsa model [message #392191 is a reply to message #392187] Fri, 08 April 2005 11:56 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 25942
Registered: July 2009
Senior Member
Chris,

EMF directly supports .mdl/.cat/.ecore/.emof/.xsd import using
"File->Project.->Eclipse Modeling Framework->EMF Project" or
"File->New->Other...->Eclipse Modeling Framework->EMF Models".

RSA won't create a .genmodel directly.


chris.schaefer wrote:

>i need to import from rational software architect 6.0.
>
>what i have done so far is:
>- i have a working rational rose model which is used as emf model.
>- i tried to import the rose model to the Rational Software Archtect (rsa
>6.0.0.2), that worked so far ...
>- and exported the model.ecore to a file from rsa.
>- but i cannot create a genmodel from the exported ecore
>
>can I load from rsa model directly ?
>
>
>
>
>
>
>
>
>
>
Re: import from rsa model [message #392202 is a reply to message #392191] Sun, 10 April 2005 08:14 Go to previous messageGo to next message
Eclipse User
Originally posted by: cgs.cgs.at

does that mean, that i can directly create the emf.genmodel from rsa files ?


"Ed Merks" <merks@ca.ibm.com> schrieb im Newsbeitrag
news:d369sl$84u$1@news.eclipse.org...
> Chris,
>
> EMF directly supports .mdl/.cat/.ecore/.emof/.xsd import using
> "File->Project.->Eclipse Modeling Framework->EMF Project" or
> "File->New->Other...->Eclipse Modeling Framework->EMF Models".
>
> RSA won't create a .genmodel directly.
>
>
> chris.schaefer wrote:
>
> >i need to import from rational software architect 6.0.
> >
> >what i have done so far is:
> >- i have a working rational rose model which is used as emf model.
> >- i tried to import the rose model to the Rational Software Archtect (rsa
> >6.0.0.2), that worked so far ...
> >- and exported the model.ecore to a file from rsa.
> >- but i cannot create a genmodel from the exported ecore
> >
> >can I load from rsa model directly ?
> >
> >
> >
> >
> >
> >
> >
> >
> >
> >
Re: import from rsa model [message #392204 is a reply to message #392202] Sun, 10 April 2005 17:36 Go to previous messageGo to next message
Kenn Hussey is currently offline Kenn Hussey
Messages: 1618
Registered: July 2009
Senior Member
Christian,

You cannot create a generator model directly from an RSA model. You must
first convert it to Ecore and use that as input to the EMF project wizard...

Kenn

"christain schaefer" <cgs@cgs.at> wrote in message
news:d3b590$hfn$1@news.eclipse.org...
> does that mean, that i can directly create the emf.genmodel from rsa files
?
>
>
> "Ed Merks" <merks@ca.ibm.com> schrieb im Newsbeitrag
> news:d369sl$84u$1@news.eclipse.org...
> > Chris,
> >
> > EMF directly supports .mdl/.cat/.ecore/.emof/.xsd import using
> > "File->Project.->Eclipse Modeling Framework->EMF Project" or
> > "File->New->Other...->Eclipse Modeling Framework->EMF Models".
> >
> > RSA won't create a .genmodel directly.
> >
> >
> > chris.schaefer wrote:
> >
> > >i need to import from rational software architect 6.0.
> > >
> > >what i have done so far is:
> > >- i have a working rational rose model which is used as emf model.
> > >- i tried to import the rose model to the Rational Software Archtect
(rsa
> > >6.0.0.2), that worked so far ...
> > >- and exported the model.ecore to a file from rsa.
> > >- but i cannot create a genmodel from the exported ecore
> > >
> > >can I load from rsa model directly ?
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
>
>
Re: import from rsa model [message #392206 is a reply to message #392204] Mon, 11 April 2005 04:01 Go to previous messageGo to next message
Eclipse User
Originally posted by: chs.tipas.at

this is what we already have tried:
within rsa we:
- exported the ecore file from RSA by using file->export -> ecore
- then opened the emf-model wizzard, selected the exported ecore file.
- on finish see exception attachedment, the wizzard dialog stay
  • Attachment: emfgen.err
    (Size: 6.28KB, Downloaded 11 times)
Re: import from rsa model [message #392209 is a reply to message #392187] Mon, 11 April 2005 06:55 Go to previous messageGo to next message
Martin Vlk is currently offline Martin Vlk
Messages: 55
Registered: July 2009
Member
Hi Chris,
RSA models are UML2 models with some extensions. Presumably you could
use UML2 to load the RSA models directly, providing you have access to
the UML profiles applied to the RSA model.

I have done some work in this area and it look like it will work.

Martin

chris.schaefer wrote:
> i need to import from rational software architect 6.0.
>
> what i have done so far is:
> - i have a working rational rose model which is used as emf model.
> - i tried to import the rose model to the Rational Software Archtect (rsa
> 6.0.0.2), that worked so far ...
> - and exported the model.ecore to a file from rsa.
> - but i cannot create a genmodel from the exported ecore
>
> can I load from rsa model directly ?
Re: import from rsa model [message #392220 is a reply to message #392187] Mon, 11 April 2005 08:48 Go to previous messageGo to next message
Eclipse User
Originally posted by: chs.tipas.at

what i found out so far:
the problem is, that the emf-wizzard that uses rational rose directly, skips
informationion from the component view, logical view or etc.
all this additonal rose information is included in the model if you generate
from rsa2ecore after importing from rose.

we now have generated a new empty project and copied the information to a
class diagram only, that helped a bit, but there are still some elements
(relationships) which are wrong or got corrupted during this process of
moving around ;-))

cgs


"chris.schaefer" <chs@tipas.at> schrieb im Newsbeitrag
news:d3653e$165$1@news.eclipse.org...
>i need to import from rational software architect 6.0.
>
> what i have done so far is:
> - i have a working rational rose model which is used as emf model.
> - i tried to import the rose model to the Rational Software Archtect (rsa
> 6.0.0.2), that worked so far ...
> - and exported the model.ecore to a file from rsa.
> - but i cannot create a genmodel from the exported ecore
>
> can I load from rsa model directly ?
>
>
>
>
>
>
>
>
Re: import from rsa model [message #392225 is a reply to message #392206] Mon, 11 April 2005 10:41 Go to previous messageGo to next message
Peter Manahan is currently offline Peter Manahan
Messages: 131
Registered: July 2009
Senior Member
chris.schaefer wrote:
> this is what we already have tried:
> within rsa we:
> - exported the ecore file from RSA by using file->export -> ecore
> - then opened the emf-model wizzard, selected the exported ecore file.
> - on finish see exception attachedment, the wizzard dialog stay┬┤s open.
>
> lg,
> chris
>

I've found that renaming the RSA model names to remove spaces and "."
chars in the model name seems to fix many of the problems on importing
into ecore. Worth a shot anyway.

Peter
Re: import from rsa model [message #392226 is a reply to message #392220] Mon, 11 April 2005 10:51 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 25942
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------020100040207010700060306
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Chris,

So are you stuck or still making progress?


chris.schaefer wrote:

>what i found out so far:
>the problem is, that the emf-wizzard that uses rational rose directly, skips
>informationion from the component view, logical view or etc.
>all this additonal rose information is included in the model if you generate
>from rsa2ecore after importing from rose.
>
>we now have generated a new empty project and copied the information to a
>class diagram only, that helped a bit, but there are still some elements
>(relationships) which are wrong or got corrupted during this process of
>moving around ;-))
>
>cgs
>
>
>"chris.schaefer" <chs@tipas.at> schrieb im Newsbeitrag
>news:d3653e$165$1@news.eclipse.org...
>
>
>>i need to import from rational software architect 6.0.
>>
>>what i have done so far is:
>>- i have a working rational rose model which is used as emf model.
>>- i tried to import the rose model to the Rational Software Archtect (rsa
>>6.0.0.2), that worked so far ...
>>- and exported the model.ecore to a file from rsa.
>>- but i cannot create a genmodel from the exported ecore
>>
>>can I load from rsa model directly ?
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>
>
>
>


--------------020100040207010700060306
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Chris,<br>
<br>
So are you stuck or still making progress?<br>
<br>
<br>
chris.schaefer wrote:
<blockquote cite="midd3ds0f$ljv$1@news.eclipse.org" type="cite">
<pre wrap="">what i found out so far:
the problem is, that the emf-wizzard that uses rational rose directly, skips
informationion from the component view, logical view or etc.
all this additonal rose information is included in the model if you generate
from rsa2ecore after importing from rose.

we now have generated a new empty project and copied the information to a
class diagram only, that helped a bit, but there are still some elements
(relationships) which are wrong or got corrupted during this process of
moving around ;-))

cgs


"chris.schaefer" <a class="moz-txt-link-rfc2396E" href="mailto:chs@tipas.at">&lt;chs@tipas.at&gt;</a> schrieb im Newsbeitrag
<a class="moz-txt-link-freetext" href="news:d3653e$165$1@news.eclipse.org">news:d3653e$165$1@news.eclipse.org</a>...
</pre>
<blockquote type="cite">
<pre wrap="">i need to import from rational software architect 6.0.

what i have done so far is:
- i have a working rational rose model which is used as emf model.
- i tried to import the rose model to the Rational Software Archtect (rsa
6.0.0.2), that worked so far ...
- and exported the model.ecore to a file from rsa.
- but i cannot create a genmodel from the exported ecore

can I load from rsa model directly ?








</pre>
</blockquote>
<pre wrap=""><!---->

</pre>
</blockquote>
<br>
</body>
</html>

--------------020100040207010700060306--
Re: import from rsa model [message #392229 is a reply to message #392226] Mon, 11 April 2005 12:46 Go to previous message
Eclipse User
Originally posted by: chs.tipas.at

This is a multi-part message in MIME format.

------=_NextPart_000_0224_01C53EC6.D79AF2B0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

thanks!
currently i am making progress, step by step.=20

currently the basic model looks fine, but some classes lost/misses the =
interfaces they should extend from ...

chris



"Ed Merks" <merks@ca.ibm.com> schrieb im Newsbeitrag =
news:d3e376$1pn$1@news.eclipse.org...
Chris,

So are you stuck or still making progress?


chris.schaefer wrote:=20
what i found out so far:
the problem is, that the emf-wizzard that uses rational rose directly, =
skips=20
informationion from the component view, logical view or etc.
all this additonal rose information is included in the model if you =
generate=20
from rsa2ecore after importing from rose.

we now have generated a new empty project and copied the information to =
a=20
class diagram only, that helped a bit, but there are still some elements =

(relationships) which are wrong or got corrupted during this process of=20
moving around ;-))

cgs


"chris.schaefer" <chs@tipas.at> schrieb im Newsbeitrag=20
news:d3653e$165$1@news.eclipse.org...
i need to import from rational software architect 6.0.

what i have done so far is:
- i have a working rational rose model which is used as emf model.
- i tried to import the rose model to the Rational Software Archtect =
(rsa=20
6.0.0.2), that worked so far ...
- and exported the model.ecore to a file from rsa.
- but i cannot create a genmodel from the exported ecore

can I load from rsa model directly ?








=20

=20

------=_NextPart_000_0224_01C53EC6.D79AF2B0
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type =
content=3Dtext/html;charset=3DISO-8859-1>
<META content=3D"MSHTML 6.00.2900.2180" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY text=3D#000000 bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>thanks!</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>currently </FONT><FONT face=3DArial =
size=3D2>i am=20
making progress, step by step. </FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>currently the basic model looks fine, =
but some=20
classes lost/misses the interfaces they should extend =
from&nbsp;...</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>chris</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<BLOCKQUOTE=20
style=3D"PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; =
BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
<DIV>"Ed Merks" &lt;<A =
href=3D"mailto:merks@ca.ibm.com">merks@ca.ibm.com</A>&gt;=20
schrieb im Newsbeitrag <A=20
=
href=3D"news:d3e376$1pn$1@news.eclipse.org">news:d3e376$1pn$1@news.eclips=
e.org</A>...</DIV>Chris,<BR><BR>So=20
are you stuck or still making progress?<BR><BR><BR>chris.schaefer =
wrote:=20
<BLOCKQUOTE cite=3Dmidd3ds0f$ljv$1@news.eclipse.org type=3D"cite"><PRE =
wrap=3D"">what i found out so far:
the problem is, that the emf-wizzard that uses rational rose directly, =
skips=20
informationion from the component view, logical view or etc.
all this additonal rose information is included in the model if you =
generate=20
from rsa2ecore after importing from rose.

we now have generated a new empty project and copied the information to =
a=20
class diagram only, that helped a bit, but there are still some elements =

(relationships) which are wrong or got corrupted during this process of=20
moving around ;-))

cgs


"chris.schaefer" <A class=3Dmoz-txt-link-rfc2396E =
href=3D"mailto:chs@tipas.at">&lt;chs@tipas.at&gt;</A> schrieb im =
Newsbeitrag=20
<A class=3Dmoz-txt-link-freetext =
href=3D"news:d3653e$165$1@news.eclipse.org">news:d3653e$165$1@news.eclips=
e.org</A>...
</PRE>
<BLOCKQUOTE type=3D"cite"><PRE wrap=3D"">i need to import from =
rational software architect 6.0.

what i have done so far is:
- i have a working rational rose model which is used as emf model.
- i tried to import the rose model to the Rational Software Archtect =
(rsa=20
6.0.0.2), that worked so far ...
- and exported the model.ecore to a file from rsa.
- but i cannot create a genmodel from the exported ecore

can I load from rsa model directly ?








</PRE></BLOCKQUOTE><PRE wrap=3D""><!---->

</PRE></BLOCKQUOTE><BR></BLOCKQUOTE></BODY></HTML>

------=_NextPart_000_0224_01C53EC6.D79AF2B0--
Previous Topic:Externalizing strings in EMF Generated classes
Next Topic:controlling URI serialization in hRefs
Goto Forum:
  


Current Time: Tue Jul 29 19:03:05 EDT 2014

Powered by FUDForum. Page generated in 0.03176 seconds