Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Buckminster » problem resolving with CVS- The {0} character is illegal in a branch/tag qualifier
problem resolving with CVS- The {0} character is illegal in a branch/tag qualifier [message #387648] Tue, 07 July 2009 00:16 Go to next message
Eclipse UserFriend
Originally posted by: pereza.gsicommerce.com

Hi all,

I get this error but I can't figure out why. Any help would be much appreciated!

eclipse.buildId=M20090211-1700
java.version=1.6.0_14

java.lang.IllegalArgumentException: The {0} character is illegal in a branch/tag qualifier
at
org.eclipse.buckminster.core.version.VersionSelector.fromStr ing(VersionSelector.java:168)
at
org.eclipse.buckminster.core.version.VersionSelector.branch( VersionSelector.java:45)
at
org.eclipse.buckminster.core.version.AbstractSCCSVersionFind er.getBestBranchOrTagMatch(AbstractSCCSVersionFinder.java:25 2)
at
org.eclipse.buckminster.core.version.AbstractSCCSVersionFind er.getBestBranchOrTagMatch(AbstractSCCSVersionFinder.java:18 5)
at
org.eclipse.buckminster.core.version.AbstractSCCSVersionFind er.getBestVersion(AbstractSCCSVersionFinder.java:141)
at
org.eclipse.buckminster.core.rmap.model.Provider.findMatch(P rovider.java:236)
at
org.eclipse.buckminster.core.rmap.model.SearchPath.getProvid er(SearchPath.java:115)
at
org.eclipse.buckminster.core.rmap.model.ResourceMap.resolve( ResourceMap.java:220)
at
org.eclipse.buckminster.core.resolver.ResourceMapResolver.in nerResolve(ResourceMapResolver.java:165)
at
org.eclipse.buckminster.core.resolver.ResolverNodeWithJob.re solve(ResolverNodeWithJob.java:177)
at
org.eclipse.buckminster.core.resolver.ResolverNodeWithJob.ru n(ResolverNodeWithJob.java:187)
at
org.eclipse.buckminster.core.resolver.ResolverNodeWithJob$No deResolutionJob.run(ResolverNodeWithJob.java:60)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
Re: problem resolving with CVS- The {0} character is illegal in a branch/tag qualifier [message #387649 is a reply to message #387648] Tue, 07 July 2009 00:55 Go to previous message
Henrik Lindberg is currently offline Henrik LindbergFriend
Messages: 2509
Registered: July 2009
Senior Member
Hi,
Can you post the RMAP you are using? Possibly also the CQuery, and any
properties set when running the query.

The {0} problem sounds like some formatting is not taking place like you
expect it to.

- henrik

Arturo Perez wrote:
> Hi all,
>
> I get this error but I can't figure out why. Any help would be much appreciated!
>
> eclipse.buildId=M20090211-1700
> java.version=1.6.0_14
>
> java.lang.IllegalArgumentException: The {0} character is illegal in a branch/tag qualifier
> at
> org.eclipse.buckminster.core.version.VersionSelector.fromStr ing(VersionSelector.java:168)
> at
Previous Topic:Buckminster 3.5 install issues
Next Topic:Problems materializing target platform
Goto Forum:
  


Current Time: Tue Jan 21 10:49:23 GMT 2020

Powered by FUDForum. Page generated in 0.03185 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top