Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Buckminster and gwt dependecies
Buckminster and gwt dependecies [message #382741] Wed, 04 February 2009 16:57 Go to next message
Frank is currently offline FrankFriend
Messages: 49
Registered: July 2009
Member
Hello,

I'm actually working on a GWT Project with Eclipse. I would like to
manage my dependencies through buckminster. I need to retrieve two gwt
1.5.3 libraries from maven central repository : gwt-user and gwt-dev.

* gwt-user: 1.4.60 retrieval works fine but 1.5.3 doesn't work.

<cs:dependency name="com.google.dev/gwt-dev"
componentType="maven"
versionDesignator="[1.4.62,1.4.62]"
versionType="OSGi"
filter="(target.os=linux)"/>


* gwt-dev : The maven repository had three versions, mac, linux and
windows. The os version is described through the classifier
attribute.Heres is my main problem : I did not find anything to ask to
buckminster for chosing a specific classifier. So I got an unresolved
error when I try to resolve the query.

<cs:dependency name="com.google.gwt/gwt-user"
componentType="maven"
versionDesignator="[1.5.3,1.5.3]"
versionType="OSGi"/>

Do you have any ideas ?

Regards,

Frank
Re: Buckminster and gwt dependecies [message #382783 is a reply to message #382741] Mon, 16 February 2009 17:03 Go to previous message
Frank is currently offline FrankFriend
Messages: 49
Registered: July 2009
Member
Hello,

I solve my problem with gwt-user, but I still can't set the
classifier for gwt-dev library. Does anyone knows how to set it in the
component specification file ?

Actually I got these lines in my component specification file :
<cs:dependency name="com.google.gwt/gwt-dev"
componentType="maven"
versionDesignator="[1.5.3,1.5.3]"
versionType="String" />

Regards,

Frank


Frank a écrit :
> Hello,
>
> I'm actually working on a GWT Project with Eclipse. I would like to
> manage my dependencies through buckminster. I need to retrieve two gwt
> 1.5.3 libraries from maven central repository : gwt-user and gwt-dev.
>
> * gwt-user: 1.4.60 retrieval works fine but 1.5.3 doesn't work.
>
> <cs:dependency name="com.google.dev/gwt-dev"
> componentType="maven"
> versionDesignator="[1.4.62,1.4.62]"
> versionType="OSGi"
> filter="(target.os=linux)"/>
>
>
> * gwt-dev : The maven repository had three versions, mac, linux and
> windows. The os version is described through the classifier
> attribute.Heres is my main problem : I did not find anything to ask to
> buckminster for chosing a specific classifier. So I got an unresolved
> error when I try to resolve the query.
>
> <cs:dependency name="com.google.gwt/gwt-user"
> componentType="maven"
> versionDesignator="[1.5.3,1.5.3]"
> versionType="OSGi"/>
>
> Do you have any ideas ?
>
> Regards,
>
> Frank
Previous Topic:The project cannot be built until its prerequisite x.y.z is built
Next Topic:Problems resolving from CVS
Goto Forum:
  


Current Time: Thu Dec 18 10:35:21 GMT 2014

Powered by FUDForum. Page generated in 0.09727 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software