Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » targetPlatformPath and installLocation
targetPlatformPath and installLocation [message #381424] Mon, 01 December 2008 12:09 Go to next message
Markus Kuppe is currently offline Markus Kuppe
Messages: 177
Registered: July 2009
Senior Member
Hi,

buckminster setpref targetPlatformPath=/foo/bar
buckminster import mymspec.mspec

still causes BM to materialize to ${buckminster.home} whereas I expect
it to use ${targetPlatformPath} instead (if installLocation isn't set in
the mspec). Is this a bug?

As a workaround how does one pass the installLocation property to BM to
set the mspec var without using a properties file?

Markus
Re: targetPlatformPath and installLocation [message #381426 is a reply to message #381424] Mon, 01 December 2008 13:11 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
Markus Alexander Kuppe wrote:
> Hi,
>
> buckminster setpref targetPlatformPath=/foo/bar
> buckminster import mymspec.mspec
>
> still causes BM to materialize to ${buckminster.home} whereas I expect
> it to use ${targetPlatformPath} instead (if installLocation isn't set in
> the mspec). Is this a bug?
>
Yes, this sounds like a bug. It should select whatever TP that is
defined in the WS that you're using. Can you please report it?

Thanks,
Thomas Hallgren
Re: targetPlatformPath and installLocation [message #381428 is a reply to message #381426] Mon, 01 December 2008 13:39 Go to previous message
Markus Kuppe is currently offline Markus Kuppe
Messages: 177
Registered: July 2009
Senior Member
Thomas Hallgren wrote:
> Markus Alexander Kuppe wrote:
>> Hi,
>>
>> buckminster setpref targetPlatformPath=/foo/bar
>> buckminster import mymspec.mspec
>>
>> still causes BM to materialize to ${buckminster.home} whereas I expect
>> it to use ${targetPlatformPath} instead (if installLocation isn't set in
>> the mspec). Is this a bug?
>>
> Yes, this sounds like a bug. It should select whatever TP that is
> defined in the WS that you're using. Can you please report it?

https://bugs.eclipse.org/bugs/show_bug.cgi?id=257069
Previous Topic:eclipse.build actor failed - cannot find java.lang.Enum; Java 1.5 compliance preference set
Next Topic:SVN content materialization
Goto Forum:
  


Current Time: Thu Sep 18 17:55:34 GMT 2014

Powered by FUDForum. Page generated in 0.02169 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software