Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Difference on ReportDesignHandle between onPrepare and beforeFactory
Difference on ReportDesignHandle between onPrepare and beforeFactory [message #366436] Tue, 30 December 2008 17:17 Go to next message
Loïc Bertholet is currently offline Loïc BertholetFriend
Messages: 57
Registered: July 2009
Member
Hi all,

I want to dynamically add columns on a Table.

I tried on the beforeFactory(...) method of ReportEventHandler and
everything is alright.
Then I tried on the onPrepare(...) method of TableEventHandler with the
same code but it didn't work.

It both case, I use the following code to get the TableHandle :
(TableHandle) reportContext.getDesignHandle().findElement("myTableName")

With the debugger, I saw that I have the same instance of reportContext in
each method. But the ReportDesignHandle behind is not the same... I guess
this is why I don't have the same final result.

But is it normal or is it a bug ?
Or maybe I don't use the good way to get the TableHandle on the
onPrepare(...) method ?

Thanks,

Loïc
Re: Difference on ReportDesignHandle between onPrepare and beforeFactory [message #366442 is a reply to message #366436] Tue, 30 December 2008 22:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jasonweathersby.alltel.net

Loïc,

I believe it is getting a cloned version of the design handle.
Can you log a bug for this?

Jason


Loïc Bertholet wrote:
> Hi all,
>
> I want to dynamically add columns on a Table.
>
> I tried on the beforeFactory(...) method of ReportEventHandler and
> everything is alright.
> Then I tried on the onPrepare(...) method of TableEventHandler with the
> same code but it didn't work.
>
> It both case, I use the following code to get the TableHandle :
> (TableHandle) reportContext.getDesignHandle().findElement("myTableName")
>
> With the debugger, I saw that I have the same instance of reportContext
> in each method. But the ReportDesignHandle behind is not the same... I
> guess this is why I don't have the same final result.
>
> But is it normal or is it a bug ?
> Or maybe I don't use the good way to get the TableHandle on the
> onPrepare(...) method ?
>
> Thanks,
>
> Loïc
>
Re: Difference on ReportDesignHandle between onPrepare and beforeFactory [message #366481 is a reply to message #366442] Mon, 05 January 2009 14:30 Go to previous message
Loïc Bertholet is currently offline Loïc BertholetFriend
Messages: 57
Registered: July 2009
Member
Ok it's done : https://bugs.eclipse.org/bugs/show_bug.cgi?id=259948
Previous Topic:Interactive report
Next Topic:BIRT 2.3.1 slower than 2.2.0
Goto Forum:
  


Current Time: Mon Dec 22 04:29:15 GMT 2014

Powered by FUDForum. Page generated in 0.11874 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software