Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Error when creating new BIRT report
Error when creating new BIRT report [message #366345] Wed, 17 December 2008 08:49 Go to next message
Eclipse User
Originally posted by: asd.asd.com

I have installed BIRT 2.3.1 on eclipse 3.4.1 for Windows Vista 32. I have
then created a new BIRT project and in that project created a Simple Report
(.rptdesign file). The report loads fine but I get the error:

"The Table must be able to access one data set."

When I switch to the XML source view the error is in this line:

....
<table id="4">
....

from this context:

</text>
</page-footer>
</simple-master-page>
</page-setup>
<body>
<table id="4"> // HERE!
<property name="width">100%</property>
<property name="pageBreakInterval">50</property>
<column id="20"/>
<column id="21"/>
<column id="22"/>


I have tried to add a XML data Source and specify and XML file with some
content. Next I also specified a Data Set (using the XML file) which I
successfully setup. But the error is still there, any ideas?
Re: Error when creating new BIRT report [message #366350 is a reply to message #366345] Wed, 17 December 2008 11:06 Go to previous message
Eclipse User
Originally posted by: asd.asd.com

Problem solved, just needed to add (drag/drop) some data.

"bob" <asd@asd.com> wrote in message news:gib01p$qde$1@build.eclipse.org...
>I have installed BIRT 2.3.1 on eclipse 3.4.1 for Windows Vista 32. I have
>then created a new BIRT project and in that project created a Simple Report
>(.rptdesign file). The report loads fine but I get the error:
>
> "The Table must be able to access one data set."
>
> When I switch to the XML source view the error is in this line:
>
> ...
> <table id="4">
> ...
>
> from this context:
>
> </text>
> </page-footer>
> </simple-master-page>
> </page-setup>
> <body>
> <table id="4"> // HERE!
> <property name="width">100%</property>
> <property name="pageBreakInterval">50</property>
> <column id="20"/>
> <column id="21"/>
> <column id="22"/>
>
>
> I have tried to add a XML data Source and specify and XML file with some
> content. Next I also specified a Data Set (using the XML file) which I
> successfully setup. But the error is still there, any ideas?
Previous Topic:Dynamic text with HTML is missing strikethrough in PDF?
Next Topic:rename legend of pie chart
Goto Forum:
  


Current Time: Mon Sep 01 03:44:43 EDT 2014

Powered by FUDForum. Page generated in 0.01599 seconds