Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » disable use of socks proxy in 3.5
disable use of socks proxy in 3.5 [message #336516] Thu, 18 June 2009 09:52 Go to next message
Jens is currently offline Jens
Messages: 3
Registered: July 2009
Junior Member
Hi,

is there a way of disabling the use of the socks proxy in eclipse 3.5?
I'm not able to do this in the prefs gui, and I think the proxy I'm behind
only offers http/https (I get a java.net.SocketException: Malformed reply
from SOCKS server).

Thx,
Jens
Re: disable use of socks proxy in 3.5 [message #336520 is a reply to message #336516] Thu, 18 June 2009 13:11 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Jens wrote:
> Hi,
>
> is there a way of disabling the use of the socks proxy in eclipse 3.5?
> I'm not able to do this in the prefs gui, and I think the proxy I'm
> behind only offers http/https (I get a java.net.SocketException:
> Malformed reply from SOCKS server).

"not about to do this in the prefs" ... you mean you can't find the
prefs, or when you change the SOCKS pref it does nothing?

The network connection prefs are in "Preferences>General>Network
Connections"

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/ganymede/index.jsp?topic=/org.eclips e.platform.doc.isv/guide/workbench.htm


Re: disable use of socks proxy in 3.5 [message #336549 is a reply to message #336520] Mon, 22 June 2009 07:36 Go to previous messageGo to next message
Jens is currently offline Jens
Messages: 3
Registered: July 2009
Junior Member
OK, in 3.4.2 I took "System proxy configuration" and it works. In 3.5,
(20090611-1022) using either the "native" or manual provider does not
work. My assumtion was that this comes from trying to use the given proxy
as a socks proxy (which I think is not possible for the proxy here).
So I was seeking a way of disabling the use of the socks proxy. But the
checkboxes in the "Network Connections" Preferences are only changeable by
the choose of an "Active provider".
Hope this makes it clearer...
Re: disable use of socks proxy in 3.5 [message #336551 is a reply to message #336549] Mon, 22 June 2009 08:44 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

If this is not working for you properly, please open a bug at
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform &component=Team

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/ganymede/index.jsp?topic=/org.eclips e.platform.doc.isv/guide/workbench.htm


Re: disable use of socks proxy in 3.5 [message #336620 is a reply to message #336551] Thu, 25 June 2009 08:42 Go to previous messageGo to next message
Gildas Guillemot is currently offline Gildas Guillemot
Messages: 1
Registered: July 2009
Junior Member
Hi,

does a bug have been filled for this issue? I searched on bugzilla but
found nothing. If not, I will.
I have the same problem problem here: I can't connect anymore to internet
through my proxy in eclipse 3.5.

thanks,
Gildas


Paul Webster wrote:

> If this is not working for you properly, please open a bug at
> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform &component=Team

> PW
Re: disable use of socks proxy in 3.5 [message #336622 is a reply to message #336620] Thu, 25 June 2009 09:34 Go to previous messageGo to next message
Paulo De Carvalho is currently offline Paulo De Carvalho
Messages: 1
Registered: July 2009
Junior Member
Hello,

I had the same pb with a proxy which refuse sockets, but It's work for me
now.
In Network Connections, with "Manual" for Active Provider, I can desactive
the SOCKS with the button "Clear" (the checkbox is always checked) but the
fields (Host, Port, Auth, User) are empty, and now, I can install new
software from network behind the proxy.
Re: disable use of socks proxy in 3.5 [message #336637 is a reply to message #336620] Thu, 25 June 2009 12:19 Go to previous messageGo to next message
Ivan is currently offline Ivan
Messages: 4
Registered: July 2009
Junior Member
Hello,

we have the similar problem here..
No update sites found when behind a proxy ( the proxy here ).
Switching to manual and clearing the socks proxy didn't help.


I described our case here
http://www.eclipse.org/newsportal/article.php?id=81774&g roup=eclipse.platform#81774

Regards
Ivan
Re: disable use of socks proxy in 3.5 [message #336642 is a reply to message #336620] Thu, 25 June 2009 15:17 Go to previous messageGo to next message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Gildas Guillemot wrote:
> Hi,
>
> does a bug have been filled for this issue? I searched on bugzilla but
> found nothing. If not, I will.
> I have the same problem problem here: I can't connect anymore to
> internet through my proxy in eclipse 3.5.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=281472

Make sure that you monitor this bug, as descriptions of the problem and
potential work arounds will be posted there.

PW

--
Paul Webster
http://wiki.eclipse.org/Platform_Command_Framework
http://wiki.eclipse.org/Command_Core_Expressions
http://wiki.eclipse.org/Menu_Contributions
http://wiki.eclipse.org/Menus_Extension_Mapping
http://help.eclipse.org/ganymede/index.jsp?topic=/org.eclips e.platform.doc.isv/guide/workbench.htm


Re: disable use of socks proxy in 3.5 [message #336655 is a reply to message #336551] Fri, 26 June 2009 02:56 Go to previous messageGo to next message
Jens is currently offline Jens
Messages: 3
Registered: July 2009
Junior Member
Paul Webster wrote:

> If this is not working for you properly, please open a bug at
> https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Platform &component=Team

> PW

I found a bug for this issue:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=281472

A hint in the bug description did the trick for me:
http://wiki.eclipse.org/ECF_Filetransfer_Support_for_NTLMv2_ Proxies

Cheers,
Jens
Re: disable use of socks proxy in 3.5 [message #789990 is a reply to message #336622] Fri, 03 February 2012 12:04 Go to previous messageGo to next message
Paul G is currently offline Paul G
Messages: 1
Registered: February 2012
Junior Member
I had the same problem in Eclipse 3.7. We're behind a firewall. I had put proxy settings in for HTTP, HTTPS, and SOCKS, but couldn't download anything. When I removed the SOCKS proxy setting using the Clear button, it started working. This should be documented for the user in a more obvious spot than an obscure forum. No one except the developers of Eclipse know (or care) what SOCKS is. Bleah.
Re: disable use of socks proxy in 3.5 [message #991515 is a reply to message #336516] Wed, 19 December 2012 11:15 Go to previous message
Pedro Santos is currently offline Pedro Santos
Messages: 1
Registered: December 2012
Junior Member
Hi,

just as previous mentioned here, I deactivated SOCKS by hitting the "Clear" button, and then it started to work fine. Smile
Previous Topic:Eclipse 4.2 Garbled Text while scrolling
Next Topic:How to Run an invisible Workbench
Goto Forum:
  


Current Time: Sat Aug 30 02:23:24 EDT 2014

Powered by FUDForum. Page generated in 0.01878 seconds