Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Xpand] Error: XMLFeatureMap is not responsible for java type org.eclipse.emf.ecore.util.FeatureMap$
[Xpand] Error: XMLFeatureMap is not responsible for java type org.eclipse.emf.ecore.util.FeatureMap$ [message #498888] Wed, 18 November 2009 19:30 Go to next message
Krzysztof Kowalczyk is currently offline Krzysztof Kowalczyk
Messages: 113
Registered: July 2009
Senior Member
I have migrated a oaw 4.3.1 Xtend XSD -> XSD project to oaw5 (xpand
0.7.2). After resolving other issues I get such error:

2009-11-19 01:19:18
org.eclipse.xtend.expression.AbstractExpressionsUsingWorkflo wComponent
invokeInternal
SEVERE: Error in Component of type org.eclipse.xtend.XtendComponent:
EvaluationException : XMLFeatureMap is not responsible for java type
org.eclipse.emf.ecore.util.FeatureMap$Entry
xsdrefactor.ext[1511,31] on line 54 'setAnyAttribute(t.anyAttribute)'

xsdrefactor.ext[906,14] on line 33 't.toTopLevel()'

xsdrefactor.ext[318,29] on line 12 'element.anonymousToType(this)'

nofile[0,70] on line 1
'anonymousToType(model,{'hibernate-mapping','hibernate-confi guration'})'


Any ideas ?

Cheers,
Krzysztof Kowalczyk
Re: [Xpand] Error: XMLFeatureMap is not responsible for java type org.eclipse.emf.ecore.util.Feature [message #499359 is a reply to message #498888] Sat, 21 November 2009 05:50 Go to previous messageGo to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

I am also facing the same problem.
I create the model code from an Ecore model that I use as metamodel in my XPand templates.
I defined an operation in java to manipulate a class (it.trim.fvc20.model.Entity.Entity) generated from the model.
I wanted to map this operation with XTend:

List[Entity::EntityOperation] loadEntitiesOperations(Entity::Entity entity, String dirToInspect):
JAVA it.trim.fvc20.mdd.entities.OperationsLoader.getOperations(it .trim.fvc20.model.Entity.Entity,java.lang.String);

but I get the error:

Entity::Entity is not responsible for java type it.trim.fvc20.model.Entity.Entity

I tried and googled a lot but... no ideas Sad


Re: [Xpand] Error: XMLFeatureMap is not responsible for java type org.eclipse.emf.ecore.util.Feature [message #499366 is a reply to message #499359] Sat, 21 November 2009 09:00 Go to previous message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

In my case it works if I change the workflow from:

<metaModel id="mm" class="org.eclipse.xtend.typesystem.emf.EmfRegistryMetaModel "/>

to:

<metaModel id="mm"
class="org.eclipse.xtend.typesystem.emf.EmfMetaModel">
<metaModelPackage value="it.trim.fvc20.model.Entity.entityPackage"/>
</metaModel>

I suppose that in this way I tell to xtend & xpand about the generated classes.


Previous Topic:[XPand] java.lang.InstantiationException when running
Next Topic:which metamodell to use
Goto Forum:
  


Current Time: Fri Aug 22 17:38:55 EDT 2014

Powered by FUDForum. Page generated in 0.02173 seconds