Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » How install PDT in existing Eclipse installation?(How install PDT in existing Eclipse installation?)
How install PDT in existing Eclipse installation? [message #495466] Thu, 05 November 2009 00:27 Go to next message
No real name is currently offline No real nameFriend
Messages: 1
Registered: November 2009
Junior Member
I am new to Eclipse and new to PHP and PDT. I already have Eclipse installed. Can someone point me to instructions for a rank beginner on how to install PDT? Thanks.
Re: How install PDT in existing Eclipse installation? [message #495495 is a reply to message #495466] Thu, 05 November 2009 05:58 Go to previous messageGo to next message
Michael Spector is currently offline Michael SpectorFriend
Messages: 110
Registered: July 2009
Senior Member

http://wiki.eclipse.org/PDT/Installation#From_Update_Site
Re: How install PDT in existing Eclipse installation? [message #496752 is a reply to message #495495] Wed, 11 November 2009 10:01 Go to previous messageGo to next message
Oliver is currently offline OliverFriend
Messages: 2
Registered: November 2009
Junior Member
Hi, I followed the instructions to the letter. Failed, followed them again but I keep gettin the following error message:

Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) Runtime Feature 2.2.0.v200911051124-7L7J-F8NcJKhTTK4TTcw (org.eclipse.php.feature.group 2.2.0.v200911051124-7L7J-F8NcJKhTTK4TTcw)
Missing requirement: Dynamic Languages Toolkit Core 2.0.0.v20091110-1755 (org.eclipse.dltk.core 2.0.0.v20091110-1755) requires 'bundle org.eclipse.emf.ecore 2.4.0' but it could not be found
Cannot satisfy dependency:
From: PDT Core Plug-in 2.2.0.v200911051124 (org.eclipse.php.debug.core 2.2.0.v200911051124)
To: bundle org.eclipse.dltk.core 2.0.0
Cannot satisfy dependency:
From: PHP Development Tools (PDT) Runtime Feature 2.2.0.v200911051124-7L7J-F8NcJKhTTK4TTcw (org.eclipse.php.feature.group 2.2.0.v200911051124-7L7J-F8NcJKhTTK4TTcw)
To: org.eclipse.php.debug.core [2.2.0.v200911051124]

So I tried to install the DLTK seperately using the same method (Help->Install new software) I selected the DLTK site and tried to install "Dynamic Languages Toolkit - Core Frameworks" V2.0.0v.20090917-1518.......... and basically got the same error message:

Cannot complete the install because one or more required items could not be found.
Software being installed: Dynamic Languages Toolkit - Core Frameworks 2.0.0.v20090917-1518-7L--EAAoOQBUSiiBVyrP (org.eclipse.dltk.core.feature.group 2.0.0.v20090917-1518-7L--EAAoOQBUSiiBVyrP)
Missing requirement: Dynamic Languages Toolkit - Core Frameworks 2.0.0.v20090917-1518-7L--EAAoOQBUSiiBVyrP (org.eclipse.dltk.core.feature.group 2.0.0.v20090917-1518-7L--EAAoOQBUSiiBVyrP) requires 'org.eclipse.emf.ecore.feature.group 2.4.0' but it could not be found

Can anyone explain this to me, it seems to require the DLTK to install the DLTK..... Catch22 anyone??

Ol
Re: How install PDT in existing Eclipse installation? [message #496769 is a reply to message #496752] Wed, 11 November 2009 11:01 Go to previous messageGo to next message
Oliver is currently offline OliverFriend
Messages: 2
Registered: November 2009
Junior Member
Nevermind I didn't have Galileo in my software sources. After adding it everything worked fine. Galileo was supposed to be there by default but for some reason wasn't.
Re: How install PDT in existing Eclipse installation? [message #502700 is a reply to message #496769] Wed, 09 December 2009 13:40 Go to previous messageGo to next message
Vaughany  is currently offline Vaughany Friend
Messages: 1
Registered: December 2009
Junior Member
Oliver wrote on Wed, 11 November 2009 06:01
Nevermind I didn't have Galileo in my software sources. After adding it everything worked fine. Galileo was supposed to be there by default but for some reason wasn't.

...How do you get Galileo in yr software sources? I can't find a URL for it anywhere, and in the detailed install instructions, it is already showing as installed, but definately isn't on my machine.

Edited to include:

Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) Runtime Feature 2.1.2.v20090826-1027-7L7979F8NcJKhKRU19TmWA (org.eclipse.php.feature.group 2.1.2.v20090826-1027-7L7979F8NcJKhKRU19TmWA)
Missing requirement: PHP Development Tools (PDT) Runtime Feature 2.1.2.v20090826-1027-7L7979F8NcJKhKRU19TmWA (org.eclipse.php.feature.group 2.1.2.v20090826-1027-7L7979F8NcJKhKRU19TmWA) requires 'org.eclipse.dltk.core.feature.group [1.0.0,2.0.0)' but it could not be found

Help appreciated.

V.

[Updated on: Wed, 09 December 2009 13:45]

Report message to a moderator

Re: How install PDT in existing Eclipse installation? [message #503099 is a reply to message #496769] Thu, 10 December 2009 20:45 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2341
Registered: July 2009
Senior Member
boomer84@gmail.com wrote:
> Nevermind I didn't have Galileo in my software sources. After adding it
> everything worked fine. Galileo was supposed to be there by default but
> for some reason wasn't.

It will only be there when you're using Eclipse 3.5.x or started
with another Galileo package.

--
---
Nitin Dahyabhai
Eclipse WTP Source Editing
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:Adding Tags to PHP Editor
Next Topic:Patch Fragment of or.eclipse.equinox.registry ignored in launch
Goto Forum:
  


Current Time: Thu Dec 18 14:27:20 GMT 2014

Powered by FUDForum. Page generated in 0.02243 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software