Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Spatiotemporal Epidemiological Modeler (STEM) » STEM Build Mac OS
STEM Build Mac OS [message #2624] Sun, 26 April 2009 15:52 Go to next message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
Hi again :),

Trying to launch the 0.5.0.I20090423 STEM app from my Mac Pro, I get:

!ENTRY org.eclipse.osgi 4 0 2009-04-26 12:44:07.581
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service.
Ensure that the org.eclipse.core.runtime bundle is resolved and started
(see config.ini).
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:74)
at

org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at

sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at

sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at

java.lang.reflect.Method.invoke(Method.java:585)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)


I'm thinking that this might have something to do with my 1.6 VM not
playing nicely with Carbon. I've been using the Cocoa x86 builds for my
own environment. Anyone had any similar issues?
Re: STEM Build Mac OS [message #2654 is a reply to message #2624] Mon, 27 April 2009 09:56 Go to previous message
Eclipse User
Originally posted by: daford.almaden.ibm.com.invalid

Miles,
I have almost the exact set up as you, Mac Pro, latest from CVS and a 1.6
JVM, and I have no build or execute issues at all. Everything works as
expected.

Something must be different between our setups. I'm running 3.5M6.

Dan


Miles Parker wrote:
> Hi again :),
>
> Trying to launch the 0.5.0.I20090423 STEM app from my Mac Pro, I get:
>
> !ENTRY org.eclipse.osgi 4 0 2009-04-26 12:44:07.581
> !MESSAGE Application error
> !STACK 1
> java.lang.IllegalStateException: Unable to acquire application service.
> Ensure that the org.eclipse.core.runtime bundle is resolved and started
> (see config.ini).
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAp
pLauncher.java:74)
> at
>
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at
>
> sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
>
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
>
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl
..java:25)
> at
>
> java.lang.reflect.Method.invoke(Method.java:585)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
>
>
> I'm thinking that this might have something to do with my 1.6 VM not
> playing nicely with Carbon. I've been using the Cocoa x86 builds for my
> own environment. Anyone had any similar issues?
>
Re: STEM Build Mac OS [message #560932 is a reply to message #2624] Mon, 27 April 2009 09:56 Go to previous message
Daniel Ford is currently offline Daniel Ford
Messages: 138
Registered: July 2009
Location: New York
Senior Member
Miles,
I have almost the exact set up as you, Mac Pro, latest from CVS and a 1.6
JVM, and I have no build or execute issues at all. Everything works as
expected.

Something must be different between our setups. I'm running 3.5M6.

Dan


Miles Parker wrote:
> Hi again :),
>
> Trying to launch the 0.5.0.I20090423 STEM app from my Mac Pro, I get:
>
> !ENTRY org.eclipse.osgi 4 0 2009-04-26 12:44:07.581
> !MESSAGE Application error
> !STACK 1
> java.lang.IllegalStateException: Unable to acquire application service.
> Ensure that the org.eclipse.core.runtime bundle is resolved and started
> (see config.ini).
> at
> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAp
pLauncher.java:74)
> at
>
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
> at
> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
> at
>
> sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
>
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
> at
>
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl
..java:25)
> at
>
> java.lang.reflect.Method.invoke(Method.java:585)
> at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
> at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
> at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
>
>
> I'm thinking that this might have something to do with my 1.6 VM not
> playing nicely with Carbon. I've been using the Cocoa x86 builds for my
> own environment. Anyone had any similar issues?
>
Previous Topic:STEM Build Mac OS
Next Topic:Air transportation now operational
Goto Forum:
  


Current Time: Tue Sep 02 08:00:56 EDT 2014

Powered by FUDForum. Page generated in 0.02206 seconds