Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Importing repositories from previous version
Importing repositories from previous version [message #30055] Wed, 06 August 2008 09:29 Go to next message
Eclipse UserFriend
Originally posted by: jdchourio.communi.tv

Hello:

Sorry if this has been asked before but I couldn't find anything with the
search engine.

Is it possible to import repositories list from my eclipse-3.2's
workspace? Or should I add again all the repositories?

Is there anyway to read the file
workspace\.metadata\.plugins\org.polarion.team.svn.core\.svn Repositories?

Thanks in advance,

Javier
Re: Importing repositories from previous version [message #30131 is a reply to message #30055] Wed, 06 August 2008 10:01 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alexander.gurov.polarion.org

Hello Javier,

If you wish to migrate from Subversive 1.1.x to Subversive 0.7.x then
please read migration guide at
http://www.eclipse.org/subversive/documentation/install_migr ate.php

I think this description will answer your question.
Re: Importing repositories from previous version [message #30307 is a reply to message #30131] Wed, 06 August 2008 12:17 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jdchourio.communi.tv

Thanks. I'll post a new message because I've found some problems.

Regards,

Javier

Alexander Gurov wrote:
> Hello Javier,
> If you wish to migrate from Subversive 1.1.x to Subversive 0.7.x then
> please read migration guide at
> http://www.eclipse.org/subversive/documentation/install_migr ate.php
>
> I think this description will answer your question.
>
>
Re: Importing repositories from previous version [message #30343 is a reply to message #30307] Wed, 06 August 2008 13:06 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alexander.gurov.polarion.org

Could you please describe what kind of problems you have found?
Re: Importing repositories from previous version [message #30379 is a reply to message #30343] Wed, 06 August 2008 14:47 Go to previous message
Eclipse UserFriend
Originally posted by: jdchourio.communi.tv

Right now I can't reproduce the error. After several tries, I decided
to recreate the workspace.

Anyway I can rescue some information from the log files. When I did as
indicated in the migration instructions, the attached message appeared.

Regards,

Javier

Message:

!ENTRY org.eclipse.team.svn.core.svnnature 4 0 2008-08-06 15:56:03.375
!MESSAGE SVN: '0x00400200: Transfer Settings' operation finished with error
!SUBENTRY 1 org.eclipse.team.svn.core.svnnature 4 0 2008-08-06 15:56:03.375
!MESSAGE Cannot convert repositories information files.
!STACK 0
java.io.StreamCorruptedException
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java :1332)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java: 348)
at
org.eclipse.team.svn.core.svnstorage.AbstractSVNStorage.load LocationsFromFile(AbstractSVNStorage.java:548)
at
org.eclipse.team.svn.core.svnstorage.AbstractSVNStorage.init ializeImpl(AbstractSVNStorage.java:402)
at
org.eclipse.team.svn.core.svnstorage.SVNRemoteStorage.initia lize(SVNRemoteStorage.java:164)
at
org.eclipse.team.svn.ui.debugmail.MigrateToEclipse$ConvertRe positoryFiles.runImpl(MigrateToEclipse.java:199)
at
org.eclipse.team.svn.core.operation.AbstractActionOperation. run(AbstractActionOperation.java:76)
at
org.eclipse.team.svn.core.utility.ProgressMonitorUtility.doT ask(ProgressMonitorUtility.java:103)
at
org.eclipse.team.svn.core.operation.CompositeOperation.runIm pl(CompositeOperation.java:94)
at
org.eclipse.team.svn.core.operation.AbstractActionOperation. run(AbstractActionOperation.java:76)
at
org.eclipse.team.svn.core.operation.LoggedOperation.run(Logg edOperation.java:37)
at
org.eclipse.team.svn.core.utility.ProgressMonitorUtility.doT ask(ProgressMonitorUtility.java:103)
at
org.eclipse.team.svn.core.utility.ProgressMonitorUtility.doT askExternal(ProgressMonitorUtility.java:89)
at
org.eclipse.team.svn.ui.utility.DefaultCancellableOperationW rapper.run(DefaultCancellableOperationWrapper.java:55)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)


Alexander Gurov wrote:
> Could you please describe what kind of problems you have found?
>
Previous Topic:Project disconnected from repository and cannot be re-shared
Next Topic:java.util.ConcurrentModificationException
Goto Forum:
  


Current Time: Sat Dec 20 21:01:17 GMT 2014

Powered by FUDForum. Page generated in 0.01717 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software