Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Nebula » PShelf Bug?
PShelf Bug? [message #29334] Wed, 21 February 2007 03:34 Go to next message
Paul Kendall is currently offline Paul Kendall
Messages: 40
Registered: July 2009
Member
I have got a PShelf in my RCP application and I cannot get images on the
shelf items. I am using Linux GTK. Whenever I have a setImage, the shelf
does not render properly. i.e. only the first shelf appears, but no text or
image.

Anyone else have this problem or should I raise a bug on the zilla?

Cheers,
Paul Kendall
Re: PShelf Bug? [message #29372 is a reply to message #29334] Wed, 21 February 2007 04:53 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5227
Registered: July 2009
Senior Member
hi,

I'm seeing the same issue on Linux GTK and I think there are animation
problems on MacOSX.

Tom

Paul Kendall schrieb:
> I have got a PShelf in my RCP application and I cannot get images on the
> shelf items. I am using Linux GTK. Whenever I have a setImage, the shelf
> does not render properly. i.e. only the first shelf appears, but no text or
> image.
>
> Anyone else have this problem or should I raise a bug on the zilla?
>
> Cheers,
> Paul Kendall
Re: PShelf Bug? [message #29410 is a reply to message #29372] Wed, 21 February 2007 05:45 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5227
Registered: July 2009
Senior Member
Ha,

this is an SWT-Problem with GC on Linux-GTK. I'll log a bug against SWT
but if you want to fix it your own simply comment out line 252 of PShelf.

You can find the fix in:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=174933

Tom

Tom Schindl schrieb:
> hi,
>
> I'm seeing the same issue on Linux GTK and I think there are animation
> problems on MacOSX.
>
> Tom
>
> Paul Kendall schrieb:
>> I have got a PShelf in my RCP application and I cannot get images on the
>> shelf items. I am using Linux GTK. Whenever I have a setImage, the shelf
>> does not render properly. i.e. only the first shelf appears, but no text or
>> image.
>>
>> Anyone else have this problem or should I raise a bug on the zilla?
>>
>> Cheers,
>> Paul Kendall
Re: PShelf Bug? [message #29447 is a reply to message #29410] Thu, 22 February 2007 03:34 Go to previous message
Paul Kendall is currently offline Paul Kendall
Messages: 40
Registered: July 2009
Member
Awesome, thanks Tom.

Paul

Tom Schindl wrote:
> Ha,
>
> this is an SWT-Problem with GC on Linux-GTK. I'll log a bug against SWT
> but if you want to fix it your own simply comment out line 252 of PShelf.
>
> You can find the fix in:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=174933
>
> Tom
>
Re: PShelf Bug? [message #578739 is a reply to message #29334] Wed, 21 February 2007 04:53 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5227
Registered: July 2009
Senior Member
hi,

I'm seeing the same issue on Linux GTK and I think there are animation
problems on MacOSX.

Tom

Paul Kendall schrieb:
> I have got a PShelf in my RCP application and I cannot get images on the
> shelf items. I am using Linux GTK. Whenever I have a setImage, the shelf
> does not render properly. i.e. only the first shelf appears, but no text or
> image.
>
> Anyone else have this problem or should I raise a bug on the zilla?
>
> Cheers,
> Paul Kendall
Re: PShelf Bug? [message #578759 is a reply to message #29372] Wed, 21 February 2007 05:45 Go to previous message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5227
Registered: July 2009
Senior Member
Ha,

this is an SWT-Problem with GC on Linux-GTK. I'll log a bug against SWT
but if you want to fix it your own simply comment out line 252 of PShelf.

You can find the fix in:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=174933

Tom

Tom Schindl schrieb:
> hi,
>
> I'm seeing the same issue on Linux GTK and I think there are animation
> problems on MacOSX.
>
> Tom
>
> Paul Kendall schrieb:
>> I have got a PShelf in my RCP application and I cannot get images on the
>> shelf items. I am using Linux GTK. Whenever I have a setImage, the shelf
>> does not render properly. i.e. only the first shelf appears, but no text or
>> image.
>>
>> Anyone else have this problem or should I raise a bug on the zilla?
>>
>> Cheers,
>> Paul Kendall
Re: PShelf Bug? [message #578777 is a reply to message #29410] Thu, 22 February 2007 03:34 Go to previous message
Paul Kendall is currently offline Paul Kendall
Messages: 40
Registered: July 2009
Member
Awesome, thanks Tom.

Paul

Tom Schindl wrote:
> Ha,
>
> this is an SWT-Problem with GC on Linux-GTK. I'll log a bug against SWT
> but if you want to fix it your own simply comment out line 252 of PShelf.
>
> You can find the fix in:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=174933
>
> Tom
>
Previous Topic:PShelf Bug?
Next Topic:Nebula Presentation
Goto Forum:
  


Current Time: Wed Jul 23 04:00:20 EDT 2014

Powered by FUDForum. Page generated in 0.01797 seconds