Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Eclipse 3.2.2 + Mylyn 2.3.2 + Subversive 0.7.2
Eclipse 3.2.2 + Mylyn 2.3.2 + Subversive 0.7.2 [message #29136] Tue, 05 August 2008 10:25 Go to next message
Jörg Thönnes is currently offline Jörg ThönnesFriend
Messages: 229
Registered: July 2009
Senior Member
Hi Alexander,

just a quick question because the API dependencies are somewhat difficult and we want to upgrade to
the newest Subversive 0.7.2:

We currently use Eclipse 3.2.2 with the following features:

Mylyn 2.3.2
SVN 1.4. SVN Kit Connector 2.0.0-20080517
Subversive SVN Team Provider v0.7.0-20080609
Subversive SVN Integration for Mylyn v0.7.0-20080517

Upgrading to 0.7.2 it is OK to move to SVN Kit 1.5, but I would leave Mylyn at 2.3.2 for the moment.
Is that possible or have I to upgrade to Mylyn 3.0.1 because of the Mylyn 3.0 API changes?

Many thanks, Jörg
Re: Eclipse 3.2.2 + Mylyn 2.3.2 + Subversive 0.7.2 [message #29249 is a reply to message #29136] Tue, 05 August 2008 12:31 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: alexander.gurov.polarion.org

Jörg Thönnes wrote:

> Hi Alexander,

> just a quick question because the API dependencies are somewhat difficult
> and we want to upgrade to the newest Subversive 0.7.2:
> We currently use Eclipse 3.2.2 with the following features:
Do you mean Eclipse 3.3.2? (0.7.x versions of the Subversive plug-in have
no support of Eclipse 3.2.x)

> Mylyn 2.3.2
> SVN 1.4. SVN Kit Connector 2.0.0-20080517
> Subversive SVN Team Provider v0.7.0-20080609
> Subversive SVN Integration for Mylyn v0.7.0-20080517
> Upgrading to 0.7.2 it is OK to move to SVN Kit 1.5, but I would leave Mylyn
> at 2.3.2 for the moment.
> Is that possible or have I to upgrade to Mylyn 3.0.1 because of the Mylyn
> 3.0 API changes?
Subversive does not support Mylyn 2.3.x anymore due to reasons described
in the bug 229495: Remove Subversive menu in Help
https://bugs.eclipse.org/bugs/show_bug.cgi?id=229495
So, now the only way to get complete SVN 1.5 support with Subversive is to
use 0.7.2 version which requires Mylyn 3.0 and higher.
Re: Eclipse 3.2.2 + Mylyn 2.3.2 + Subversive 0.7.2 [message #29325 is a reply to message #29249] Tue, 05 August 2008 12:53 Go to previous message
Jörg Thönnes is currently offline Jörg ThönnesFriend
Messages: 229
Registered: July 2009
Senior Member
On 08/05/08 14:31, Alexander Gurov wrote:
> Jörg Thönnes wrote:
>
>> Hi Alexander,
>
>> just a quick question because the API dependencies are somewhat
>> difficult and we want to upgrade to the newest Subversive 0.7.2:
>> We currently use Eclipse 3.2.2 with the following features:
> Do you mean Eclipse 3.3.2? (0.7.x versions of the Subversive plug-in
> have no support of Eclipse 3.2.x)

Yes, of course I meant 3.3.2. I did confuse the many appearances of 2 and 3 :-)

>> Mylyn 2.3.2
>> SVN 1.4. SVN Kit Connector 2.0.0-20080517
>> Subversive SVN Team Provider v0.7.0-20080609
>> Subversive SVN Integration for Mylyn v0.7.0-20080517
>> Upgrading to 0.7.2 it is OK to move to SVN Kit 1.5, but I would leave
>> Mylyn at 2.3.2 for the moment.
>> Is that possible or have I to upgrade to Mylyn 3.0.1 because of the
>> Mylyn 3.0 API changes?
> Subversive does not support Mylyn 2.3.x anymore due to reasons described
> in the bug 229495: Remove Subversive menu in Help
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=229495
> So, now the only way to get complete SVN 1.5 support with Subversive is
> to use 0.7.2 version which requires Mylyn 3.0 and higher.

OK, that answers my question.

Many thanks, Jörg
Previous Topic:Synchronize does not view changes deeper than root dir
Next Topic:self-signed certificate problem
Goto Forum:
  


Current Time: Mon Dec 22 14:57:33 GMT 2014

Powered by FUDForum. Page generated in 0.02399 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software