Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Eclipse Foundation » Building Eclipse with Eclipse
Building Eclipse with Eclipse [message #28862] Sat, 21 January 2006 13:39 Go to next message
Eclipse UserFriend
Originally posted by: ramtung.gmail.com

In a research project, I have to make some modifications to various parts
of Eclipse, so I cannot contribute my work as a plug-in. I have to work on
the Eclipse sources.

I imported Eclipse plug-in source files into Eclipse, but when I want to
build, I get several error messages, many of them rooted from 4-5 errors
like this:

Project org.eclipse.osgi is missing required library: 'osgi/collx.jar'

The source files are taken from eclipse-sourceBuild-srcIncluded-3.2M4.zip.

Is something wrong with the entire method (i.e., trying to build Eclipse
with Eclipse), or it can be fixed somehow? Please note that I have a task
that cannot be done by writing a plug-in!

--Ramtin
Re: Building Eclipse with Eclipse [message #28870 is a reply to message #28862] Mon, 23 January 2006 00:16 Go to previous messageGo to next message
Mike Milinkovich is currently offline Mike MilinkovichFriend
Messages: 258
Registered: July 2009
Senior Member
This post would likely be better answered if you asked it at
eclipse.newcomer

"Ramtin Khosravi" <ramtung@gmail.com> wrote in message
news:fba38d9e96c37ee24b392438c805ddfa$1@www.eclipse.org...
> In a research project, I have to make some modifications to various parts
> of Eclipse, so I cannot contribute my work as a plug-in. I have to work on
> the Eclipse sources.
>
> I imported Eclipse plug-in source files into Eclipse, but when I want to
> build, I get several error messages, many of them rooted from 4-5 errors
> like this:
>
> Project org.eclipse.osgi is missing required library: 'osgi/collx.jar'
>
> The source files are taken from eclipse-sourceBuild-srcIncluded-3.2M4.zip.
>
> Is something wrong with the entire method (i.e., trying to build Eclipse
> with Eclipse), or it can be fixed somehow? Please note that I have a task
> that cannot be done by writing a plug-in!
>
> --Ramtin
>
Re: Building Eclipse with Eclipse [message #36553 is a reply to message #28870] Fri, 07 July 2006 09:56 Go to previous messageGo to next message
Stuart Stephen is currently offline Stuart StephenFriend
Messages: 22
Registered: July 2009
Junior Member
I eventually found where I could get the files. If you follow the link to this page http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.ercp/or g.eclipse.osgi/osgi/?cvsroot=Technology_Project#dirlist then you should get a list of the files that you are missing.

If you click through on each file you should be able to download them. Put them in the C:\eclipse-src\plugins\org.eclipse.osgi\osgi folder.

Hopefully that should be you sorted, although I now have other issues with regards to org.eclipse.swt:

Package 'org.eclipse.swt.accessibility' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.awt' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.browser' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.custom' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.dnd' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.events' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.graphics' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.internal.image' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.internal.theme' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.internal' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.layout' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.opengl' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.printing' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.program' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt.widgets' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
Package 'org.eclipse.swt' does not exist in this plug-in org.eclipse.swt/META-INF MANIFEST.MF
The project cannot be built until build path errors are resolved org.eclipse.swt
Unable to read '.classpath' file of project org.eclipse.swt org.eclipse.swt

Hopefully I'll resolve this soon and hopefully I was more use than Ramtin. I'll keep you posted.

--Swadge
Re: Building Eclipse with Eclipse [message #36582 is a reply to message #36553] Fri, 07 July 2006 10:07 Go to previous message
Stuart Stephen is currently offline Stuart StephenFriend
Messages: 22
Registered: July 2009
Junior Member
This is a simple one. The classpath simply needs setting up to suit your environment.

classpath_carbon
classpath_carbon_j2me
classpath_gtk
classpath_gtk_j2me
classpath_motif
classpath_motif_j2me
classpath_photon
classpath_photon_j2me
classpath_win32
classpath_win32_j2me

Copy the relevant one to a file named .classpath

If you are using windows you may need to do it in the command prompt as windows does not allow the name .classpath - simply goto the folder where the .classpath files are and type "<i>rename .classpath_win32 .classpath</i>" and this will work fine.

Hope this helps.

--Swadge
Previous Topic:3.2 plugin tutorial issue
Next Topic:Problem with Saving the workbench
Goto Forum:
  


Current Time: Wed Nov 26 15:38:32 GMT 2014

Powered by FUDForum. Page generated in 0.03390 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software