Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DTP » Data Source Explorer shows no content under each connection profile
Data Source Explorer shows no content under each connection profile [message #28244] Mon, 26 March 2007 21:53 Go to next message
Charles Doucette is currently offline Charles DoucetteFriend
Messages: 125
Registered: July 2009
Senior Member
I already posted a note earlier about problems with MS SQL Server.
Now, I performed a similar test with Oracle.
Both connection profiles ping fine; but, neither one shows any content in
the data source explorer.
I am using DTP SDK 1.5M5
on top of Eclipse SDK 3.3M5eh (for Win32).
Should I try DTP SDK 1.5M6 instead?

Also, I read something about a Data perspective.
I don't see that in my list of other perspectives.
I am able to set up drivers and connection profiles.

Thanks,
Chuck
Re: Data Source Explorer shows no content under each connection profile [message #29500 is a reply to message #28244] Tue, 17 April 2007 19:17 Go to previous messageGo to next message
Charles Doucette is currently offline Charles DoucetteFriend
Messages: 125
Registered: July 2009
Senior Member
I have now setup Eclipse 3.2.2 with DTP 1.5M6 (plus EMF 2.2.3 and GEF 3.2.2)
as well as a separate installation of Eclipse 3.3.0M6 with DTP 1.5M6 (plus
EMF 2.3.0M6 and GEF 3.3M6).

DTP 1.5 now works fine for showing the database meta data of both MS SQL
Server 2000 and for Oracle 9.

Thanks,
Chuck

"Chuck Doucette" <cdoucette@vaultus.com> wrote in message
news:eu9fdb$bu$1@utils.eclipse.org...
>I already posted a note earlier about problems with MS SQL Server.
> Now, I performed a similar test with Oracle.
> Both connection profiles ping fine; but, neither one shows any content in
> the data source explorer.
> I am using DTP SDK 1.5M5
> on top of Eclipse SDK 3.3M5eh (for Win32).
> Should I try DTP SDK 1.5M6 instead?
>
> Also, I read something about a Data perspective.
> I don't see that in my list of other perspectives.
> I am able to set up drivers and connection profiles.
>
> Thanks,
> Chuck
>
>
Re: Data Source Explorer shows no content under each connection profile [message #30122 is a reply to message #29500] Thu, 26 April 2007 18:55 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: john.graham.sybase.com

Chuck,

Sorry for the late reply, and glad to see that it is working for you now.
When I read the original post, I suspected that you might have installed
just the "base" EMF (without SDO), since no DSE content and no Database
Development perspective are symptomatic of that.

Just a thought, in case you run into a similar issue as you move up the
Eclipse 3.3/DTP 1.5 milestone train.

-- John Graham
Eclipse Data Tools Platform PMC Chair

Chuck Doucette wrote:

> I have now setup Eclipse 3.2.2 with DTP 1.5M6 (plus EMF 2.2.3 and GEF 3.2.2)
> as well as a separate installation of Eclipse 3.3.0M6 with DTP 1.5M6 (plus
> EMF 2.3.0M6 and GEF 3.3M6).

> DTP 1.5 now works fine for showing the database meta data of both MS SQL
> Server 2000 and for Oracle 9.

> Thanks,
> Chuck

> "Chuck Doucette" <cdoucette@vaultus.com> wrote in message
> news:eu9fdb$bu$1@utils.eclipse.org...
>>I already posted a note earlier about problems with MS SQL Server.
>> Now, I performed a similar test with Oracle.
>> Both connection profiles ping fine; but, neither one shows any content in
>> the data source explorer.
>> I am using DTP SDK 1.5M5
>> on top of Eclipse SDK 3.3M5eh (for Win32).
>> Should I try DTP SDK 1.5M6 instead?
>>
>> Also, I read something about a Data perspective.
>> I don't see that in my list of other perspectives.
>> I am able to set up drivers and connection profiles.
>>
>> Thanks,
>> Chuck
>>
>>
Re: Data Source Explorer shows no content under each connection profile [message #30590 is a reply to message #30122] Sat, 05 May 2007 16:27 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: farmerjohn1958.comcast.net

I'm using the 3.3M6 set and the schema node is empty for SQL Server.
Im able to connect & it shows the Catalog (i.e. MS Databases), but not
schema or tables.
Tried with MS SQL JDBC 1.1, 1.2 & JTDS.

DSE works fine with Derby.



"John Graham" <john.graham@sybase.com> wrote in message
news:97380f2bc746f2143f4005344ad1f324$1@www.eclipse.org...
> Chuck,
>
> Sorry for the late reply, and glad to see that it is working for you now.
> When I read the original post, I suspected that you might have installed
> just the "base" EMF (without SDO), since no DSE content and no Database
> Development perspective are symptomatic of that.
>
> Just a thought, in case you run into a similar issue as you move up the
> Eclipse 3.3/DTP 1.5 milestone train.
>
> -- John Graham
> Eclipse Data Tools Platform PMC Chair
>
> Chuck Doucette wrote:
>
> > I have now setup Eclipse 3.2.2 with DTP 1.5M6 (plus EMF 2.2.3 and GEF
3.2.2)
> > as well as a separate installation of Eclipse 3.3.0M6 with DTP 1.5M6
(plus
> > EMF 2.3.0M6 and GEF 3.3M6).
>
> > DTP 1.5 now works fine for showing the database meta data of both MS SQL
> > Server 2000 and for Oracle 9.
>
> > Thanks,
> > Chuck
>
> > "Chuck Doucette" <cdoucette@vaultus.com> wrote in message
> > news:eu9fdb$bu$1@utils.eclipse.org...
> >>I already posted a note earlier about problems with MS SQL Server.
> >> Now, I performed a similar test with Oracle.
> >> Both connection profiles ping fine; but, neither one shows any content
in
> >> the data source explorer.
> >> I am using DTP SDK 1.5M5
> >> on top of Eclipse SDK 3.3M5eh (for Win32).
> >> Should I try DTP SDK 1.5M6 instead?
> >>
> >> Also, I read something about a Data perspective.
> >> I don't see that in my list of other perspectives.
> >> I am able to set up drivers and connection profiles.
> >>
> >> Thanks,
> >> Chuck
> >>
> >>
>
>
Re: Data Source Explorer shows no content under each connection profile [message #31154 is a reply to message #29500] Tue, 05 June 2007 04:27 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: ushakov.int.com.ru

Hi Chuck,

could you share a little bit of details for the steps that gave you luck
with MS SQL? Anything that you believe might be important?

I have the same problem you had before:
- MS SQL 2000
- sa account
- connection is ok
- the list of databases is ok
- only empty "Schemas" folders are visible
- no complaints in any logs

My configuration is similar to yours but a little bit up-to-date:
- eclipse-SDK-3.3RC3-win32
- emf-sdo-xsd-SDK-2.3.0RC2
- GEF-ALL-3.3RC2
- dtp-sdk_1.5RC2
- wtp-sdk-S-2.0RC1-200705250432
- jTDS 1.2

Thanks and regards,

Sergey


"Chuck Doucette" <cdoucette@vaultus.com> wrote in message
news:f036ge$j21$1@build.eclipse.org...
>I have now setup Eclipse 3.2.2 with DTP 1.5M6 (plus EMF 2.2.3 and GEF
>3.2.2)
> as well as a separate installation of Eclipse 3.3.0M6 with DTP 1.5M6
> (plus EMF 2.3.0M6 and GEF 3.3M6).
>
> DTP 1.5 now works fine for showing the database meta data of both MS SQL
> Server 2000 and for Oracle 9.
>
> Thanks,
> Chuck
>
> "Chuck Doucette" <cdoucette@vaultus.com> wrote in message
> news:eu9fdb$bu$1@utils.eclipse.org...
>>I already posted a note earlier about problems with MS SQL Server.
>> Now, I performed a similar test with Oracle.
>> Both connection profiles ping fine; but, neither one shows any content in
>> the data source explorer.
>> I am using DTP SDK 1.5M5
>> on top of Eclipse SDK 3.3M5eh (for Win32).
>> Should I try DTP SDK 1.5M6 instead?
>>
>> Also, I read something about a Data perspective.
>> I don't see that in my list of other perspectives.
>> I am able to set up drivers and connection profiles.
>>
>> Thanks,
>> Chuck
>>
>>
>
>
Re: Data Source Explorer shows no content under each connection profile [message #33875 is a reply to message #31154] Thu, 02 August 2007 16:55 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: bill_middleton.yahoo.com

I'm having the identical problem when accessing MS SQL Server 8 with
jTDS... The catalog of databases displays fine in Data Source Explorer,
but the databases show only empty Schema folders.
Re: Data Source Explorer shows no content under each connection profile [message #37094 is a reply to message #31154] Tue, 09 October 2007 18:22 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: ddumaresq.bccampus.ca

Alas, I am yet another who cannot view content under the MS SQL Server
database connection. My database only shows "Catalogs", database instance
names and "Schemas" - no tables, views, etc. I would like to browse a SQL
Server 2000 database and would appreciate any help. Here are some details of
how I've set things up:

My initial creation of the driver details for SQL Server was a little messy
and I did not have all the requirements as stated on
http://www.eclipse.org/datatools/downloads.html. I now meet those
requirements. I`m running on Windows Vista platform with JRE (build
1.6.0-oem-b104).

To create a new connection, I select a new Generic JDBC Connection. This
allows me to select the driver for Microsoft SQL Server 2000 for JDBC.
I must provide the paths to the jars (msbase.jar, mssqlserver.jar,
msutil.jar) and other driver details. Interestingly, the default driver
class (com.microsoft.jdbc.sqlserver.SQLServerDriver) is hardcoded in the
database driver properties dialog. There is no way to select available
classes from the included jars... I would have liked to do this as a sanity
check.

The Connection Driver Version information shows:
`Microsoft SQL Server: 0.0.0.2 (Build 3790: ) The following technologies are
available on this server: JDBC: unknown`
I have the latest driver (SP3) from the microsoft site, but I don't think
the build number here has changed with SP3.

Well, I'll move on with something else for now... Any help is appreciated!

Regards,
Dave

"Bill Middleton" <bill_middleton@yahoo.com> wrote in message
news:d1edbf6a330a981ca94c9bf23af5e10e$1@www.eclipse.org...
> I'm having the identical problem when accessing MS SQL Server 8 with
> jTDS... The catalog of databases displays fine in Data Source Explorer,
> but the databases show only empty Schema folders.
>
Re: Data Source Explorer shows no content under each connection profile [message #37128 is a reply to message #30122] Wed, 10 October 2007 11:02 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: u.ende.mid.de

John,
I can't find out what is wrong with my eclipse installation. As I see I
should have actual downloads for Eclipse 3.3: DTP 1.5.1, EMF 2.4 0M2 with
SDO, and GEF 3.3.1
In my Data Source Explorer View I do not get any ODA Data Sources, but I
do have Databases with JDBC Connections to Derby, MySQL an Oracle. I can
ping and connect to all of them, but do not get any more information in a
tree or whatever.
I do not know what is the mistake.
Re: Data Source Explorer shows no content under each connection profile [message #37162 is a reply to message #37128] Thu, 11 October 2007 08:20 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: u.ende.mid.de

Hm, unfortunately I did not see any remark showing that Eclipse classic is
not enough, after downloading the eclipse for Java Developers' stuff, I
get contents.
Re: Data Source Explorer shows no content under each connection profile [message #37501 is a reply to message #37162] Thu, 25 October 2007 08:17 Go to previous message
Eclipse UserFriend
Originally posted by: yourspamhere.hotmail.com

Udo, I think your problem was related to the JVM you were using (1.5 is
required for the last versions of EMF) and not to the Java Development
stuff.

Anyways, I got more or less the same problem but just with the ODA Data
Sources, this is, the database connections work as expected but when I
create a connection to a flat file data source, for example, it works and
I can ping and whatnot but when connected the node does not expand, so no
files or tables or whatever are shown. Has anybody experienced this
before? Because I could not find anything regarding this issue. Thanks in
advance!
Re: Data Source Explorer shows no content under each connection profile [message #585283 is a reply to message #28244] Tue, 17 April 2007 19:17 Go to previous message
Charles Doucette is currently offline Charles DoucetteFriend
Messages: 125
Registered: July 2009
Senior Member
I have now setup Eclipse 3.2.2 with DTP 1.5M6 (plus EMF 2.2.3 and GEF 3.2.2)
as well as a separate installation of Eclipse 3.3.0M6 with DTP 1.5M6 (plus
EMF 2.3.0M6 and GEF 3.3M6).

DTP 1.5 now works fine for showing the database meta data of both MS SQL
Server 2000 and for Oracle 9.

Thanks,
Chuck

"Chuck Doucette" <cdoucette@vaultus.com> wrote in message
news:eu9fdb$bu$1@utils.eclipse.org...
>I already posted a note earlier about problems with MS SQL Server.
> Now, I performed a similar test with Oracle.
> Both connection profiles ping fine; but, neither one shows any content in
> the data source explorer.
> I am using DTP SDK 1.5M5
> on top of Eclipse SDK 3.3M5eh (for Win32).
> Should I try DTP SDK 1.5M6 instead?
>
> Also, I read something about a Data perspective.
> I don't see that in my list of other perspectives.
> I am able to set up drivers and connection profiles.
>
> Thanks,
> Chuck
>
>
Re: Data Source Explorer shows no content under each connection profile [message #585425 is a reply to message #29500] Thu, 26 April 2007 18:55 Go to previous message
John Graham is currently offline John GrahamFriend
Messages: 183
Registered: July 2009
Senior Member
Chuck,

Sorry for the late reply, and glad to see that it is working for you now.
When I read the original post, I suspected that you might have installed
just the "base" EMF (without SDO), since no DSE content and no Database
Development perspective are symptomatic of that.

Just a thought, in case you run into a similar issue as you move up the
Eclipse 3.3/DTP 1.5 milestone train.

-- John Graham
Eclipse Data Tools Platform PMC Chair

Chuck Doucette wrote:

> I have now setup Eclipse 3.2.2 with DTP 1.5M6 (plus EMF 2.2.3 and GEF 3.2.2)
> as well as a separate installation of Eclipse 3.3.0M6 with DTP 1.5M6 (plus
> EMF 2.3.0M6 and GEF 3.3M6).

> DTP 1.5 now works fine for showing the database meta data of both MS SQL
> Server 2000 and for Oracle 9.

> Thanks,
> Chuck

> "Chuck Doucette" <cdoucette@vaultus.com> wrote in message
> news:eu9fdb$bu$1@utils.eclipse.org...
>>I already posted a note earlier about problems with MS SQL Server.
>> Now, I performed a similar test with Oracle.
>> Both connection profiles ping fine; but, neither one shows any content in
>> the data source explorer.
>> I am using DTP SDK 1.5M5
>> on top of Eclipse SDK 3.3M5eh (for Win32).
>> Should I try DTP SDK 1.5M6 instead?
>>
>> Also, I read something about a Data perspective.
>> I don't see that in my list of other perspectives.
>> I am able to set up drivers and connection profiles.
>>
>> Thanks,
>> Chuck
>>
>>
Re: Data Source Explorer shows no content under each connection profile [message #585613 is a reply to message #30122] Sat, 05 May 2007 16:27 Go to previous message
JB is currently offline JBFriend
Messages: 4
Registered: July 2009
Junior Member
I'm using the 3.3M6 set and the schema node is empty for SQL Server.
Im able to connect & it shows the Catalog (i.e. MS Databases), but not
schema or tables.
Tried with MS SQL JDBC 1.1, 1.2 & JTDS.

DSE works fine with Derby.



"John Graham" <john.graham@sybase.com> wrote in message
news:97380f2bc746f2143f4005344ad1f324$1@www.eclipse.org...
> Chuck,
>
> Sorry for the late reply, and glad to see that it is working for you now.
> When I read the original post, I suspected that you might have installed
> just the "base" EMF (without SDO), since no DSE content and no Database
> Development perspective are symptomatic of that.
>
> Just a thought, in case you run into a similar issue as you move up the
> Eclipse 3.3/DTP 1.5 milestone train.
>
> -- John Graham
> Eclipse Data Tools Platform PMC Chair
>
> Chuck Doucette wrote:
>
> > I have now setup Eclipse 3.2.2 with DTP 1.5M6 (plus EMF 2.2.3 and GEF
3.2.2)
> > as well as a separate installation of Eclipse 3.3.0M6 with DTP 1.5M6
(plus
> > EMF 2.3.0M6 and GEF 3.3M6).
>
> > DTP 1.5 now works fine for showing the database meta data of both MS SQL
> > Server 2000 and for Oracle 9.
>
> > Thanks,
> > Chuck
>
> > "Chuck Doucette" <cdoucette@vaultus.com> wrote in message
> > news:eu9fdb$bu$1@utils.eclipse.org...
> >>I already posted a note earlier about problems with MS SQL Server.
> >> Now, I performed a similar test with Oracle.
> >> Both connection profiles ping fine; but, neither one shows any content
in
> >> the data source explorer.
> >> I am using DTP SDK 1.5M5
> >> on top of Eclipse SDK 3.3M5eh (for Win32).
> >> Should I try DTP SDK 1.5M6 instead?
> >>
> >> Also, I read something about a Data perspective.
> >> I don't see that in my list of other perspectives.
> >> I am able to set up drivers and connection profiles.
> >>
> >> Thanks,
> >> Chuck
> >>
> >>
>
>
Re: Data Source Explorer shows no content under each connection profile [message #585799 is a reply to message #29500] Tue, 05 June 2007 04:27 Go to previous message
Eclipse UserFriend
Originally posted by: ushakov.int.com.ru

Hi Chuck,

could you share a little bit of details for the steps that gave you luck
with MS SQL? Anything that you believe might be important?

I have the same problem you had before:
- MS SQL 2000
- sa account
- connection is ok
- the list of databases is ok
- only empty "Schemas" folders are visible
- no complaints in any logs

My configuration is similar to yours but a little bit up-to-date:
- eclipse-SDK-3.3RC3-win32
- emf-sdo-xsd-SDK-2.3.0RC2
- GEF-ALL-3.3RC2
- dtp-sdk_1.5RC2
- wtp-sdk-S-2.0RC1-200705250432
- jTDS 1.2

Thanks and regards,

Sergey


"Chuck Doucette" <cdoucette@vaultus.com> wrote in message
news:f036ge$j21$1@build.eclipse.org...
>I have now setup Eclipse 3.2.2 with DTP 1.5M6 (plus EMF 2.2.3 and GEF
>3.2.2)
> as well as a separate installation of Eclipse 3.3.0M6 with DTP 1.5M6
> (plus EMF 2.3.0M6 and GEF 3.3M6).
>
> DTP 1.5 now works fine for showing the database meta data of both MS SQL
> Server 2000 and for Oracle 9.
>
> Thanks,
> Chuck
>
> "Chuck Doucette" <cdoucette@vaultus.com> wrote in message
> news:eu9fdb$bu$1@utils.eclipse.org...
>>I already posted a note earlier about problems with MS SQL Server.
>> Now, I performed a similar test with Oracle.
>> Both connection profiles ping fine; but, neither one shows any content in
>> the data source explorer.
>> I am using DTP SDK 1.5M5
>> on top of Eclipse SDK 3.3M5eh (for Win32).
>> Should I try DTP SDK 1.5M6 instead?
>>
>> Also, I read something about a Data perspective.
>> I don't see that in my list of other perspectives.
>> I am able to set up drivers and connection profiles.
>>
>> Thanks,
>> Chuck
>>
>>
>
>
Re: Data Source Explorer shows no content under each connection profile [message #586982 is a reply to message #31154] Thu, 02 August 2007 16:55 Go to previous message
Bill Middleton is currently offline Bill MiddletonFriend
Messages: 1
Registered: July 2009
Junior Member
I'm having the identical problem when accessing MS SQL Server 8 with
jTDS... The catalog of databases displays fine in Data Source Explorer,
but the databases show only empty Schema folders.
Re: Data Source Explorer shows no content under each connection profile [message #588139 is a reply to message #31154] Tue, 09 October 2007 18:22 Go to previous message
Eclipse UserFriend
Originally posted by: ddumaresq.bccampus.ca

Alas, I am yet another who cannot view content under the MS SQL Server
database connection. My database only shows "Catalogs", database instance
names and "Schemas" - no tables, views, etc. I would like to browse a SQL
Server 2000 database and would appreciate any help. Here are some details of
how I've set things up:

My initial creation of the driver details for SQL Server was a little messy
and I did not have all the requirements as stated on
http://www.eclipse.org/datatools/downloads.html I now meet those
requirements. I`m running on Windows Vista platform with JRE (build
1.6.0-oem-b104).

To create a new connection, I select a new Generic JDBC Connection. This
allows me to select the driver for Microsoft SQL Server 2000 for JDBC.
I must provide the paths to the jars (msbase.jar, mssqlserver.jar,
msutil.jar) and other driver details. Interestingly, the default driver
class (com.microsoft.jdbc.sqlserver.SQLServerDriver) is hardcoded in the
database driver properties dialog. There is no way to select available
classes from the included jars... I would have liked to do this as a sanity
check.

The Connection Driver Version information shows:
`Microsoft SQL Server: 0.0.0.2 (Build 3790: ) The following technologies are
available on this server: JDBC: unknown`
I have the latest driver (SP3) from the microsoft site, but I don't think
the build number here has changed with SP3.

Well, I'll move on with something else for now... Any help is appreciated!

Regards,
Dave

"Bill Middleton" <bill_middleton@yahoo.com> wrote in message
news:d1edbf6a330a981ca94c9bf23af5e10e$1@www.eclipse.org...
> I'm having the identical problem when accessing MS SQL Server 8 with
> jTDS... The catalog of databases displays fine in Data Source Explorer,
> but the databases show only empty Schema folders.
>
Re: Data Source Explorer shows no content under each connection profile [message #588143 is a reply to message #30122] Wed, 10 October 2007 11:02 Go to previous message
Udo Walker is currently offline Udo WalkerFriend
Messages: 67
Registered: July 2009
Member
John,
I can't find out what is wrong with my eclipse installation. As I see I
should have actual downloads for Eclipse 3.3: DTP 1.5.1, EMF 2.4 0M2 with
SDO, and GEF 3.3.1
In my Data Source Explorer View I do not get any ODA Data Sources, but I
do have Databases with JDBC Connections to Derby, MySQL an Oracle. I can
ping and connect to all of them, but do not get any more information in a
tree or whatever.
I do not know what is the mistake.
Re: Data Source Explorer shows no content under each connection profile [message #588157 is a reply to message #37128] Thu, 11 October 2007 08:20 Go to previous message
Udo Walker is currently offline Udo WalkerFriend
Messages: 67
Registered: July 2009
Member
Hm, unfortunately I did not see any remark showing that Eclipse classic is
not enough, after downloading the eclipse for Java Developers' stuff, I
get contents.
Re: Data Source Explorer shows no content under each connection profile [message #588250 is a reply to message #37162] Thu, 25 October 2007 08:17 Go to previous message
Eclipse UserFriend
Originally posted by: yourspamhere.hotmail.com

Udo, I think your problem was related to the JVM you were using (1.5 is
required for the last versions of EMF) and not to the Java Development
stuff.

Anyways, I got more or less the same problem but just with the ODA Data
Sources, this is, the database connections work as expected but when I
create a connection to a flat file data source, for example, it works and
I can ping and whatnot but when connected the node does not expand, so no
files or tables or whatever are shown. Has anybody experienced this
before? Because I could not find anything regarding this issue. Thanks in
advance!
Previous Topic:Looking for 1.5.1 version
Next Topic:DDL Generator for Postgres
Goto Forum:
  


Current Time: Mon Dec 22 14:18:13 GMT 2014

Powered by FUDForum. Page generated in 0.03033 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software