Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » DSDP - Native Application Builder (NAB) » WideStudio build fails on Linux
WideStudio build fails on Linux [message #231] Tue, 27 February 2007 18:30 Go to next message
Eclipse UserFriend
Originally posted by: keyanema.aol.com

Hi,

I am new to NAB and Widestudio. I have downloaded the widestudio 3.96
sources avaiable at NAB downloads. But I am unable to build the
Widestudio on Linux x86 machine. The errors that I come across is related
to "lwsx11".

When I run "make" the build fails giving error stating that lwsx11 library
is not found. Can someone let me know from where can I get this library?
I tried googling for this library but I found one corresponding to an
earlier release of Widestudio 3.0 or something. The problem is not
getting solved with that too.

Please let me know if this a known issue and how can I build the
Widestudio successfully.

Thanks & Regards,
Keya
Re: WideStudio build fails on Linux [message #241 is a reply to message #231] Thu, 01 March 2007 10:38 Go to previous message
Eclipse UserFriend
Originally posted by: keyanema.aol.com

Hi,

I got the problem solved. The issue was with "libxt" library that was not
installed on my machine.
Once that package was available to the Widestudio it got compiled properly.

Here are the steps that I was suggested ( on the Widestudio users mailing
list ) to follow in order to solve the build issue:

Check the dynamic linking library: ws/lib/libwsx11.so.3.96.
If there is no libwsx11.so.3.96,
check the building process of ws-v3.96-1/src/x11
by the following operation:

Operation:
$ cd ws-v3.96-1/src/x11
$ make runtime

Regards,
Keya


Keya wrote:

> Hi,

> I am new to NAB and Widestudio. I have downloaded the widestudio 3.96
> sources avaiable at NAB downloads. But I am unable to build the
> Widestudio on Linux x86 machine. The errors that I come across is related
> to "lwsx11".

> When I run "make" the build fails giving error stating that lwsx11 library
> is not found. Can someone let me know from where can I get this library?
> I tried googling for this library but I found one corresponding to an
> earlier release of Widestudio 3.0 or something. The problem is not
> getting solved with that too.

> Please let me know if this a known issue and how can I build the
> Widestudio successfully.

> Thanks & Regards,
> Keya
Re: WideStudio build fails on Linux [message #568911 is a reply to message #231] Thu, 01 March 2007 10:38 Go to previous message
Keya is currently offline KeyaFriend
Messages: 13
Registered: July 2009
Junior Member
Hi,

I got the problem solved. The issue was with "libxt" library that was not
installed on my machine.
Once that package was available to the Widestudio it got compiled properly.

Here are the steps that I was suggested ( on the Widestudio users mailing
list ) to follow in order to solve the build issue:

Check the dynamic linking library: ws/lib/libwsx11.so.3.96.
If there is no libwsx11.so.3.96,
check the building process of ws-v3.96-1/src/x11
by the following operation:

Operation:
$ cd ws-v3.96-1/src/x11
$ make runtime

Regards,
Keya


Keya wrote:

> Hi,

> I am new to NAB and Widestudio. I have downloaded the widestudio 3.96
> sources avaiable at NAB downloads. But I am unable to build the
> Widestudio on Linux x86 machine. The errors that I come across is related
> to "lwsx11".

> When I run "make" the build fails giving error stating that lwsx11 library
> is not found. Can someone let me know from where can I get this library?
> I tried googling for this library but I found one corresponding to an
> earlier release of Widestudio 3.0 or something. The problem is not
> getting solved with that too.

> Please let me know if this a known issue and how can I build the
> Widestudio successfully.

> Thanks & Regards,
> Keya
Previous Topic:WideStudio build fails on Linux
Next Topic:WideStudio build fails on Windows
Goto Forum:
  


Current Time: Sun Dec 21 00:30:09 GMT 2014

Powered by FUDForum. Page generated in 0.01713 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software